Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco Port-Channels Won't Come Up

Hello Experts,

Can some please take at the attached configs and help me determine why I can't get the port channels to come up the switches.?

Cheers

Carlton

15 REPLIES

Re: Cisco Port-Channels Won't Come Up

Carlton,

I may not be seeing it, but I only see one side on DLS1 where you posted the interface configs. Can you post the interface configs on DLS2? Also, you'll need to configure the switchports that are part of the trunk as L3 as well with "no switchport".

John

Please rate helpful posts...

HTH, John *** Please rate all useful posts ***
New Member

Re: Cisco Port-Channels Won't Come Up

Hi Blakely,

Please find attached configs again.....

Re: Cisco Port-Channels Won't Come Up

Can you post "sh etherchannel detail" from both switches.

HTH, John *** Please rate all useful posts ***
New Member

Re: Cisco Port-Channels Won't Come Up

DLS1#show etherchan detail

                Channel-group listing:

                -----------------------

Group: 1

----------

Group state = L3

Ports: 2   Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol:   LACP

Minimum Links: 0

                Ports in the group:

                -------------------

Port: Et2/0

------------

Port state    = Down Not-in-Bndl

Channel group = 1           Mode = Active      Gcchange = -

Port-channel  = null        GC   =   -         Pseudo port-channel = Po1

Port index    = 0           Load = 0x00        Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.

        A - Device is in active mode.        P - Device is in passive mode.

Local information:

                            LACP port     Admin     Oper    Port        Port

Port      Flags   State     Priority      Key       Key     Number      State

Et2/0     SA      down      32768         0x1       0x0     0x201       0x45 

Age of the port in the current state: 0d:00h:40m:17s

Port: Et2/1

------------

Port state    = Down Not-in-Bndl

Channel group = 1           Mode = Active      Gcchange = -

Port-channel  = null        GC   =   -         Pseudo port-channel = Po1

Port index    = 0           Load = 0x00        Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.

        A - Device is in active mode.        P - Device is in passive mode.

Local information:

                            LACP port     Admin     Oper    Port        Port

Port      Flags   State     Priority      Key       Key     Number      State

Et2/1     SA      down      32768         0x1       0x0     0x202       0x45 

Age of the port in the current state: 0d:00h:40m:17s

                Port-channels in the group:

                ----------------------

Port-channel: Po1    (Primary Aggregator)

------------

Age of the Port-channel   = 0d:00h:19m:38s

Logical slot/port   = 16/1          Number of ports = 0

HotStandBy port = null

Passive port list   = Et2/0 Et2/1

Port state          = Port-channel L3-Ag Ag-Not-Inuse

Protocol            =   LACP

Port security       = Disabled

Fast-switchover     = disabled

Load share deferral = disabled  

DLS2#show etherchan detail

                Channel-group listing:

                -----------------------

Group: 1

----------

Group state = L3

Ports: 2   Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol:   LACP

Minimum Links: 0

                Ports in the group:

                -------------------

Port: Et2/0

------------

Port state    = Down Not-in-Bndl

Channel group = 1           Mode = Active      Gcchange = -

Port-channel  = null        GC   =   -         Pseudo port-channel = Po1

Port index    = 0           Load = 0x00        Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.

        A - Device is in active mode.        P - Device is in passive mode.

Local information:

                            LACP port     Admin     Oper    Port        Port

Port      Flags   State     Priority      Key       Key     Number      State

Et2/0     SA      down      32768         0x1       0x0     0x201       0x45 

Age of the port in the current state: 0d:00h:39m:55s

Port: Et2/1

------------

Port state    = Down Not-in-Bndl

Channel group = 1           Mode = Active      Gcchange = -

Port-channel  = null        GC   =   -         Pseudo port-channel = Po1

Port index    = 0           Load = 0x00        Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.

        A - Device is in active mode.        P - Device is in passive mode.

Local information:

                            LACP port     Admin     Oper    Port        Port

Port      Flags   State     Priority      Key       Key     Number      State

Et2/1     SA      down      32768         0x1       0x0     0x202       0x45 

Age of the port in the current state: 0d:00h:39m:55s

                Port-channels in the group:

                ----------------------

Port-channel: Po1    (Primary Aggregator)

------------

Age of the Port-channel   = 0d:00h:19m:38s

Logical slot/port   = 16/1          Number of ports = 0

HotStandBy port = null

Passive port list   = Et2/0 Et2/1

Port state          = Port-channel L3-Ag Ag-Not-Inuse

Protocol            =   LACP

Port security       = Disabled

Fast-switchover     = disabled

Load share deferral = disabled  

DLS2#

DLS2#

Re: Cisco Port-Channels Won't Come Up

Did you create the port channel interface manually or was it created for you? I think things need to be recreated. Try deleting your PO interfaces and start from scratch. I don't see anything glaringly wrong in the config.

Can you post from DLS1:

sh int eth2/0 switchport

sh int eth2/1 switchport

and the same for the channel-group ports on DLS2?

HTH, John *** Please rate all useful posts ***
New Member

Re: Cisco Port-Channels Won't Come Up

HI Blakely,

It was created for me.

Re: Cisco Port-Channels Won't Come Up

Can you post from DLS1:

sh int eth2/0 switchport

sh int eth2/1 switchport

and the same for the channel-group ports on DLS2?

HTH, John *** Please rate all useful posts ***
Bronze

Re: Cisco Port-Channels Won't Come Up

I believe you need to add the command "no switchport" to both of the Port-Channel interfaces (on both sides).

New Member

Re: Cisco Port-Channels Won't Come Up

Hi Blakely

I created in a new channel-group and deleted the port-channel automatically and recreated it, however the new channel-port wouldn't come up.

Hall of Fame Super Gold

Cisco Port-Channels Won't Come Up

Errr ... I must be getting blind.  In DLS2, I don't see what ports are members of your EtherChannel.

Re: Cisco Port-Channels Won't Come Up

Carlton,

I'm confused. The first configs that you posted had the interface configurations listed in active mode, but these configurations don't show anything listed at all.

!

interface Port-channel1

ip address 172.16.1.1 255.255.255.252

!

interface Port-channel2

ip address 150.50.5.1 255.255.0.0

!

interface Ethernet0/0

no ip address

shutdown

duplex auto

!

interface Ethernet0/1

no ip address

shutdown

duplex auto

!

interface Ethernet0/2

no ip address

shutdown

duplex auto

!

interface Ethernet0/3

no ip address

shutdown

duplex auto

!

interface Ethernet1/0

switchport

switchport access vlan 100

duplex auto

!

interface Ethernet1/1

no ip address

shutdown

duplex auto

!

interface Ethernet1/2

no ip address

shutdown

duplex auto

!

interface Ethernet1/3

no ip address

shutdown

duplex auto

!

interface Ethernet2/0

no ip address

duplex auto

!

interface Ethernet2/1

no ip address

duplex auto

!

interface Ethernet2/2

no ip address

shutdown

duplex auto

!

interface Ethernet2/3

no ip address

shutdown

duplex auto

!

interface Ethernet3/0

no ip address

shutdown

duplex auto

!

interface Ethernet3/1

no ip address

shutdown

duplex auto

!

interface Ethernet3/2

no ip address

shutdown

duplex auto

!

interface Ethernet3/3

no ip address

shutdown

duplex auto

!

interface Vlan1

no ip address

shutdown

!

interface Vlan100

You don't have any ports configured on this switch according to this config.

HTH, John *** Please rate all useful posts ***
Purple

Cisco Port-Channels Won't Come Up

  What kind of switches are these where you only have 4 ports in a slot ?

New Member

Re: Cisco Port-Channels Won't Come Up

Blakely

DLS2#show ver

Cisco IOS Software, Linux Software (LINUXL2-UPK9-M), Experimental Version 12.2(20100802:165548) [mtimm-mtrosel2iol 102]

Copyright (c) 1986-2010 by Cisco Systems, Inc.

Compiled Mon 02-Aug-10 10:05 by mtimm

ROM: Bootstrap program is Linux

DLS2 uptime is 15 minutes

System returned to ROM by reload at 0

System image file is "unix:/home/iou/herebedragons/ins1019/i86bi_linuxl2-upk9-ms"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Linux Unix (Intel-x86) processor with 138728K bytes of memory.

Processor board ID 2048196

16 Ethernet interfaces

128K bytes of NVRAM.

Configuration register is 0x0

DLS2#

Re: Cisco Port-Channels Won't Come Up

Is this an emulator? I can't help you with this...I'm not even sure what it supports. This is IOU (IOS on Unix) and I've never played around with it. Glen made a good call by noticing the port count; something I didn't notice. The configuration itself is straightforward for L3 EC. Just make sure that the switchport is converted to a routed port.

HTH, John *** Please rate all useful posts ***
New Member

Re: Cisco Port-Channels Won't Come Up

Thanks for your comments chaps...

I reconfigured the devices again. They are definitely configured witn no swithchport.... Please check out the new configs if you have a spare moment..

2631
Views
0
Helpful
15
Replies
CreatePlease to create content