Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Cisco SG300 HOSTP_flash_operation: fatal error during read operation!

I have 2 Cisco SG300-52P switches.   Earlier this week, one of them started dropping connections and POE was not working on a couple of devices...  I came in this morning to restart them when no one else was around. After restarting them, the troublesome one was still not detecting POE devices.  

I have been waiting for some down time to do a firmware update, so I thought this might straighten things out.  I Downloaded the updated bootloader and firmware from Cisco's site.  Updating the (non-problem) SG300 went exactly as it should.  Upgrading the the bootloader on the problem SG300 went exactly as it should.  Started the firmware update on the problem switch ....... and it didn't come back online.  The power light was flashing, and occasionally the lights on ports would blink like they were trying to reset, but they never made it.   There weren't really any special configurations on this switch so I had nothing to lose by trying a factory reset via the pinhole on the front ...... same result.

I connected to the serial port via a win7 PC with putty. .. All setting per Cisco. I got a message that the connection was detected, but it would not accept keyboard input.  I power cycled the SG300 and watched the messages go by ... It looked like everything was working.  I even got a message that the "Initialization task was completed"..

Then this message "HOSTP_flash_operation: fatal error during read operation!"

We have had a couple of internet and power outages recently, but I am trying to rule out other issues before blaming it on that. 

any suggestions?

putty output file attached

Everyone's tags (1)
2 REPLIES
VIP Super Bronze

I am not familiar with SG

I am not familiar with SG series products, but looking at the error message in the attached file, it appears there is an issue with reading from the flash.  It could be that the flash file is corrupted and the flash needs to be formatted and then reload the software again.

If you have support contract on the product, I would suggest you open a TAC ticket with Cisco and have them help you.

HTH

Community Member

Reza,That's what I suspected

Reza,

That's what I suspected as well.  I did try to reload the software via xmodem.  Loading the current version of the firmware (v1.3.7.18) failed even when I slowed the port speed down to 19200.  So I tried doing back to an earlier version   (v1.3.0.62)  the download appeared successful, but I still got a FATAL ERROR when the switch rebooted.    See the attached file

213
Views
0
Helpful
2
Replies
CreatePlease to create content