Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco VRF Route leak

I have 2 switches (Core sw, Access sw) which I have set up. VRF has been set up on the Core sw with Access switch connected to it. Now, I am trying to ping from the access switch to a network outside the VRF zone which the access switch is in. But it seems like it just won't work unless route leakage has been configured. I have done it, but it just wouldn't work for me. Following and attached contains my configuration. Would appreciate all the help. Thanks.

Description:

1. VRF "ClientA" set up on core switch

2. Gi1/0/2 (192.168.1.1/24) was configured as part of VRF "ClientA"

3. Loopback1 interface on core switch has been configured with an IP of 192.168.2.1/24 (Lo1)

4. An access switch has been configured - Gi1/0/14 (192.168.1.2/24).

5. Switch port of Gi1/0/2 is linked up to Gi1/0/14 via ethernet cable

Problem :

Unable to ping 192.168.2.1 on access switch

Question:

What is the proper method to perform route leakage from the VRF zone "ClientA" to Global routing table

Switch configuration:

Core sw

ip classless

ip vrf clientA

rd 100:110

route-target export 100:110

route-target import 100:110

interface GigabitEthernet1/0/2

description 192.168.1.2

no switchport

ip vrf forwarding clientA

ip address 192.168.1.2 255.255.255.0

end

interface Loopback1

description LoopBack interface for ClientA VRF

ip address 192.168.2.1 255.255.255.0

end

interface GigabitEthernet1/0/3

description 192.168.2.1

no switchport

no ip address

end

ip route 192.168.1.0 255.255.255.0 GigabitEthernet1/0/2

ip route vrf clientA 192.168.2.0 255.255.255.0 Loopback1

Access switch

ip classless

interface GigabitEthernet1/0/14

description TestVRF1

no switchport

ip address 192.168.1.1 255.255.255.0

end

3 REPLIES
Cisco Employee

Re: Cisco VRF Route leak

Try adding a vrf static route on the access switch for 192.168.2.0/24 with a next hop of 192.168.1.2.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Re: Cisco VRF Route leak

your gateway should be a gateway within the vrf.

use the ip address under GigabitEthernet1/0/2 because GigabitEthernet1/0/2 is forwarding the the vrf. ip is 192.168.1.2

see this http://www.cisco.com/en/US/tech/tk436/tk832/technologies_configuration_example09186a0080231a3e.shtml

New Member

Re: Cisco VRF Route leak

Hi,

Thought the VRF static routes are only added to the core switch.

Anyway, what I tried on the access switch is :

ip route 192.168.2.0 255.255.255.0 192.168.1.2

Apparently, the above does not work. I tried to ping the loopback interface, but am still having issues.

854
Views
0
Helpful
3
Replies
CreatePlease to create content