Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cisco877 proxyDNS intermittent problem

Hi all

I was hoping someone would be able to shed some light on my current problem.

Got a Cisco 877W up and running on a PPPoE ADSL2+ connection with my ISP.

Router is set up as proxyDNS and the local workstations are configured to use the router as both gateway and DNS via DHCP.

After a router reboot everything is working as expected, however after 1 to 6 hours DNS resolution from the locally connected workstations (Windows 7 and other devices) stops working. I am fairly confident the problem is with the router (perhaps IOS), because if I change the DHCPs DNS server entries to my ISP DNS it works. If I change DNS to the router IP, resolution eventually fails. In other words:

THIS ALWAYS WORK

ip dhcp pool DHCP_LAN

   dns-server 111.118.175.56 (ISP DNS)

THIS WORK FOR A WHILE, BUT EVENTUALLY FAILS

ip dhcp pool DHCP_LAN

   dns-server 192.168.50.3 (Router IP)

Troubleshooting examples from Router & Workstation + Router config provided below.

Any feedback is highly appreciated.

RUNNING CONFIGURATION

Current configuration : 4108 bytes

!

version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug uptime

service timestamps log uptime

service password-encryption

service sequence-numbers

!

hostname 877gateway.org

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

dot11 ssid 877-WiFi

   authentication open

   authentication key-management wpa

   guest-mode

   wpa-psk ascii "removed"

!

ip cef

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.50.1 192.168.50.10

!

ip dhcp pool DHCP_LAN

   import all

   network 192.168.50.0 255.255.255.0

   dns-server 192.168.50.3

   default-router 192.168.50.3

!

ip dhcp pool QNAP219

   host 192.168.50.9 255.255.255.0

   client-identifier "removed"

!

ip dhcp pool X58A_N1

   host 192.168.50.51 255.255.255.0

   client-identifier "removed"

!

ip dhcp pool X58A_N2

   host 192.168.50.52 255.255.255.0

   client-identifier "removed"

!

ip name-server 111.118.175.56

ip name-server 118.127.33.48

!

multilink bundle-name authenticated

!

username "removed" privilege 15 password "removed"

archive

log config

  hidekeys

!

bridge irb

!

interface ATM0

no ip address

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

no snmp trap link-status

pvc 8/35

  pppoe-client dial-pool-number 1

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Dot11Radio0

no ip address

ip route-cache flow

!

encryption mode ciphers tkip

!

ssid 877-WiFi

!

speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

no ip address

ip route-cache flow

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dialer0

ip address negotiated

ip access-group 101 in

no ip redirects

no ip unreachables

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

no cdp enable

ppp pap sent-username "removed" password "removed"

ppp ipcp dns request

ppp ipcp route default

!

interface BVI1

ip address 192.168.50.3 255.255.255.0

ip access-group 102 in

ip nat inside

ip virtual-reassembly

ip route-cache flow

ip tcp adjust-mss 1452

!

ip flow-cache timeout active 1

ip flow-export source Vlan1

ip flow-export version 9

ip flow-export destination 192.168.50.53 2048

!

no ip http server

no ip http secure-server

ip dns server

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 permit any

access-list 101 permit ip any any

access-list 102 permit ip any any

dialer-list 1 protocol ip permit

snmp-server community public RO

snmp-server ifindex persist

!

control-plane

!

bridge 1 route ip

!

line con 0

exec-timeout 0 0

logging synchronous

no modem enable

line aux 0

line vty 0 4

exec-timeout 0 0

password "removed"

logging synchronous

login local

!

scheduler max-task-time 5000

!

webvpn cef

end

ROUTER TROUBLESHOOTING

Show Version


ROM: System Bootstrap, Version 12.3(8r)YI2, RELEASE SOFTWARE

877gateway.org uptime is 16 hours, 57 minutes

System returned to ROM by reload

System image file is "flash:c870-adventerprisek9-mz.124-15.T.bin"

Cisco 877W (MPC8272) processor (revision 0x200) with 118784K/12288K bytes of memory.

DNS test from router (DNS always working from router)

877gateway.org#ping google.com

Translating "google.com"...domain server (111.118.175.56) [OK]

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 74.125.237.131, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/44/60 ms

877gateway.org#tracer google.com

Type escape sequence to abort.

Tracing the route to google.com (74.125.237.131)

  1 "removed"

  2 "removed"

  3 "removed"

  4 "removed"

  5 202.7.171.46 48 msec 52 msec 28 msec

  6 66.249.95.234 36 msec 112 msec 52 msec

  7 72.14.237.137 36 msec 28 msec 36 msec

  8 google.com (74.125.237.131) 32 msec 48 msec 28 msec

877gateway.org#

WORKSTATION (WIN7) TROUBLESHOOTING

Ethernet adapter "Local Area Connection" on PC

IPv4 Address

: 192.168.50.51(Preferred)

Subnet Mask

: 255.255.255.0

Default Gateway

: 192.168.50.3

DHCP Server

: 192.168.50.3

DNS Servers

: 192.168.50.3

NetBIOS over Tcpip

: Enabled

DNS troubleshooting from workstation (DNS stops working after a while)

C:\>ping -n 2 google.com

Ping request could not find host google.com. Please check the name and try again

.

C:\>tracert -d google.com

Unable to resolve target system name google.com.

C:\>nslookup

DNS request timed out.

    timeout was 2 seconds.

Default Server:  UnKnown

Address:  192.168.50.3

> server 192.168.50.3

Default Server:  [192.168.50.3]

Address:  192.168.50.3

> google.com

Server:  [192.168.50.3]

Address:  192.168.50.3

DNS request timed out.

    timeout was 2 seconds.

DNS request timed out.

    timeout was 2 seconds.

DNS request timed out.

    timeout was 2 seconds.

DNS request timed out.

    timeout was 2 seconds.

*** Request to [192.168.50.3] timed-out

>

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Cisco877 proxyDNS intermittent problem

Hi,

Can you do a packet capture on the router WAN and LAN interfaces when working and when failing as well at look at the dns cache with sh  hosts command on the router

For packet capture use this:http://routerjockey.com/2011/02/14/ios-embedded-packet-capture/

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
5 REPLIES

Cisco877 proxyDNS intermittent problem

hi,

could you add the ip domain-lookup command and try again?

New Member

Re: Cisco877 proxyDNS intermittent problem

Thanks for the suggestion, I already did.

Interesting part is, it's not showing up in the running-config but it is enabled. If I do a "no ip domain lookup" it shows.

Entry from running config with "ip domain lookup" enabled

!

!

ip name-server 111.118.175.56

ip name-server 118.127.33.48

!

multilink bundle-name authenticated

Entry from running config "ip domain lookup" not enabled

!

!

no ip domain lookup

ip name-server 111.118.175.56

ip name-server 118.127.33.48

!

multilink bundle-name authenticated

Unfortunately I already tested with this command enabled/not enabled and did reboots, but this is not the cause of my problem.

Even my monitoring software is indicating a problem with the routers DNS service

Perhaps someone knows the relevant debug commands I could use to troubleshoot router dns?

Purple

Cisco877 proxyDNS intermittent problem

Hi,

Can you do a packet capture on the router WAN and LAN interfaces when working and when failing as well at look at the dns cache with sh  hosts command on the router

For packet capture use this:http://routerjockey.com/2011/02/14/ios-embedded-packet-capture/

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Re: Cisco877 proxyDNS intermittent problem

Hi Alain

I hit the "Correct Answer" button by mistake, is there anyway I can undo that to not mark my question answered?

Regarding your link, it says:

Since IOS 12.4(20)T Cisco has made Embedded Packet Capture

My current IOS version is:

System image file is "flash:c870-adventerprisek9-mz.124-15.T.bin

877gateway.org#monitor ?

  event-trace  Control event tracing

  processes    Monitor processes

I think I have a newer IOS version available and I migth do an update, since I am eager to find out what is causing this problem.

Anyway appreciate the feedback. I will get back to you when I have some solid info.

Purple

Cisco877 proxyDNS intermittent problem

Hi,

if EPC is not supported on your image then you can do RITE:http://www.cisco.com/en/US/docs/ios/12_4t/12_4t11/ht_rawip.html

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
970
Views
0
Helpful
5
Replies
CreatePlease to create content