Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

CISOC 3524 XL VLAN CONFIG

Hello i am trying to setup vlans. am i am stuck will this config work. vlan1 is getting dhcp from win 2008 server and vlan 2 from trixbox dhcp. do i need the dhcp help in the vlan 2. ip helper-address XXX.XXX.XXX

ALSO WHAT EXACTLY PLUGS INTO THE ACCESS PORTS THE DHCP SERVERS ??

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

!

!

!

!

!

!

ip subnet-zero

!

!

!

interface FastEthernet0/1

description DATA ACCESS

!

interface FastEthernet0/2

description VOICE ACCESS

switchport access vlan 2

!

interface FastEthernet0/3

description PHONE AND PCS

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,1002-1005

switchport mode trunk

switchport voice vlan 2

!

interface FastEthernet0/4

description PHONE AND PCS

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,1002-1005

switchport mode trunk

switchport voice vlan 2

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface VLAN1

description DATA INCOMING

ip address 192.168.0.140 255.255.255.0

no ip directed-broadcast

no ip route-cache

!

interface VLAN2

description VOICE INCOMING

ip address 10.10.10.1 255.255.254.0

ip helper-address 192.168.0.5

no ip directed-broadcast

no ip route-cache

shutdown

!

!

line con 0

transport input none

stopbits 1

line vty 5 15

!

end

Everyone's tags (4)
5 REPLIES
Cisco Employee

CISOC 3524 XL VLAN CONFIG

Hi Jarvis,

No, you do not need to use the ip helper-address command - in fact, it is counterproductive to use it here. This command is intended to be used on routers that connect the appropriate VLAN to the rest of network. It should not be used on switches that do not perform inter-VLAN routing.

In your case, if you want each VLAN to be served by a different DHCP server, simply make sure that the appropriate DHCP server is connected to an access port placed into the corresponding VLAN.

Best regards,

Peter

Purple

Re: CISOC 3524 XL VLAN CONFIG

  Be aware that a 3524xl is a layer 2 only switch .  It looks like you are trying to setup routing on this switch and you cannot. You can only have 1 active SVI on this switch and that is strictly for switch management and nothing else.  You are going to have to do your layer 3 routing on a different device.

  Delete one of your SVI's that is not being used to manage the switch .       

New Member

CISOC 3524 XL VLAN CONFIG

What do i need to do to fix this.  vlan 2 is shutdown and won go no shut bc u can only have one active. . I understand that only 1 vlan will go active with this switch..

New Member

Re: CISOC 3524 XL VLAN CONFIG

Layout of network is as follows

trixbox DHCP -------10.10.10.8/255.255.254.0-----------------C3524 SWITCH PWR

WIN2008R2 DHCP/DNS-----192.168.0.5 255.255.255.0------------------------------TO SWITCH ABOVE

CISCO 1841----192.168.0.250/DNS GOES TO 192.168.0.5 ALL PHONES USE THIS GATEWAY------------------TO SWITCH ABOVE

PFSENSE FIREWALL/ROUTER TO WEB FOR PC'S THEY USE GATEWAY 192.168.0.1

SO THE DHCP SERVERS SHOULD BE IN FA01=WIN SVR 2008 AND FA02 GOES TO TRIXBOX DHCP=

THEN EACH PC/ PHONE WILL PLUG INTO FA0/4-----FA0/24.

I AM CONFUSED ON WHAT I NEED TO DO TO GET THIS TO WORK..

I WILL HAVE MULITPLE SWICHES ON THE NETWORK MABYE 3.

STARTING FROM WIREING CLOSET TO 5TH FLOOR.

I TRIED PLUGGING IN THE FA0/1 TO NETWORK AND PLUGGED A PC INTO IT AND IT GOT A IP BUT WHEN I PLUGGED A PHONE INTO IT IT GOT A IP FROM THE WIN2008 SVR. IT SHOWS IT  WENT TO VLAN 2(VOICE)..

ANY HELP IS HELPFUL

THANKS,

New Member

Re: CISOC 3524 XL VLAN CONFIG

Here is my config layed out.

I  think i may have to use router on a stick but i have to use two dhcp servers. Or i could use one what do u guys suggest.

862
Views
0
Helpful
5
Replies
CreatePlease to create content