Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Client can ping up to router but not beyond.

I am trying to connect a couple of clients to the internet but the problem is that they can ping the vlan of the ehwic card of the router but not the actual wan port and beyond that thus not getting a internet connection.

Any thoughts?

Everyone's tags (4)
8 REPLIES

Below is the config you can

Below is the config you can paste into your devices that should make it work.

==Router
no ip route 0.0.0.0 0.0.0.0 Vlan1
no ip route 0.0.0.0 0.0.0.0 Vlan2
!
ip route 0.0.0.0 0.0.0.0 77.160.176.32
!
interface g0/0
ip nat outside
!
interface vlan 1
ip nat inside
!
interface vlan 2
ip nat inside
!
ip access-list standard NAT
 permit 192.168.10.0 0.0.0.255
 permit 10.1.10.0 0.0.0.255
!
ip nat inside source list NAT interface g0/0 overload
!
==Switch
no ip default-gateway 77.160.176.32
ip default-gateway 192.168.10.1
!If VLAN2 is needed on switch for example:
!vlan 2 
!interface fa0/2
!switchport access vlan 2

New Member

The ip route won't work

The ip route won't work because it's the router itself. Also, why is the access list mask 0.0.0.255 and not 255.255.255.0?

My mistake. I meant to put

My mistake. I meant to put after the ip route change this to whatever your ISP default gateway is. The interface in your config is set to 255.0.0.0 which could be anything. Typically you would get a /30 from a provider unless they are handing out single IP addresses from a larger block. On the ACL part it takes wildcard masks which is why I used 0.0.0.255. If you can figure out your ISP gateway and enter that in as the ip route statement then it should work no problem.

New Member

Thanks for the help so far!

Thanks for the help so far! The switch can now ping outside the router but there is still one problem. The clients can't even ping to the router atm, they can to the switch though. The router is able to ping everything on our network and the switch too, but it seems if the clients can't get through the switch, any ideas?

 

So clients are on the switch

So clients are on the switch and can't ping the router? Are they on vlan 1 or 2? If vlan 2 then you will need to add it to the vlan database and configure the port for access vlan 2.
New Member

They are on vlan 1, that's

They are on vlan 1, that's the strange part about it.

If you do sh ip interface br

If you do sh ip interface br on the switch does it show vlan 1 as admin down?
New Member

No, that certainly is not the

No, that certainly is not the problem.

2899
Views
0
Helpful
8
Replies
CreatePlease to create content