Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Complete novice queston.

This is the config of a router I have inherited and am scratching to understand as quickly as possible.

Yes I have no experience with routers......... A machine connected with a crossover into nterface FastEthernet0/1 gets a 192 address from the pool.

interface FastEthernet0/0 I do not understand.

Are you are to help me out here?

R1#show config

Using 1347 out of 29688 bytes

!

version 12.4

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.0.1 192.168.0.10

!

ip dhcp pool THEIPPOOL

   network 192.168.0.0 255.255.255.0

   default-router 192.168.0.1

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

!

interface FastEthernet0/0.10

 encapsulation dot1Q 10

 ip address 172.16.10.1 255.255.255.0

!

interface FastEthernet0/0.20

 encapsulation dot1Q 20

 ip address 172.16.20.1 255.255.255.0

 ip helper-address 172.16.10.10

!

interface FastEthernet0/0.30

 encapsulation dot1Q 30

 ip address 172.16.30.1 255.255.255.0

 ip helper-address 172.16.10.10

!

interface Serial0/0

 no ip address

 shutdown

 no fair-queue

!

interface FastEthernet0/1

 ip address 192.168.0.1 255.255.255.0

 duplex auto

 speed auto

!

interface Serial0/1

 no ip address

 shutdown

!

interface Serial0/2

 no ip address

 shutdown

!

ip forward-protocol nd

!

ip http server

no ip http secure-server

!

!

!

control-plane

!

!

!

!

line con 0

line aux 0

line vty 0 4

 login

 transport input none

!

!

end

 

R1#

  • LAN Switching and Routing
2 REPLIES
New Member

The physical FastEthernet 0/0

The physical FastEthernet 0/0 has been configured provide layer 3 interfaces on an 802.1Q trunk connection for the VLANs 10, 20 and 30.

This is probably connected to a trunk port on a layer 2 switch with those 3 vlans configured and will allow routing between the VLANs.

Super Bronze

As cmcclinton has already

As cmcclinton has already noted, FastEthernet 0/0 appears to be configured to work with .1Q VLAN tagged frames.  On a Cisco switch, such a port would be usually configured with access-mode trunk.  On a Cisco router, such a port is configured using subinterfaces, with the interface name's .# suffix indicating the subinterface identification.  BTW, the subinterface identification number doesn't need to match the VLAN tag, but it's good practice to do so.

Also BTW, the main interface could also have an IP address.  If it did, it would deal with untagged frames, the "native" VLAN, for a Cisco switch port.

24
Views
0
Helpful
2
Replies