Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

config replace issue

I am trying to use copy replace but getting "%The input file is not a valid config file." errror message on ASR1001 platform.

following is the config i am trying to replace (saved as test-config)

 

hostname ABC-01
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
logging buffered informational
enable secret 5 xxxxxxxxx
!
aaa new-model
!
!
aaa authentication login default local
!
aaa session-id common
!
username xxxxx privilege 15 secret 5 xxxxxxxxxxxxxx
!
no ip bootp server
ip domain name xyz.com
!
!
!
ipv6 spd queue max-threshold 63
!
!
!
multilink bundle-name authenticated
!
!
redundancy
 mode none
!
!
!
!
!
!
ip tftp source-interface GigabitEthernet0
ip ssh time-out 60
ip ssh version 2
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 description TEST
 ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 ip address 192.168.20.20 255.255.255.0
 negotiation auto
 cdp enable
!
ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 192.168.20.1
!

!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0
 exec-timeout 5 0
 privilege level 15
 no activation-character
 logging synchronous
 transport preferred none
 transport input ssh
 transport output none
 stopbits 1
 default exec
line vty 1 4
 exec-timeout 5 0
 privilege level 15
 logging synchronous
 transport input ssh
 transport output none
line vty 5 15
 exec-timeout 5 0
 privilege level 15
 logging synchronous
 transport input ssh
 transport output none
!
!
end

 

3 REPLIES

What command are you running

What command are you running to copy it into the running config?

New Member

Config replace nvram:test

Config replace nvram:test-config

There are some strict

There are some strict restrictions on the file format. See if this link helps.
http://ieoc.com/forums/p/29629/241872.aspx

683
Views
0
Helpful
3
Replies
CreatePlease to create content