Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Configuration changes are locked

I am trying copy startup-config running-config

The above command is failing with an error.

User Access Verification

Password:

MLS-77-1>enable

Password:

MLS-77-1#copy startup-config running-config

% Copy to running-config failed because configuration changes are locked

And if I try the command after few seconds, it will be successful.

What can be the problem?

6 REPLIES
Purple

Re: Configuration changes are locked

What model is this device and is it native or hybrid os ?? If its 6500 running hybrid then there is no write memory or copy run start commands , confgiurations are saved as soon as you enter the information . Just by looking at your prompt it looks like hybrid so there is no need to save any config it is saved automatically , but of course it is always smart to save a copy on a tftp server somewhere in case the hardware fails .

New Member

Re: Configuration changes are locked

I am using 6509 with Image..

c6sup22-psv-mz.121-26.E5.bin

Re: Configuration changes are locked

Hi

I think its the issue with u r access level privilages on the device.Can u confrim what level of access u have on this device.

Thanks

Mahmood

Purple

Re: Configuration changes are locked

Do a show mod command and post here and we can tell better . To me it looks your first post prompt is catos but I could be wrong.

New Member

Re: Configuration changes are locked

MLS-77-1#sh mod

Mod Ports Card Type Model Serial No.

--- ----- -------------------------------------- ------------------ -----------

1 2 Catalyst 6000 supervisor 2 (Active) WS-X6K-S2U-MSFC2 SAL0749QEGC

2 2 Catalyst 6000 supervisor 2 (Standby) WS-X6K-S2U-MSFC2 SAL0749QEFW

3 48 48-port 10/100 mb RJ45 WS-X6148-RJ-45 SAL0749Q6YP

4 16 SFM-capable 16 port 10/100/1000mb RJ45 WS-X6516-GE-TX SAL0748Q5DP

6 0 2 port adapter FlexWAN WS-X6182-2PA SAD0710005F

Mod MAC addresses Hw Fw Sw Status

--- ---------------------------------- ------ ------------ ------------ -------

1 0006.d65d.afd8 to 0006.d65d.afd9 5.0 7.1(1) 12.1(26)E5 Ok

2 0009.1246.d664 to 0009.1246.d665 5.0 7.1(1) 12.1(26)E5 Ok

3 000e.3893.7780 to 000e.3893.77af 1.3 5.4(2) 8.5(0.9)TFW3 Ok

4 000e.38c3.dac0 to 000e.38c3.dacf 2.5 6.3(1) 8.5(0.9)TFW3 Ok

6 0008.7cd6.5180 to 0008.7cd6.51bf 1.5 12.1(26)E5 12.1(26)E5 Ok

Mod Sub-Module Model Serial Hw Status

--- --------------------------- --------------- --------------- ------- -------

1 Policy Feature Card 2 WS-F6K-PFC2 SAL0749QD34 3.4 Ok

1 Cat6k MSFC 2 daughterboard WS-F6K-MSFC2 SAL0749QBQ2 2.6 Ok

2 Policy Feature Card 2 WS-F6K-PFC2 SAL0747PZWP 3.4 Ok

2 Cat6k MSFC 2 daughterboard WS-F6K-MSFC2 SAL0749QBNY 2.6 Ok

Mod Online Diag Status

--- -------------------

1 Pass

2 Pass

3 Pass

4 Pass

6 Not Applicable

New Member

Re: Configuration changes are locked

I think the reason for that error is because I am trying to run the command when both the active and standby card are trying to sync.

Jan 14 16:10:13.818 GMT: %PFREDUN-SP-6-ACTIVE: Standby initializing for R

PR-PLUS modesh

Jan 14 16:10:14.070 GMT: %PFINIT-SP-5-CONFIG_SYNC: Sync'ing the startup c

onfiguration to the standby Router mod

### here I run the command.. ##########

MLS-77-1#copy startup-config running-config

% Copy to running-config failed because configuration changes are locked

####### here the sync is completed #######

Jan 14 16:11:14.607 GMT: %SNMP-5-MODULETRAP: Module 1 [Up] Trap

Jan 14 16:11:14.091 GMT: %DIAG-SP-6-RUN_MINIMUM: Module 1: Running Minimu

m Online Diagnostics...

Jan 14 16:11:14.091 GMT: %DIAG-SP-6-DIAG_OK: Module 1: Passed Online Diag

nostics

Jan 14 16:11:14.503 GMT: %OIR-SP-6-INSCARD: Card inserted in slot 1, inte

rfaces are now onlinesh mod

00:00:08: %OIR-SP-STDBY-6-CONSOLE: Changing console ownership to route pr

ocessor

00:00:42: %PFREDUN-SP-STDBY-6-STANDBY: Initializing for RPR-PLUS mode

00:00:47: %SPANTREE-SP-STDBY-5-EXTENDED_SYSID: Extended SysId enabled for

type vlan

00:00:47: SP-STDBY: SP: Currently running ROMMON from S (Gold) region

00:00:58: %DIAG-SP-STDBY-6-RUN_MINIMUM: Module 1: Running Minimum Online

Diagnostics...

00:01:36: %DIAG-SP-STDBY-6-DIAG_OK: Module 1: Passed Online Diagnostics

00:01:50: %SW_VLAN-SP-STDBY-6-VT

If I try to save configs before or after this sync process then I will be able to save the configs properly.

Actually I am writing a upgrade script, and it was failing as it was unable to save the configs.

Thanks anyways to all of you.

421
Views
0
Helpful
6
Replies
CreatePlease to create content