Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuration L2TP Client

BOnjour à vous,

Je me permet de vous demander votre aide sur la configuration de mes routeurs C887 et C888.

Voici l'architecture souhaitée :

L2TP.bmp

Je souhaiterais donc monter un tunnel L2TP depuis mon routeur CISCO, jusqu'à mon LNS en passant par une connexion internet naté via mon LAN (routeur LTE).

Le problème rencontré est que je traverse deux NAT. Le premier sur mon routeur LTE et le second sur le réseau de mon opérateur (l'IP de l'itnerface pstn de mon routeur 4G est une IP privé).

Mon routeur Cisco 887VA-W est connecté à mon router LTE via une interface LAN.

D'après mes recherches j'ai le choix entre plusieurs solutions, dont VPDN :

CISCO

!

service internal

!

vpdn enable

!

vpdn-group L2TP

request-dialin

protocol l2tp

pool-member 1

initiate-to ip "IP_LNS"

no l2tp tunnel authentication

!

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 1

dialer vpdn

dialer-group 1

no cdp enable

ppp authentication ms-chap callin

ppp chap hostname CTCQUATRE

ppp chap password 0 ***********

!

!

ip route "IP_LNS" 255.255.255.255 FastEthernet0

ip route 0.0.0.0 0.0.0.0 Dialer1

!

Avec cette solution, le tunnel ne tente pas de s'initialiser. Je n'ai aucun résultat dans mes debugs.

Je vous metterai ce soir la configuration que j'ai effectué avec un pseudowire.

Merci pour votre lecture.

Cordialement,

Benoît

1 REPLY
New Member

Re: Configuration L2TP Client

Bonjour à vous,

J'ai trouvé la solution à ce problème.

En faite la technologie VPDN n'est pas approprié, elle permet de configurer un routeur en tant que LAC L2TP.

J'ai opté pour la solution pseudowire L2TPv2.

Voici la configuration fonctionnelle :

CISCO

!

l2tp-class PW

hostname HOSTNAME

!

vlan 2

name DATA

!

pseudowire-class L2TP

encapsulation l2tpv2

protocol l2tpv2 PW

ip local interface Vlan2

!

!

interface FastEthernet0

switchport access vlan 2

switchport trunk native vlan 2

switchport mode trunk

no ip address

!

interface FastEthernet1

switchport access vlan 2

switchport trunk native vlan 2

switchport mode trunk

no ip address

!

!

interface Virtual-PPP1

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip verify unicast reverse-path

ip nat outside

ip virtual-reassembly in

ip tcp adjust-mss 1420

ppp chap hostname &HOST&

ppp chap password &PASS&

ppp ipcp dns request

ppp ipcp route default

no cdp enable

pseudowire &IPLNS& 1 encapsulation l2tpv2 pw-class L2TP

!

!

interface Vlan1

no ip address

shutdown

!

interface Vlan2

description Vlan Data

ip address 192.168.127.252 255.255.0.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nbar protocol-discovery

ip nat inside

ip virtual-reassembly in

!

!        

!

ip nat inside source list NAT interface Virtual-PPP1 overload

ip route 0.0.0.0 0.0.0.0 Virtual-PPP1

ip route 0.0.0.0 0.0.0.0 192.168.127.254 10

ip route &IPLNS& 255.255.255.255 192.168.127.254

!

ip access-list extended NAT

permit ip 192.168.0.0 0.0.255.255 any

!

J'espère que cette réponse aidera quelques-uns d'entre vous.

Benoît

269
Views
0
Helpful
1
Replies
CreatePlease login to create content