Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuration of a CISCO CATALYST 2940 SWITCH

How to associate a port (fast ethernet) of the switch CISCO CATALYST 2940 with 2 different VLAN (2 and 3).

I tried by means of the enchainement of the commands(orders):

conf t

interface FastEthernet0/1

switchport mode access

switchport access vlan 2

switchport access vlan 3

end

show running-config

Only the VLAN 3 is associated with the port 1.

5 REPLIES
Purple

Re: Configuration of a CISCO CATALYST 2940 SWITCH

The only way to to do that is to have the device on the other end support trunking then you would make that port a trunk link.

Hall of Fame Super Blue

Re: Configuration of a CISCO CATALYST 2940 SWITCH

You can't do this. However what you can do is

1) make the port a trunk port and only allow vlan 2 & 3 on it ie.

switchport mode trunk

switchport trunk allowed vlan add 2 3

2) have a data vlan and a voice vlan ie.

switchport access vlan 2 ( vlan 2 = data )

switchport voice vlan 3

What is it you are trying to achieve ?

Jon

New Member

Re: Configuration of a CISCO CATALYST 2940 SWITCH

Hello,

I try to connect 2 groups of PCs (the First one goupe on port 2 and 3, the second group on ports 4 and 5) which are not in the same network and who have to reach a common PC which is on the port 1of the switch.

The PCs connected on ports 2 and 3 must not be seen the PCs connected on ports 4 and 5 of the switch and conversely. These PC have to see and be seen by the PC connected on the port 1 of the switch.

I had thought that to create VLAN, with the port 1 of the switch declared in 2 VLAN was possible during the configuration of the switch.

If this solution is imposible, do you have an other one?

Re: Configuration of a CISCO CATALYST 2940 SWITCH

Hi,

if all the PCs were in the same subnet, you could think about private VLANs.

But this feature is not supported on 2940s, I'm afraid.

You need some router or L3 switch to implement this task.

BR,

Milan

New Member

Re: Configuration of a CISCO CATALYST 2940 SWITCH

Thank you for the information, by looking at the documentation it is indeed of what I thought.

We have to take a switch of level 3.

135
Views
0
Helpful
5
Replies
CreatePlease login to create content