Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuration of DHCP relay information

Dear All;

first of all many many thankx for all my friends ..

here is my scenerio...for enabling DHCP relay and inter Vlan routing....

switch3560)_1(configt)#ip routing

switch3560_1(configt)service dhcp

switch3560_1(configt)ip dhcp relay information policy replace | keep

switch3560_1(configt-if)#swotchport mode trunk

switch3560_1(configt-if)#switchport trunk encap isl

!

!

switch3560_1(vlan)#vlan 2 name AA

switch3560_1(vlan)#vlan 3 name BB

switch3560_1(vlan)#vlan 4 name MM <Management purpose>

on vlan 2

switch3560_1(configt-if)#ip address 10.1.2.1 255.255.255.0

switch3560_1(configt-if)#no shut

switch3560_1(configt-if)#ip helper-address <dhcp add>

same for vlan 3 10.1.3.1

on Vlan 4 <management>

switch3560_1(config-if)#ip address 10.1.4.1 255.255.255.0

switch3560_1(config-if)#no shut

switch3560_1(config-if)#ip helper-address <dhcp add>

switch3560_1(vlan)#vtp domain CISCO

switch3560_1(Vlan)#vtp client

this switch is connected with another 3560_2 switch where on gig 0/45 port DHCP server is attached

switch3560_2(config)#service dhcp

(no relay info configured)

switch3560_2(config)#ip routing

switch3560_2(vlan)#vlan 5 name DD

switch3560_2(vlan)#vlan 6 name EE

switch3560_2(vlan)#vlan 4 name MM

<Management>

on vlan 5

switch3560_2(config-if)#ip address 10.1.5.1 255.255.255.0

switch3560_2(config-if)#no shut

switch3560_2(config-if)#ip helper-address <dhcp add>

on vlan 6

switch3560_2(config-if)#ip address 10.1.6.1 255.255.255.0

switch3560_2(config-if)#no shut

switch3560_2(config-if)#ip helper-address <dhcp add>

!

!

on vlan 7

switch3560_2(config-if)#ip address 10.1.4.2 255.255.255.0

switch3560_2(config-if)#no shut

switch3560_2(config-if)#ip helper-address <dhcp add>

!

!

after this configuration still VLAN attached PC is not getting IP address from DHCP server which is connected on next switch.

PLEASE help me in this regard.

7 REPLIES

Re: Configuration of DHCP relay information

Hi

I dnot see any config related to your intervlan routing.Can u say where u r layer 3 SVI are configured.U need to give the ip helper-address command under u r layer 3 interface not under u r layer 2 interface.

Thanks

Mahmood

New Member

Re: Configuration of DHCP relay information

thank you very mush for you kind reply ;;;;

could you please further guide me.......

both 3560 switches could be act as layer 3 ....so please help me out...how to and where to pass that command......

Cisco Employee

Re: Configuration of DHCP relay information

Hi Friend,

WHY do you want routing on both the switches. As per me you should be doing routing for all your vlans on one switch only.

Also please specify the ip address of your DHCP server and in which vlan does your DHCP server exist?

Also I see vlan 4 subnet ip configured on switch 2 also with vlan 7 name can you confirm its a typo error?

Regards,

Ankur

New Member

Re: Configuration of DHCP relay information

Yea Dear you are right;

it was my typo mistake....

it is Vlan 4

and routing is enable in only 1 wsitch that is switch3560_1. (again typing mistake)

DHCP server is attached in VLAN 6.

please guide me further.....

Re: Configuration of DHCP relay information

Hi

What u need to decide first how u r going to implement your vlan topology.

first decide which switch is going to act as the VTP server and which one is going to act as client.

I would suggest u to congiure Vlan routing on u r VTP server.From each switch which is acting as a client configure the ports which will connect to vtp server as trunk ports.

then u can define the SVI for each vlan.like this.

int vlan 2

ip address 10.0.0.1 255.0.0.0

ip helper-address

Thanks

Mahmood

New Member

Re: Configuration of DHCP relay information

Dear i did same.....means on all VLAN i did same......i assign IP addresses and ip helper-address to all interfaces of VLAN....

switch3560_1 is VTP server

switch3560_2 is client

please add you comments

Re: Configuration of DHCP relay information

Hi

The switch which is acting as the VTP server configure like this.

int vlan 1

ip address 10.0.0.1 255.0.0.0

ip helper-address

no shut

Thanks

Mahmood

366
Views
0
Helpful
7
Replies
CreatePlease login to create content