Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Configure 871W wifi devices to talk to wired devies

Guys,

here is my config. My wireless laptops get in fine, but when I plug a pc/laptop to the ports, I do not get an IP.

I even manually gave my pc an IP on the same LAN subnet but no communication.

Can you please help me on what's going on and how do I setup those ports to be on the same subnet as 10.6.2.0 so any device I plug into the ports can talk to the wireless devices and can also go out to the internet?

871W#sh run

Building configuration...

.

.

dot11 syslog

!

dot11 ssid caipwifi

authentication open

guest-mode

!

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.6.2.1 10.6.2.49

ip dhcp excluded-address 10.6.2.100 10.6.2.255

!

ip dhcp pool sdm-pool1

import all

network 10.6.2.0 255.255.255.0

default-router 10.6.2.1

!

!

no ip domain lookup

ip domain name yourdomain.com

!

multilink bundle-name authenticated

!

!

username itadmin privilege 15 secret 5 $1$i9qi$BdCiOlAo4QPP4upVMPbQQ/

!

!

crypto isakmp policy 1

encr 3des

hash md5

authentication pre-share

group 2

crypto isakmp key xxx address 66.66.66.66

crypto isakmp invalid-spi-recovery

!

!

crypto ipsec transform-set myset esp-3des esp-md5-hmac

!

crypto map mymap 10 ipsec-isakmp

set peer 66.66.66.66

set transform-set myset

match address insc_acl

!

archive

log config

hidekeys

!

!

!

bridge irb

!

!

interface Loopback0

ip address 1.1.1.1 255.255.255.252

!

interface FastEthernet0

no cdp enable

!

interface FastEthernet1

no cdp enable

!

interface FastEthernet2

no cdp enable

!

interface FastEthernet3

no cdp enable

!

interface FastEthernet4

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

crypto map mymap

!

interface Dot11Radio0

no ip address

!

encryption key 1 size 40bit 0 901CA78731 transmit-key

encryption mode wep mandatory

!

ssid caipwifi

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

no ip address

!

interface BVI1

description $ES_LAN$$FW_INSIDE$

ip address 10.6.2.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

ip policy route-map VPN-MAP

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 dhcp

!

!

no ip http server

no ip http secure-server

ip nat inside source static tcp 10.6.2.2 6502 interface FastEthernet4 6502

ip nat inside source static tcp 10.6.2.2 3389 interface FastEthernet4 3389

ip nat inside source route-map ISP1 interface FastEthernet4 overload

!

ip access-list extended insc_acl

permit ip 10.6.2.0 0.0.0.255 10.21.30.0 0.0.0.255

permit ip 10.6.2.0 0.0.0.255 10.8.251.0 0.0.0.255

!

access-list 114 permit ip 10.6.2.0 0.0.0.255 10.21.30.0 0.0.0.255

access-list 180 deny ip 10.6.2.0 0.0.0.255 10.21.30.0 0.0.0.255

access-list 180 deny ip 10.6.2.0 0.0.0.255 10.8.251.0 0.0.0.255

access-list 180 permit ip 10.6.2.0 0.0.0.255 any

no cdp run

!

!

!

route-map VPN-MAP permit 10

match ip address 114

set ip next-hop 1.1.1.2

!

route-map ISP1 permit 10

match ip address 180

match interface FastEthernet4

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

.

.

871W#

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Configure 871W wifi devices to talk to wired devies

Hi,

You need to add VLAN1 to the bridge-group as well so traffic between dot11 and FastE interfaces will be bridged. By default, your wired interfaces belong to VLAN 1:

int vlan 1

bridge-group 1

!

HTH

Laurent.

4 REPLIES
Cisco Employee

Re: Configure 871W wifi devices to talk to wired devies

Hi,

You need to add VLAN1 to the bridge-group as well so traffic between dot11 and FastE interfaces will be bridged. By default, your wired interfaces belong to VLAN 1:

int vlan 1

bridge-group 1

!

HTH

Laurent.

Community Member

Re: Configure 871W wifi devices to talk to wired devies

Laurent, thank you very much for the info.

As soon as I put those commands you suggested, my wired guys have now a presence on the network.

you're the best man!

thank you

any good links to read about this? I did some searching but found nothing.

Hall of Fame Super Silver

Re: Configure 871W wifi devices to talk to wired devies

Hello Angel,

here it is a link to the chapter in configuration guide for wireless

http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/wireless.html#wp999879

Hope to help

Giuseppe

Community Member

Re: Configure 871W wifi devices to talk to wired devies

Great stuff Giuseppe. Really good link with the basics.

436
Views
5
Helpful
4
Replies
CreatePlease to create content