Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configure catalyst 3500XL

Hi Everyone,

I'm configuring a catalyst 3500XL, but I'm having a problem, when I connect an ip phone it works just fine but if I connect a computer to the pc port in the phone the computer doesn't get an ip address. The switch is configure with two vlans Voice and Data and is connected from fa0/24 to a Catalyst 3560 fa0/46. I did configure both ports as trunk. Can someone give a hand?

Thanks

9 REPLIES
Cisco Employee

Configure catalyst 3500XL

Hello Abraham,

We will need to see parts of configuration on your switches to narrow down the cause of the problem. Please be so kind to post the following information:

  1. the entire configuration of the port on the 3500XL that connects to the IP phone
  2. the entire configuration of the fa0/24 port on the 3500XL
  3. the entire configuration of the fa0/46 port on the 3560
  4. the show vlan brief from the 3500XL and 3560

Also, if a different port on the 3500XL is configured simply as an access port in the data VLAN with no voice VLAN, if you plug a PC into such a port, does it get an IP address?

Best regards,

Peter

New Member

Re: Configure catalyst 3500XL

Thanks

In switch 3500XL,

If I connect a pc direct to a port configure with this configurations

interface FastEthernet0/2

switchport access vlan 3

switchport voice vlan 2

spanning-tree portfast

It work just fine, but the phone doesn't.

And here are the configurations to fa0/23 were an ip phone is connected and work fine but computer doesn't

interface FastEthernet0/23

switchport access vlan 3

switchport trunk encapsulation dot1q

switchport mode trunk

switchport priority default 5

switchport voice vlan 2

switchport priority extend cos 3

spanning-tree portfast

Attach are the files with your request for both switches 3500XL and 3560

Cisco Employee

Configure catalyst 3500XL

Abraham,

The configuration of the Fa0/2 port is the recommended way of configuring a port with a data and voice VLAN. We should primarily focus on making this configuration work. Now, the Fa0/2 interface here is configured absolutely correctly. However, the IP phone here depends on working CDP to learn about its voice VLAN. Therefore, my question is whether the CDP is enabled on your switch. If it is disabled (look for command no cdp run somewhere in the global configuration) it needs to be reenabled.

Just as a workaround, your Fa0/23 configuration can be made to work for both IP phone and the PC like this:

interface FastEthernet0/23

  switchport trunk encapsulation dot1q

  switchport trunk native vlan 3

  switchport trunk allowed vlan 1-3

  switchport mode trunk

  switchport priority default 5

  switchport voice vlan 2

  switchport priority extend cos 3

  spanning-tree portfast trunk

The primary change here is the modification of the native VLAN from 1 (the default) to 3 (the data VLAN). Note that when a port operates in trunk mode, all switchport access ... commands are ignored. Therefore here, we must change the native VLAN to put the untagged frames sent to and from the PC into the data VLAN 3. However, I stress again that this style of configuration is not recommended and we should really focus on solving the question why does not the Fa0/2 configuration work as expected.

Also, do you have a voice VLAN configured on the 3500XL Fa0/24 (the trunk towards 3560)? If yes then please remove the command from the Fa0/24 interface. It is not necessary on an ordinary trunk between switches.

Best regards,

Peter

Hall of Fame Super Silver

Configure catalyst 3500XL

Hello Peter, Abraham,

C3500XL should be among some unfortunate models that do not support the implicit mini trunk and it should require the explicit configuration of a trunk.

Peter's last workaround template should fix the issue.

We had several C3500XL in branch offices in a previous customer and if I correctly remember they were configured with the trunk to support IP phone+PC out of  a switchport

Hope to help

Giuseppe

Cisco Employee

Configure catalyst 3500XL

Hello Giuseppe,

You may very well be right. In that case, the switchport voice vlan command would merely instruct the CDP to tell the IP phone about the voice VLAN but it would not further configure the port as the "mini-trunk". My last XL switch was the 2900XL and frankly, I was never assigned the task of configuring a voice-enabled port on it.

Thank you for this update!

Best regards,

Peter

New Member

Re: Configure catalyst 3500XL

Guys I really apreciate your help.

Peter,

I did as you said, I check if cdp was enable and it is enable. So i did the configuration in fa0/23 as you said

interface FastEthernet0/23

  switchport trunk encapsulation dot1q

  switchport trunk native vlan 3

  switchport trunk allowed vlan 1-3

  switchport mode trunk

  switchport priority default 5

  switchport voice vlan 2

  switchport priority extend cos 3

  spanning-tree portfast trunk

and it works perfect! no issue at all, also i remove the access to voice vlan in fa0/24.

It's something else that you recomend ?

Thanks a million!

Configure catalyst 3500XL

Giuseppe,

I am very curious what you mean by

>>implicit mini trunk and it should require the explicit configuration of a trunk.

I am fighting a older 3524XL connecting directly up to (to complicate matters slightly) an Extreme 5i.

When on the extreme I have the port tagged, and on the cisco I have the uplink port trunked, I cannot have at the same time end user connectivity AND management connectivity. 

The only way I could resolve the issue was to add sw tr na vla 19 and untag vl 19 on the 5i.

So just curious what you mean by mini trunk.

Ty.

Hall of Fame Super Silver

Re: Configure catalyst 3500XL

Hello Jimmy,

mini trunk is a term used to describe the common setup to support an IP phone: a switchport that supports an untagged data vlan and a tagged voice vlan, implicit just means without configuring the port as a trunk.

Your scenario is different and involves the connection between two switches, I see that you have found a workaround that is to change the native vlan from default vlan 1 to vlan 19 that is one of the involved vlans (= one of the permitted vlans on the trunk)

A possible hint is that the switch works well if the native vlan is included in the list of permitted vlans on trunk. This is just a guess.

I'm not aware of limitations to the number of tagged vlans on a trunk on a C3500XL.

Most of deployments I have seen of C3500XL were using a single Vlan as they were used in some remote branch offices or a pair of Vlans to support IP phones.

Hope to help

Giuseppe

Configure catalyst 3500XL

Thanks for your response.

1559
Views
10
Helpful
9
Replies
CreatePlease login to create content