Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Configure IP address on Cisco3825 FastEth0/0/3 using HWIC-4ESW

Hi,

I was hoping someone can provide some information on how to set an IP address on the FastEthernet interface. i.e FastEthernet0/0/3. When I try to set the IP address, I get the following error:

"IP addresses may not be configured on L2 links."

So I tried a few options, but all failed:

Option 1: "no switchport" command.

this failed with : no switchport Command rejected: Not a convertable port.

Option 2: make it via a Vlan

This failed as well. Below is my configuration for vlan. I can ping address 10.75.22.1, but I can't ping the adj. router i.e 10.75.22.2. I think this may be an issue with arp? Notice below that Vlan100 is using the mac address of the GE interface??? What am I doing wrong?

interface FastEthernet0/0/3

description To_SYS75_1_5_4

switchport trunk native vlan 100

switchport mode trunk

arp snap

!

interface Vlan100

ip address 10.75.22.1 255.255.255.252

vlan-id dot1q 100

exit-vlan-config

GigabitEthernet0/0 is administratively down, line protocol is down Hardware is BCM1125 Internal MAC, address is 001e.4a2e.ab50 (bia 001e.4a2e.ab50)

FastEthernet0/0/3 is up, line protocol is up

Hardware is Fast Ethernet, address is 001f.cad3.cf72 (bia 001f.cad3.cf72)

Vlan100 is up, line protocol is up

Hardware is EtherSVI, address is 001e.4a2e.ab50 (bia 001e.4a2e.ab50)

Internet address is 10.75.22.1/30

9 REPLIES
Hall of Fame Super Gold

Re: Configure IP address on Cisco3825 FastEth0/0/3 using HWIC-4E

Arnold

I am a bit surprised that you made FastEthernet0/0/3 into a trunk port. If I understood your requirement correctly you want to associate an IP address with the interface. To do that I would make the interface an access port in VLAN 100, and assign the address in VLAN 100 (as you did).

Perhaps if we understood the environment a bit better - especially what that switch port will connect to - then we might be able to give better answers.

HTH

Rick

Community Member

Re: Configure IP address on Cisco3825 FastEth0/0/3 using HWIC-4E

I initially had it set to access, but was told that it should be set to trunk. When it was set to access, it failed as well.

interface FastEthernet0/0/3

description To_SYS75_1_5_4

switchport access vlan 100

arp snap

!

interface Vlan100

ip address 10.75.22.1 255.255.255.252

vlan-id dot1q 100

exit-vlan-config

Purple

Re: Configure IP address on Cisco3825 FastEth0/0/3 using HWIC-4E

You need to create the layer 2 vlan in the vlan database. At your normal prompt , non config mode, type vlan database then enter vlan 100 then type exit . See if it works after that .

Hall of Fame Super Gold

Re: Configure IP address on Cisco3825 FastEth0/0/3 using HWIC-4E

Arnold

What is this switch port connected to? If we knew that it would help guide how the interface should be configured?

Also in looking at the config I see that you are setting the ARP type to snap. Is there a reason for that? Most IP devices on Ethernet use ARPA type arp and not SNAP.

HTH

Rick

Community Member

Re: Configure IP address on Cisco3825 FastEth0/0/3 using HWIC-4E

I added vlan 100 to the database... still fail.

SYS22-Cis#vlan database

SYS22-Cis(vlan)#vlan 100

VLAN 100 modified:

SYS22-Cis(vlan)#exit

APPLY completed.

Setting arp to SNAP, was something I thought I would try. I set it back to ARPA.

This interface is connected to ALU 7705 SAR a8-eth port.

Now my config is below:

interface FastEthernet0/0/3

description To_SYS75_1_5_4

switchport access vlan 100

!

interface Vlan1

no ip address

shutdown

!

interface Vlan100

ip address 10.75.22.1 255.255.255.252

vlan-id dot1q 100

exit-vlan-config

!

!

Hall of Fame Super Gold

Re: Configure IP address on Cisco3825 FastEth0/0/3 using HWIC-4E

Arnold

What is the Alcatel expecting to see on the connection? How is its interface configured?

HTH

Rick

Community Member

Re: Configure IP address on Cisco3825 FastEth0/0/3 using HWIC-4E

The interface is configured with dot1q VLAN 100. This interface, is then connected to a router interface which contains an IP address. I need this interface to comunicate to a Cisco router interface, to create an IP network.

Hall of Fame Super Gold

Re: Configure IP address on Cisco3825 FastEth0/0/3 using HWIC-4E

Arnold

Is the port on the Alcatel configured as an access port or as a trunk port?

Also, I am not familiar with the command:

vlan-id dot1q 100

I wonder if the behavior would change if you remove it?

HTH

Rick

Community Member

Re: Configure IP address on Cisco3825 FastEth0/0/3 using HWIC-4E

The port is configured as "Network", which I believe is similar to Ciscos's "trunk". I tried configuring the cisco to both trunk and access, with the same result.

I removed it, and it did not make a difference. My understanding is that vlan-id dot1q is to enable IEEE 802.1Q VLAN encapsulation. On SAR, we configure as follows:

*A:SYS75-8>config>port# /configure port 1/5/4

*A:SYS75-8>config>port# info

----------------------------------------------

ethernet

mode network

encap-type dot1q

mtu 1500

exit

no shutdown

----------------------------------------------

*A:SYS75-8>config>router# /configure router interface to_CISCO_0_0_3

*A:SYS75-8>config>router>if# info

----------------------------------------------

address 10.75.22.2/30

port 1/5/4:100

----------------------------------------------

Now it's in the routing table...

show router route-table

Dest Prefix Type Proto Age Pref

Next Hop[Interface Name] Metric

-------------------------------------------------------------------------------

10.75.22.0/30 Local Local 00h05m39s 0

to_CISCO_0_0_3 0

I'm trying to setup cisco, to allow the same type of configuration.

1623
Views
0
Helpful
9
Replies
CreatePlease to create content