Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

configure ip to cat 2960

Hi,

I configure ip address to CAT 2960. However, I cannot telnet or ping the CAT. anything I missing?

switch>

interface vlan 1

ip address 192.168.16.10 255.255.255.0

!

ip default-gateway 192.168.16.1

!

line vty 0 4

password cisco

login

!

19 REPLIES
New Member

Re: configure ip to cat 2960

Is the interface VLAN 1 shutdown?

New Member

Re: configure ip to cat 2960

Hi,

I show the interface, the status and protocol are up.

the IOS is 12.2

rdgs

New Member

Re: configure ip to cat 2960

How does your network look? is the machine connected directly to the CAT? Is there a router between your machine and the CAT? Can you post your running-config?

ta

New Member

Re: configure ip to cat 2960

Hi,

the router is connect to CAT directly. the segment is 192.168.16.x

router is 192.168.16.1

servers are 192.168.16.50 - 192.168.16.100

CAT is 192.168.16.10

the router config is

!

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname switch

!

no aaa new-model

system mtu routing 1500

ip subnet-zero

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

ip address 192.168.16.10 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.16.1

ip http server

!

control-plane

!

!

line con 0

line vty 5 15

password cisco

login

!

end

New Member

Re: configure ip to cat 2960

Can you run a 'show int vlan 1' and post the output

New Member

Re: configure ip to cat 2960

Can you ping 192.168.16.1 from this machine you are trying to ping the switch with.

The machine you are pinging from is on the 192.168.16.x network right?

New Member

Re: configure ip to cat 2960

I'm going home shortly, but will be back on line in an hour.

New Member

Re: configure ip to cat 2960

Hi,

the output of "show inter vlan 1" and ping result.

I cannot ping the gateway even it connect to CAT directly.

switch#

sh inter vlan 1

Vlan1 is up, line protocol is up

Hardware is EtherSVI, address is 001e.1491.0b40 (bia 001e.1491.0b40)

Internet address is 192.168.16.10/24

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:37, output 00:00:31, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

25258 packets input, 1685099 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

910 packets output, 532549 bytes, 0 underruns

0 output errors, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

switch#ping 192.168.16.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.16.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

swith#

Re: configure ip to cat 2960

You say the router is connected directly. Please check that the interface it is connected to is on VLAN 1 as an access port, or as a trunk carrying VLAN 1.

If you do a show arp on the switch, can you see the MAC adress of the router? In fact, can you ping anything in 192.168.16.x from the switch?

Is the interface where the router is connected actually up?

Kevin Dorrell

Luxembourg

Cisco Employee

Re: configure ip to cat 2960

Instead of using ip default-gateway, use

ip route 0.0.0.0 0.0.0.0 192.168.16.1

instead.

HTH,

jerry

New Member

Re: configure ip to cat 2960

Hi Jerry, just reading your post. Don't you think this problem is more related to the switch/port configuration, VLANS etc...?

Can you post the 'show ip interfaces fastethernet (then add the port number the machine is connected to)' and run the same command but for the port the router is connected to.

The run a show vlan and post this output too.

Cheers,

Garry

New Member

Re: configure ip to cat 2960

Correction... sorry, i dont have a switch in front of me. Can you run these commands below instead and post the output.

show interfaces fastethernet (then add the port number the machine is connected to) and run the same command but for the port the router is connected to.

Then run a 'show vlan' and post this output too.

New Member

Re: configure ip to cat 2960

Hi,

I haven't configured VLAN on the CAT switch. I would like to configure IP for me to manage the box. I do not want to configure the VLAN on the swicth. there is no 802.1q, there is no trunk port.

the router is direct connect to switch 1, If I show the interface, the line and protocol are up.

I try to use "ip route" but the IOS does not support.

I would like to assign one ip address to switch. Does it means that I must config VLAN with trunk first?

regs,

New Member

Re: configure ip to cat 2960

I would like to assign one ip address to switch. Does it means that I must config VLAN with trunk first?

A VLAN and a trunk has nothing to do with interface vlan ip address. You should just be able to console into the switch, configure the interface VLAN 1 with IP/MASK (as you have done) attach a machine to fa/01 and ping that switches VLAN 1 (management) interface, thats providing the machine is in the same subnet as the switch is in.

New Member

Re: configure ip to cat 2960

Could do with a more experienced NetPro to look at this, I'm out of ideas at the minute...

New Member

Re: configure ip to cat 2960

Hi,

I have 4 routers in the same segment. one of routers has to in FE 0/1 port, has not it?

rdgs

New Member

Re: configure ip to cat 2960

up VLAN with no shut in vlan interface mode and then check

New Member

Re: configure ip to cat 2960

Hi,

I try it and the vlan is up. However, I cannot ping outside. not sure what is going wrong.

rdgs

New Member

Re: configure ip to cat 2960

Can you respond to the following questions.

1, The machine you are pinging from is connect directly to the switch right?

2, If yes, does the machine have an IP address assigned which falls in 192.168.16.x /24 network?

3, Where the machine connects to switch have you got a steady green light?

4, Run a 'show ip int br' and make sure the port the machine is using to connect to the switch states connected up/up

5, Have you tried a different port on the switch

1112
Views
0
Helpful
19
Replies
CreatePlease to create content