Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Configure Management Interface

I am trying to configure Management Interface on a 4506 that has a supervisor v-10GE.

I followed the following steps

configure terminal

interface vlan 99

ip address 192.168.1.245 255.255.255.0

no shutdown

interface fa 3/4

switchport mode access

switchport access vlan 99

end

configure terminal

ip default-gateway 192.168.1.1

when I try to ping the local ip address from the switch it fails

The same results happen when I try to ping a host on the network from the switch or ping the switch from a host.

I read another article that states to configure the loopback address

config t

int loopback 0

ip address 192.168.1.245 255.255.255.0

The only thing that accomplish was allow be to ping the local ip address from the switch. every other ping situation failed.

What am I missing?

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: Configure Management Interface

Cedric

For traffic to flow between 2 vlans you need either a L3 switch or a router. Here is a quick idea of the sort of config you would need on a L3 switch

Create the L2 vlans

===================

4500(config)# vlan 20

4500(config-vlan)# name v20

4500(config)# vlan 30

4500(config-vlan)# name v30

Create the L3 interfaces

========================

int vlan 20

ip address 192.168.5.1 255.255.255.0

int vlan 30

ip address 192.168.6.1 255.255.255.0

Now those 2 interfaces will only come up when you meet one of the 2 conditions in previous post.

You would then assign clients/servers into either vlan and use the address configured on the respective vlan interface as the default-gateway.

Note that on some L3 switches you first need to enable "ip routing".

Jon

5 REPLIES
Hall of Fame Super Bronze

Re: Configure Management Interface

What's the status of interface vlan 99 ?

Please post the show interface vlan 99 output.

What subnet are you pinging from and to?

__

Edison.

Community Member

Re: Configure Management Interface

the status is vlan 99 is down and the line is down. I am ping from and to subnet 255.255.255.0

All host are connected to the same switch and in the same subnet as the switch

The only thing I have not tried is to use the default vlan 1

how would I go about deleting vlan 99 to test my theory?

Thanks

Hall of Fame Super Blue

Re: Configure Management Interface

Cedric

If the status is down/down then you need to have either

1) a port that is up in vlan 99

2) a trunk port that allows vlan 99 on it

You also need to have vlan 99 created as a L2 vlan which you didn't show doing in your config example.

If you can't have 1 or 2 then yes you shift the config for interface vlan 99 to interface vlan 1.

4500(config)# no int vlan 99

will remove the interface you have created.

Jon

Jon

Community Member

Re: Configure Management Interface

Ok, so I did switch is to vlan 1 and it worked. This is my first time working with vlans, so some basic questions. It looks like the vlans are not talking thus if I configure management of vlan 99 all pings will fail until I allow traffic to flow between the two vlans. How is this done?

Hall of Fame Super Blue

Re: Configure Management Interface

Cedric

For traffic to flow between 2 vlans you need either a L3 switch or a router. Here is a quick idea of the sort of config you would need on a L3 switch

Create the L2 vlans

===================

4500(config)# vlan 20

4500(config-vlan)# name v20

4500(config)# vlan 30

4500(config-vlan)# name v30

Create the L3 interfaces

========================

int vlan 20

ip address 192.168.5.1 255.255.255.0

int vlan 30

ip address 192.168.6.1 255.255.255.0

Now those 2 interfaces will only come up when you meet one of the 2 conditions in previous post.

You would then assign clients/servers into either vlan and use the address configured on the respective vlan interface as the default-gateway.

Note that on some L3 switches you first need to enable "ip routing".

Jon

165
Views
0
Helpful
5
Replies
CreatePlease to create content