Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Configure Port-Channel Interface or Physical Interface on Etherchannel

So I am a bit confused on how to configure this. I did it in the past but kind of forgot how I did it.

I have a stacked 3750 (two physical switches) connecting to a 2960.

I am creating trunk ports with limited access to VLAN 300, 600, and 700.

There is two interfaces connected from the 3750's(one on each physical stack member) to the 2960.

I have the physical interfaces configured exactly the same.

3750 Config:

interface Port-channel2

!

interface FastEthernet1/0/46

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1, 300,600,700

switchport mode trunk

speed 100

duplex full

channel-group 2 mode active

interface FastEthernet2/0/46

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1, 300,600,700

switchport mode trunk

speed 100

duplex full

channel-group 2 mode active

2960G Config:

interface Port-channel1

!

interface FastEthernet1/0/1

switchport trunk allowed vlan 1, 300,600,700

switchport mode trunk

speed 100

duplex full

channel-group 1 mode active

interface FastEthernet1/0/2

switchport trunk allowed vlan 1, 300,600,700

switchport mode trunk

speed 100

duplex full

channel-group 1 mode active

Am I missing anything? Should I keep the configuration on the physical ports and not configure the Port-Channel Interfaces? Do I need to configure port-channel load balancing? Is the channel-group mode sufficient? Goal is to basically create 2 links to the 2960 to double the bandwidth and provide redundancy.

1 ACCEPTED SOLUTION

Accepted Solutions

Configure Port-Channel Interface or Physical Interface on Etherc

Are there fast etehernet interfaces on the 2960G?

Anyway, you have not clearly stated what your issue is.

If links are not coming up, this is probably due to the fixed speed/duplex.

regards,

Leo

7 REPLIES

Configure Port-Channel Interface or Physical Interface on Etherc

Are there fast etehernet interfaces on the 2960G?

Anyway, you have not clearly stated what your issue is.

If links are not coming up, this is probably due to the fixed speed/duplex.

regards,

Leo

Community Member

Configure Port-Channel Interface or Physical Interface on Etherc

No fastethernet interfaces, once my GBICs come in I will be utilizing those GB interfaces on the 3750. For now I want to get it working. The links are not coming up. I will try to remove the fixed speed/duplex but I had a few questions.

I said:

Am I missing anything? Should I keep the configuration on the physical ports and not configure the Port-Channel Interfaces? Do I need to configure port-channel load balancing? Is the channel-group mode sufficient? Goal is to basically create 2 links to the 2960 to double the bandwidth and provide redundancy.

Biggest question of all do I have to configure the port-channel interfaces?

Purple

Re: Configure Port-Channel Interface or Physical Interface on Et

  Looks fine , just make sure all ports are down when you configure them .  Bring the ports up together by doing a no shut on the port channel SVI on the 3750  + 2960 . I would put the trunking info under the port channel SVI also .  Any future changes  to the trunking parameters would be done under the SVI .   If the ports are not coming  up then are you using a crossover cable between your devices ?  If not then thats why it wont come up . The mdix function will only work if the ports are set auto for speed and duplex. 

Community Member

Configure Port-Channel Interface or Physical Interface on Etherc

Thanks, seems to be working well now without any configuration in the port-channel interfaces on either side. I am using straight-throughs. Last question, how can I verify I am getting 2gbps or at least 200mbps (until I get my GBICs).

Community Member

Re: Configure Port-Channel Interface or Physical Interface on Et

Thanks, everything was correct, once I removed the speed/duplex they came up.

Last question, how can I verify I am getting 2gbps or at least 200mbps (until I get my GBICs).

Configure Port-Channel Interface or Physical Interface on Etherc


mundusrector wrote:

Thanks, everything was correct, once I removed the speed/duplex they came up.

Last question, how can I verify I am getting 2gbps or at least 200mbps (until I get my GBICs).

That can be a tricky one as well. You will not get 200Mbps in a single session. The traffic is essentially load-balanced per source- or destination mac. This implies you will never get the aggregate throughput while testing between two machines.

The easiest way to check channel throughput is by regularly checking the load on the port-channel in a production environment. You should then be able to observe load over 100Mbps, indicating that more than one interface is being utilized. Set load-interval 30 on the port-channel to get a more real-time figure.

regards,

Leo

Purple

Configure Port-Channel Interface or Physical Interface on Etherc

  For a given conversation across say a 2 gig etherchannel  you will never get more than a gig thruput as each conversation is hashed across one link or the other. It does not ride both links for a given conversation .

1411
Views
5
Helpful
7
Replies
CreatePlease to create content