Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configure vlan to be up everytime

Hello i have a question about a configuration in a 3750 i want to access a interface ip vlan of the switch from a routed network but it seems that if there is no uplink on the switch the vlan is down so i want the vlan to be up in order to access his ip address.

How can i configure my switch to let the specific vlan up when nothing is connected to ?

thanks

12 REPLIES

Re: Configure vlan to be up everytime

Hi Yan,

@least 1 port should a member of vlan2(as an eg.), then only the interface vlan2 will be up.

Cisco Employee

Re: Configure vlan to be up everytime

Hi Yann,

Thats not possible. You need to have one atleast port configured for that vlan or you need to have a trunk configured carrying that vlan.

HTH

Ankur

New Member

Re: Configure vlan to be up everytime

Hi all,

thank you for you answer but all my ports are already configured in that vlan but i use thi switch for a disaster recovery plan so when everything is ok there is no link on that ports and i want to manage the switch with his vlan ip and the only port up is connected to a layer 3 router but the vlan is down so ip isn't reachable

Re: Configure vlan to be up everytime

can you share output of "show vlan" command on this switch?

New Member

Re: Configure vlan to be up everytime

i have no access to the switch at the moment but i look to my troubles on google the command may be something like keep alive or loopback-mode for the vlan to force the vlan to be up when there is no physical port connected to

Re: Configure vlan to be up everytime

Yann,

You want only Vlan2 interface to up. How is the connectvity rt now and how you will access the switch if nothing is connected to the switch.There should be an uplink connected to the switch in order to access it over the network.

Try using command " no-keepalive" under the fastethernet interface and this will bring the ethernet interface as up/up. Once that interface is up, your vlan interface should go up. I have not tried this practically on the switch.If that doesnot work on a layer 2 interface try setting the interface as layer3- switch" no switchport" command.

I have tried this on the routers, when there was no cable connected on the router interface and then setting up "no keep-alive" brought the interface as up/up.

I dont know whether the suggestion above can solve your problem but that's one of the thing that came to my mind wanted to share wigth you guys.

HTH,

-amit singh

New Member

Re: Configure vlan to be up everytime

thank your for your help but it doesn't seems to go up

please see my configuration, follow :

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname XXXXXXX

!

enable password 7 XXXXXX

!

username XXXX password 7 XXXXXXXXXXXX

no aaa new-model

switch 1 provision ws-c3750g-12s

vtp interface vlan

ip subnet-zero

ip routing

ip dhcp excluded-address 10.33.7.254

!

ip dhcp pool XXXXXX

network 10.33.4.0 255.255.252.0

default-router 10.33.7.254

dns-server 10.33.0.2 10.33.0.3

lease 8

!

!

mls qos

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface GigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 520

switchport mode trunk

!

interface GigabitEthernet1/0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 520

switchport mode trunk

!

interface GigabitEthernet1/0/3

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 520

switchport mode trunk

!

interface GigabitEthernet1/0/4

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 520

switchport mode trunk

!

interface GigabitEthernet1/0/5

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 520

switchport mode trunk

!

interface GigabitEthernet1/0/6

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 520

switchport mode trunk

!

interface GigabitEthernet1/0/7

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 520

switchport mode trunk

!

interface GigabitEthernet1/0/8

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 520

switchport mode trunk

!

interface GigabitEthernet1/0/9

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 520

switchport mode trunk

!

interface GigabitEthernet1/0/10

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 520

switchport mode trunk

!

interface GigabitEthernet1/0/11

switchport access vlan 520

switchport mode access

!

interface GigabitEthernet1/0/12

switchport access vlan 727

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface Vlan1

no ip address

!

interface Vlan520

ip address 10.33.7.254 255.255.252.0

!

interface Vlan727

ip address 10.12.14.158 255.255.255.240

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.12.14.145

ip http server

!

!

!

control-plane

!

!

line con 0

login local

line vty 0 4

login local

line vty 5 15

login local

------------------------

so what i want to do is to access ip address of the vlan 520, i can access the switch now using the vlan 727 ip address because the g1/0/12 interface is up/up but the vlan 520 is up/down

Re: Configure vlan to be up everytime

Hmm.. This is intresting. You vlan 520 should be up as you have a lots of trunks configured already. Arent they connected ?

Please pasete the output of any trunk interface using" show interface gig 1/0/x" and also " show interface vlan 520".

Did you try configuring any port as Layer-3 port with : no switchport " and then using " no keep-alive" under that interface.

-amit singh

New Member

Re: Configure vlan to be up everytime

no they are not connected right now the only one interface connected is g1/0/12

please see what you want :

Port Name Status Vlan Duplex Speed Type

Gi1/0/1 notconnect 1 auto auto 1000BaseSX SFP

Gi1/0/2 notconnect 1 auto auto Not Present

Gi1/0/3 notconnect 1 auto auto 1000BaseSX SFP

Gi1/0/4 notconnect 1 auto auto Not Present

Gi1/0/5 notconnect 1 auto auto 1000BaseSX SFP

Gi1/0/6 notconnect 1 auto auto Not Present

Gi1/0/7 notconnect 1 auto auto 1000BaseSX SFP

Gi1/0/8 notconnect 1 auto auto Not Present

Gi1/0/9 notconnect 1 auto auto 1000BaseSX SFP

Gi1/0/10 notconnect 1 auto auto Not Present

Gi1/0/11 notconnect 1 auto auto Not Present

Gi1/0/12 connected 727 full 100 10/100/1000BaseTX SFP

+

Vlan520 is up, line protocol is down

Hardware is EtherSVI, address is 0018.18a4.6cc1 (bia 0018.18a4.6cc1)

Internet address is 10.33.7.254/22

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:51:43, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

15 packets output, 1107 bytes, 0 underruns

0 output errors, 0 interface resets

0 output buffer failures, 0 output buffers swapped ou

what to you mean exactly because no keep alive is a default configuration ??

New Member

Re: Configure vlan to be up everytime

Sorry I'm 4 years late on this, but I just had the same scenario today. I tried the keep alive change on routed and switch ports as people suggested higher up, it didn't work. I tried gettin all fancy with loopback ints, that didn't work either.

The easiest solution was to enable trunking on one port on the router/switch, and connect it to another switch. For me that is a spare switch in this pile I have on my desk. Another way to do this would be to place each vlan on a port and connect that port to another switch, but that requires more configuration and more cabling. The trunk solution is easiest. I hope this helps.

Mike

Jax Florida

New Member

Re: Configure vlan to be up everytime

Hi vann.boulet,

Typically you need at least on switchport (a host) in the vlan to be in up/up state before the vlan interface will come up. You may want to consider using a loopback interface instead of the vlan interface if it's simply for monitoring purposes. The loopback will always be in up/up state unless you lose the switch.

Pls rate if help.

Regards,

Brandon

New Member

This may / may not directly

This may / may not directly help.

Have labbed a C3850 with some SVIs.  Obviously, without a trunk, none of them will come up.

Even with GigabitEthernet1/0/1 configured as (essentially allow all VLANs) ...

interface GigabitEthernet1/0/1
 switchport mode trunk
 no keepalive

... didn't help.

Totally as a band-aid, cannot vouch for this in PROD, introducing a "dangling patch lead", etc... but configuring -- say -- GigabitEthernet1/0/2 as ...

interface GigabitEthernet1/0/2
 no switchport
 no ip address

... and then plugging a patch lead in between the two, will bring up all the SVI's!

This works because in this scenario because "no switchport" only providing Layer-1 and no BPDUs for Layer-2.

1791
Views
9
Helpful
12
Replies
CreatePlease login to create content