Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Configuring 1941 with 8 port EHWic Switch Module and onboard GE Ports

Hi,

Can you configure a Cisco 1941 to use an 8 port EHWic module and the 2 onboard GE ports in a single LAN?

I've discovered you can't have the on GE ports associated with a VLan, and I'm when I've previously researched for a solution, bridging was mentioned but I cannot seem to get it to work (or completely understand it)

The reason I would like to use all 10 ports on for the LAN is becuase I have 10 devices I need to connect to the 1941?

Any help would be appreciated

Regards

Andrew

Everyone's tags (1)
2 REPLIES
VIP Super Bronze

Re: Configuring 1941 with 8 port EHWic Switch Module and onboard

Hi Andrew,

The onboard gig ports on the router are routed ports and not switch ports.  So, you can't assign the same subnet to 2 different interfaces.  You can use IRB to put both interfaces on the same subnet, but that is not very common and older technology and not sure if it is available on your router. 

Even if you put theses interface on the same subnet, you can't add all the EHWIC ports to it.

Here is a link:

http://www.cisco.com/en/US/tech/tk389/tk815/technologies_tech_note09186a0080094663.shtml

HTH

Community Member

Configuring 1941 with 8 port EHWic Switch Module and onboard GE

Hi Reza,

Thanks for your reply, and for the link. I did actually find that page during my search, but didn't look too closely at it.

I read through it more detail, and decided that I may need to run the PCs over 2 subnets to utilise all ports I have on the router.
I was following the guide on the link when I decided to try something - I created the bridge group, added both the onboard routed ports to that bridge group, then added a VLAN to the bridge group.

I then added the ports in the EHWIC to that VLAN (switchport access).

From the preliminary testing I've done so far, this seems to have solved my issue. Devices connected to either of online GE ports, or any of the EHWIC ports appear to be able to be on the same subnet and can talk to each other.

Below is a watered down version of the config I've got on the router.

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname R1

!

boot-start-marker

boot system flash c1900-universalk9-mz.SPA.151-4.M4.bin

boot-end-marker

!

!

!

!

!

!

!

!

!

aaa session-id common

!

clock timezone EST 10 0

clock summer-time ESDT recurring last Sun Oct 2:00 last Sun Mar 2:00

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

!

no ip domain lookup

!

multilink bundle-name authenticated

!

crypto pki token default removal timeout 0

!

!

!

!

vtp mode transparent

!

redundancy

!

!

!

!

vlan 8

!

!

!

!

bridge irb

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

bridge-group 1

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

bridge-group 1

!

interface ATM0/0/0

no ip address

ip virtual-reassembly in

no atm ilmi-keepalive

pvc 8/35

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

!

interface GigabitEthernet0/1/0

switchport access vlan 8

no ip address

!

interface GigabitEthernet0/1/1

switchport access vlan 8

no ip address

!

interface GigabitEthernet0/1/2

switchport access vlan 8

no ip address

!

interface GigabitEthernet0/1/3

switchport access vlan 8

no ip address

!

interface GigabitEthernet0/1/4

switchport access vlan 8

no ip address

!

interface GigabitEthernet0/1/5

switchport access vlan 8

no ip address

!

interface GigabitEthernet0/1/6

switchport access vlan 8

no ip address

!

interface GigabitEthernet0/1/7

switchport access vlan 8

no ip address

!

interface Vlan1

no ip address

shutdown

!

interface Vlan8

no ip address

bridge-group 1

!

interface Dialer1

ip address negotiated

ip mtu 1460

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer-group 1

ppp chap hostname xxxxxxxx@xxxxxx.xxx

ppp chap password xxxxxxxxxxx

ppp ipcp route default

!

interface BVI1

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip nat inside source list NAT_SOURCE interface Dialer1 overload

!

ip access-list extended NAT_SOURCE

permit ip 10.10.10.0 0.0.0.255 any

!

access-list 1 permit 10.10.10.0 0.0.0.255

dialer-list 1 protocol ip permit

!

!

!

!

!

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

banner motd ^C

WARNING: Access to this system is limited to authorised users only.

^C

!

line con 0

logging synchronous

line aux 0

logging synchronous

line vty 0 4

logging synchronous

transport input all

!

scheduler allocate 20000 1000

end

Do you see anything obviously wrong with this config?

Like I said, the testing of the local network side seemed promising. I just need to test and make sure all ports can access the internet next.

Thanks again for your help so far

Regards

Andrew

1823
Views
0
Helpful
2
Replies
CreatePlease to create content