Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

configuring 802.1q on 2600's ethernet interface

Is 802.1q on 2620's ethernet interface possible. coz as far as im concerned it only works on fast ethernet interface..i dont have any fast ethernet on my 2600 router..i just want to make sure on this. coz i tried to configure my 2600, and there is a command for 802.1q..so i configured my trunking and it does not work at all. or is there something wrong with my setup..anyway, here is my config:

2900:

interface FastEthernet0/1

switchport trunk encapsulation dot1q

!

interface FastEthernet0/2

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet0/3

switchport access vlan 3

spanning-tree portfast

2600:

interface Ethernet0/0

description Connection to LAN

no ip address

ip accounting output-packets

half-duplex

!

interface Ethernet0/0.1

description TO-GACI

encapsulation dot1Q 1 native

ip address 10.10.10.254 255.255.255.192

!

interface Ethernet0/0.2

description GPS

encapsulation dot1Q 2

ip address 192.168.111.1 255.255.255.0

!

interface Ethernet0/0.3

description TO-ZHAPA

encapsulation dot1Q 3

ip address 192.168.112.1 255.255.255.0

2 REPLIES
Silver

Re: configuring 802.1q on 2600's ethernet interface

Vlan trunking is supported only on FE, GE and 10GE interfaces.

Re: configuring 802.1q on 2600's ethernet interface

Hi,

Despite it is said in the books that it is not supported on Ethernet interfaces (only FE and GE), practically it works out on Ethernet, however there is a possibility that you have come across Caveat CSCds42715, in which the 802.1Q native VLAN keyword does not function properly, please check the status and a brief description of the bug by using the Bug Toolkit (registered customers only) and entering the bug ID CSCds42715.

HTH,

Mohammed Mahmoud.

348
Views
0
Helpful
2
Replies
CreatePlease to create content