Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
New Member

Configuring 871W via HTTP server


I am attempting to setup a provisioning environment for new SOHO users. What I would like to do is have the new SOHO users order a Cisco 871W, and when it gets to their house, I want them to run a custom setup script I am writing that checks the current IOS version, uploads new one if necessary, completes appropriate configurations, etc.

This is all working very well with the exception of the code upload portion. To give you an example:

User launches a web browser and opens my custom script that uses xmlhttprequest to get the following URL:

The script gets the response, parses it, determines if new code is necessary, and if so, launches a new xmlhttprequest to this URL:\/\/\/file.bin/flash:/CR

The problem is that the source tftp URI (tftp:// gets all the forward-slashes converted to spaces by the router. I cannot figure out how to send a "/" in the request.

I have tried to escape the / with a \ like so: tftp:\/\/\/file.bin but then it converts both "\" and "/" to spaces...

I have tried to send hex encoded: but it still converts the %2F to a space...

Any help appreciated.


Re: Configuring 871W via HTTP server

This document provides a sample configuration for IPsec between a Cisco 871 router and a Cisco 7200VXR router using Easy VPN (EzVPN). The 7200 acts as the Easy VPN Server and the 871 acts as the Easy VPN Remote. In this example, the loopback interfaces are used on both routers as private networks. These can be replaced by other interfaces such as FastEthernet or Serial interfaces as required.

New Member

Re: Configuring 871W via HTTP server

Hi Pengke11,

I think you may have posted your reply to the wrong thread.

I am interested in syntax and formatting of the HTTP configuration tool.

Perhaps I don't understand how that article relates to the issue I am facing?


CreatePlease to create content