Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Configuring a new 800 serires router

Hi all

We got a new 800 series router and we wish to upload the config of the other working 800 series router we have in our office to replace it. We plan to do this via TFTP and therefore we need to set a temporary IP. The router has FOUR fast Ethernet ports and a WAN port. Assigning an IP to an interface is not possible and a VLAN must be created - Layer 3 only. I am assigning an IP to VLAN1 but when I connect the cable to FE0 the link is not coming up. I ve done the switchport access commands etc but I am not managing. This is running config of the router still untouched. I just need to make the router pingable bidirectionally. Thanks

 

Router#sh run
Building configuration...

Current configuration : 927 bytes
!
! No configuration change since last restart
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
memory-size iomem 10
crypto pki token default removal timeout 0
!
!
ip source-route
!
!
!
!
!
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid <removed>
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface FastEthernet4
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login
 transport input all
!
end

 

 

 

Thanks for your help.

7 REPLIES

Are you connecting the FE0

Are you connecting the FE0 interface to a switch? If so, you may need to use an Ethernet crossover cable to get connectivity.

Can you advice the correct

Can you advice the correct method to setup the interfaces? maybe I am missing something....(dont think so just to be 100%)

My config...straight cable is connected to FE0 and to an unmanaged switch....cant ping to and from router!

 

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int vlan 1
Router(config-if)#ip address 192.168.0.100 255.255.255.0
Router(config-if)#no shut
Router(config-if)#ex
Router(config)#int faste
Router(config)#int fastethernet 0
Router(config-if)#switchport mode access
Router(config-if)#switchport access vlan 1
Router(config-if)#end
Router#
Nov 10 16:56:19.995: %SYS-5-CONFIG_I: Configured from console by console
Router#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0              unassigned      YES unset  up                    up
FastEthernet1              unassigned      YES unset  down                  down
FastEthernet2              unassigned      YES unset  down                  down
FastEthernet3              unassigned      YES unset  down                  down
FastEthernet4              unassigned      YES unset  administratively down down
Vlan1                      192.168.0.100 YES manual down                  down

 

Assigning the IPv4 address to

Assigning the IPv4 address to VLAN1 will work, but the fact that the physical interface isn't coming up points to a crossover (or auto-MDIX on the switch as @danejone3 points out) being needed. Definitely look at using the FE4 interface option as well.

Cisco Employee

If the port is not coming up

If the port is not coming up at all, then it's likely a cabling issue as Jody pointed out.  If you are connecting to a switch, you may be able to enter the "mdix auto" command under the interface on the switch.  Not all models support it, so it depends on the switch you're using.

Interface 4 should be your WAN port.  You should be able to apply an IP address directly to that port rather than to a VLAN if you like.

If you're just trying to get the config over, is there some reason you can't simply do a "show running-config" on the old device and copy and paste that into the new one?  It's quicker and simpler unless there's some technical reason or policy which prevents it.

Can you advice the correct

Can you advice the correct method to setup the interfaces? maybe I am missing something....(dont think so just to be 100%)

My config...straight cable is connected to FE0 and to an unmanaged switch....cant ping to and from router!

 

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int vlan 1
Router(config-if)#ip address 192.168.0.100 255.255.255.0
Router(config-if)#no shut
Router(config-if)#ex
Router(config)#int faste
Router(config)#int fastethernet 0
Router(config-if)#switchport mode access
Router(config-if)#switchport access vlan 1
Router(config-if)#end
Router#
Nov 10 16:56:19.995: %SYS-5-CONFIG_I: Configured from console by console
Router#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0              unassigned      YES unset  up                    up
FastEthernet1              unassigned      YES unset  down                  down
FastEthernet2              unassigned      YES unset  down                  down
FastEthernet3              unassigned      YES unset  down                  down
FastEthernet4              unassigned      YES unset  administratively down down
Vlan1                      192.168.0.100 YES manual down                  down

 

Cisco Employee

Your fa 0 interface is

Your fa 0 interface is showing up/up, so the cabling is likely OK.  The SVI (interface vlan 1), however, is showing down/down. That's why you can't ping. This usually means you don't have a port or trunk forwarding that VLAN. If fa 0 is assigned to that VLAN and is up/up, the SVI should also be up/up. Can you post the output of the following commands?

sh run interface fa 0

sh interface status

Router#sh run interface

Router#sh run interface fastethernet 0
Building configuration...

Current configuration : 46 bytes
!
interface FastEthernet0
 no ip address
end


Router#sh interfaces status

Port    Name               Status       Vlan       Duplex Speed Type
Fa0                        connected    1          a-full   a-100 10/100BaseTX
Fa1                        notconnect   1            auto    auto 10/100BaseTX
Fa2                        notconnect   1            auto    auto 10/100BaseTX
Fa3                        notconnect   1            auto    auto 10/100BaseTX
Router#

 

197
Views
0
Helpful
7
Replies
CreatePlease login to create content