Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuring COS on 2960G switches with non-cisco phones

I have 7 POE switches that have ESI IP phones attached.  I have two VLANS, 1 and 2.  VLAN 2 is used for voice and is defined in each switch.

The ESI IP phones connect to my POE switch ports and the pc attaches through the ESI IP phone.

I have had voice quality issue between floors in my building.  Talking to others on my floor via the IP phone, there are no voice quality issues.

On each switch i have the following global commands:

no mls qos rewrite ip dscp

mls qos

Below are my port configurations.

interface Port-channel1
switchport trunk allowed vlan 1,2          This is my EtherChannel
switchport mode trunk
switchport nonegotiate


interface GigabitEthernet0/1                    This is an example of a port that my ESI IP phones are attached to.
switchport trunk allowed vlan 1,2
switchport mode trunk
switchport nonegotiate
priority-queue out
mls qos trust cos
channel-group 1 mode on

interface GigabitEthernet0/24
switchport trunk allowed vlan 1,2          This is an example of my uplink port to other switches.
switchport mode trunk
switchport nonegotiate
priority-queue out
mls qos trust cos
channel-group 6 mode on

POESWITCH#sh mls qos int gi1/0/15

GigabitEthernet1/0/15

trust state: trust cos

trust mode: trust cos

trust enabled flag: ena

COS override: dis

default COS: 0

DSCP Mutation Map: Default DSCP Mutation Mapsh msl

Trust device: none

qos mode: port-based

GVS12SW02GBPOE#sh int gi1/0/15 switchport
Name: Gi1/0/15
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: 1,2
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Is this a correct configuration to prioritize voice traffic? 

1 REPLY
New Member

Configuring COS on 2960G switches with non-cisco phones

Here are statistics from an active phone.

POE#sh mls qos int gi1/0/13 statistics
GigabitEthernet1/0/13 (All statistics are in packets)

  dscp: incoming
-------------------------------

  0 -  4 :     2953143            0            0            0            0
  5 -  9 :           0            0            0            0            0
10 - 14 :           0            0            0            0            0
15 - 19 :           0            0            0            0            0
20 - 24 :           0            0            0            0            0
25 - 29 :           0            0            0            0            0
30 - 34 :           0            0            0            0            0
35 - 39 :           0            0            0            0            0
40 - 44 :           0            0       668724            0            0
45 - 49 :           0      2364721            0            0            0
50 - 54 :           0            0            0            0            0
55 - 59 :           0            0            0            0            0
60 - 64 :           0            0            0            0
  dscp: outgoing
-------------------------------

  0 -  4 :      406289            1            8            0         1013
  5 -  9 :           0           21         6565         5521            4
10 - 14 :           5            0            8            0            0
15 - 19 :           0            7            0           12            0
20 - 24 :           6            1           10            0          149
25 - 29 :           0            0            0            0            0
30 - 34 :           0            0            0            0            0
35 - 39 :           0            0            0            0            0
40 - 44 :           1            0      1786175            0           19
45 - 49 :           0      2377678            0      3530882            0
50 - 54 :           9            0            0            0            0
55 - 59 :           0        95542            0            0            0
60 - 64 :           0            0            0            0
  cos: incoming
-------------------------------

  0 -  4 :    20326768            0            0            0            0
  5 -  7 :           0            0            0
  cos: outgoing
-------------------------------

  0 -  4 :   223618994          978         9616         2003         3177
  5 -  7 :         733         3266     10105807
  output queues enqueued:
queue:    threshold1   threshold2   threshold3
-----------------------------------------------
queue 0:           0           0           0
queue 1:   190675369      113177    10109078
queue 2:           0           0           0
queue 3:           0           0    33573181

  output queues dropped:
queue:    threshold1   threshold2   threshold3
-----------------------------------------------
queue 0:           0           0           0
queue 1:          32           0           0
queue 2:           0           0           0
queue 3:           0           0           0

Policer: Inprofile:            0 OutofProfile:            0

391
Views
0
Helpful
1
Replies
CreatePlease login to create content