Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Configuring eigrp between a Cisco ASA 5510 and Cisco 3560

I am attempting to configure eigrp between a Cisco 5510 and a Cisco 3560. Here is the relevant configuration:

ASA:

interface Ethernet0/1
 nameif Inside
 security-level 100
 ip address 172.17.254.1 255.255.255.0 

router eigrp 2
 network 172.17.254.0 255.255.255.0

3560:

router eigrp 2
   network 172.17.254.0 0.0.0.255

interface GigabitEthernet0/1
    ip address 172.17.254.2 255.255.255.0
    no switchport

On each device I can see the other as a neighbor. So I believe that eigrp is running on the correct interfaces.

However if I check the routing tables I don't see the routing information propagated. On the 3560 if I run show ip route eigrp I don't get anything back.

 

Any help would be appreciated.

 

Everyone's tags (1)
1 REPLY

Hi Mathew ,           Your

Hi Mathew , 

          Your configuration is working as excepted , though you have configured only one network statement under EIGRP , which is again connected interface . you would be seeing only one route under your route . as well as on eigrp route

Either you need to add another network which to  be advertised over eigrp by using network command / simply you can use redistribute command . while re-distributing please make sure which you want to advertise only connected subnet or only static routes or both . 

router eigrp 2
 redistribute static 
 redistribute connected 

 

HTH

Sandy

 

191
Views
0
Helpful
1
Replies
CreatePlease to create content