Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

Configuring EtherChannel between 6513 switch and a HP server

I have a HP server with 2 NIC's that I would like to Etherchannel together to increase the bandwidth to 2gb (possibly higher with more NIC's if I can get this working). I am teaming the NIC's with HP Network Configuration Utility. Currently the NIC's are teamed as, Transmit Load Balancing with Fault Tolerance (TLB), which allows one NIC to transmit and receive and the other NIC to transmit only and I would like both NIC's to be able to Tx and Rx. I would like to set the teaming to Switch-assisted Load Balancing with Fault Tolerance (SLB), which would allow both NIC's to Tx and Rx but to have this work I need to EtherChannel the port. I have not done this as of yet and I tried after I read through the Cisco papers and HP papers but it was not working properly. I did get the link working and it said the NIC's were set to Tx and Rx but when I sent some large files to the server only one NIC was used and the throughput maxed out at 107Mbps. I think I had the configuration incorrect. Could someone show me how I should set the Port-channel up and config the Interfaces. I have a Catalyst 6513 and the ports are 10/100/1000mb ports on a WS-X6748-GE-TX module. Has anyone done this with HP servers and does it work?

Thank you,

Mike

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Bronze

Re: Configuring EtherChannel between 6513 switch and a HP server

If the HP Server supports LACP, at the switch side do the following on the interfaces forming the bundle:

interface fx/x

channel-group 1 mode active

interface fx/x

channel-group 1 mode active

If the HP server does not support LACP, then issue the following commands:

interface fx/x

channel-group 1 mode on

interface fx/x

channel-group 1 mode on

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SXF/native/configuration/guide/channel.html

HTH,

__

Edison.

New Member

Re: Configuring EtherChannel between 6513 switch and a HP server

Dude,

Check this out:

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a008089a821.shtml

It works perfectly, i'm using such kind of setup for all my servers.

Laurent

8 REPLIES
Hall of Fame Super Bronze

Re: Configuring EtherChannel between 6513 switch and a HP server

If the HP Server supports LACP, at the switch side do the following on the interfaces forming the bundle:

interface fx/x

channel-group 1 mode active

interface fx/x

channel-group 1 mode active

If the HP server does not support LACP, then issue the following commands:

interface fx/x

channel-group 1 mode on

interface fx/x

channel-group 1 mode on

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SXF/native/configuration/guide/channel.html

HTH,

__

Edison.

New Member

Re: Configuring EtherChannel between 6513 switch and a HP server

Dude,

Check this out:

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a008089a821.shtml

It works perfectly, i'm using such kind of setup for all my servers.

Laurent

Re: Configuring EtherChannel between 6513 switch and a HP server

Thanks. I will be testing today. I also feel like a idiot... I posted roughly the same question back in November and forgot totally about it. Way too much going on at work and I must be losing it.... :-)

Thanks I will let you know how I make out.

Mike

Re: Configuring EtherChannel between 6513 switch and a HP server

What Load balancing do you use? and Why did you choose that?

Mike

Re: Configuring EtherChannel between 6513 switch and a HP server

Worked great thanks for your help.

Mike

Re: Configuring EtherChannel between 6513 switch and a HP server

Thanks for your help I will chack it out.

Mike

Re: Configuring EtherChannel between 6513 switch and a HP server

Worked great thanks for your help

New Member

Re: Configuring EtherChannel between 6513 switch and a HP server

We are expriencing the same issues, with 3560G and 2960G.

A HP DL380 with "Automatic" setting. And the Etherchannel set to active or passive.

This results in approx. 12,5~20% utilization of the combined linkspeed(2Gbit).

We have also tried setting the HP Team as "802.3ad Dynamic w. Fault Tolerance" and "Switch-assisted Load Ballancing w. Fault Tollerance" with the same results.

Any input?

3359
Views
0
Helpful
8
Replies
CreatePlease to create content