Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuring QoS for traffic inside a VLAN on Cisco 881

We've been trying to setup QoS for traffic leaving VLAN1 on FE0 in order to shape or police this to a certain value while prioritising voice traffic.

We can mark the packets (DSCP value) either as they arrive on the WAN FE4 or as they leave VLAN1, but the QoS policy which is in place on outbound FE0 can't see the marked packets.

I know IP ToS reflect and QoS pre-classify can be used on VPN tunnels to apply marked packets on the inside of the tunnel to the outside of the tunnel.

I've been searching for a solution but Google hasn't been very helpful on this occasion, splitting voice and data in to seperate VLANs isn't an option as they have a great deal of non-VLAN capable switches which they don't intend to swap out.

I imagine there must be a way for this to work on a Cisco 881, could someone please advise on a suitable solution\configuration?

Here's the current configuration.

class-map match-any VoIP

match  dscp ef

match  dscp af31

match ip precedence 5

class-map match-all VoIP_IN

match access-group 150

policy-map QoS_CHILD
class VoIP
    priority percent 75
class class-default
    fair-queue
    bandwidth percent 5
policy-map QoS_PARENT
class class-default
    shape average percent 88
   police rate percent 90
  service-policy QoS_CHILD

policy-map QoS_IN_MARK

class VoIP_IN

  set ip precedence 5

interface FastEthernet0
description LAN Physical
bandwidth 32768
no cdp enable

!

service-policy output QoS_PARENT

interface Vlan1
description LAN Virtual

ip address 10.0.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly

interface FastEthernet4
description WAN
bandwidth 32768
ip address 95.138.202.202 255.255.255.248
ip nat outside
ip virtual-reassembly
ip tcp adjust-mss 1452
duplex full
speed 10
crypto map ASGVPN
!
service-policy input QoS_IN_MARK
service-policy output QoS_PARENT

access-list 150 permit ip 154.51.129.0 0.0.0.63 any

1480
Views
0
Helpful
0
Replies