Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuring WCCP

Hello,

I need to know diffference between command

ip wccp 10 redirect out and

ip wccp 12 group-listen

3 REPLIES
Cisco Employee

Configuring WCCP

Hi,

ip wccp redirect out

To enable packet redirection an outbound interface using WCCP, use the ip wccp redirect out interface configuration command. To disable the ability of a router to verify that appropriate packets are being redirected, use the no form of this command.

ip wccp {web-cache | service-number} redirect out

no ip wccp {web-cache | service-number} redirect out


while

ip wccp group-listen

To configure an interface on a router to enable or disable the reception of IP multicast packets for the Web Cache Communication Protocol (WCCP) feature, use the ip wccp group-listen interface configuration command. To remove control of the reception of IP multicast packets for the WCCP feature, use the noform of this command.

ip wccp {web-cache | service-number} group-listen

no ip wccp {web-cache | service-number} group-listen

http://www.cisco.com/en/US/docs/ios/12_1/configfun/command/reference/frd3005.html

Basically if you decide to use the multicast address option for your service group, you must configure the router to listen for the multicast broadcasts on an interface.

Check the WCCP config guide for more

http://www.cisco.com/en/US/docs/ios/12_2/configfun/configuration/guide/fcf018_ps1835_TSD_Products_Configuration_Guide_Chapter.html

Riccardo

New Member

Configuring WCCP

We have proxy server Bluecoat in our Lan and some URL are not opening.

So i have to bypass bluecoat only those websites.

One of the location which is currently bypassing proxyserver.

As you mentioned multicasting, I am not seeing it configured in this location router.

interface GigabitEthernet0/0.1

description LAN

encapsulation dot1Q 1 native

ip address 10.50.2.1 255.255.254.0 secondary

ip address 192.168.80.1 255.255.248.0

ip access-group Deny_192.168.82.95 out

ip accounting output-packets

ip wccp 12 group-listen

ip nat inside

ip virtual-reassembly

ip policy route-map PBR-G0/0.1

One more location, where I have to bypass proxy server.

I am seeing configuration different.

interface GigabitEthernet0/0
description Connected to F0/5 on PS_Access-2950
ip address 10.53.8.14 255.255.255.0
ip wccp 11 redirect out
ip route-cache flow
ip tcp adjust-mss 1300
ip policy route-map MDWReturnTraffic
duplex auto
speed auto
standby 4 ip 10.53.8.13
standby 4 priority 150
standby 4 preempt

Let me know if you need some more information.

Cisco Employee

Configuring WCCP

Hi Kesar,

what do you mean by "I have to bypass bluecoat"? What do you exactly do in order to bypass it?

I am asking as WCCP is a transparent protocl which allows you to redirect traffic to cache engines... you mentioned instead a proxy server, so I suppose that your clients have a proxy configured in their browesers. This defeats the overall idea of transparent redirection.

Can you clarify?

About multicast you need to ask the wccp client (the appliances) administrator if they use a cluster with wccp v2 using a mcast address instead of unicast address.

Finally which models are your 2 routers which you attached the interface configurations for?

can you also print

show ip wccp

show ip wccp detail

show ip wccp  web-cache  detail

Riccardo

431
Views
0
Helpful
3
Replies
CreatePlease to create content