Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

confreg 0x2142 doesn't skip the config file

We've a 6509 with a config without enable user.

When we trie to skip the config (in rommon confreg 0x2142) in order to get a clean running config so we can copy the originate config

in running and then to set the enable passord the router starts up with the config in bootflash (where we doesn't have a user....

rommon 5 > dir bootflash:

Directory of bootflash:/

    1  -rw-    25205200  Jul 31 2007 12:10:01 +02:00  c6sup22-dsv-mz.121-26.E8.bin
    2  -rw-     1861272  Jul 31 2007 12:15:53 +02:00  c6msfc2-boot-mz.121-26.E8.bin
  118  -rw-       40758  Dec 14 2009 14:11:02 +01:00  AAA-BBB.XXX.cfg

rommon 6 > set
PS1=rommon ! >
SLOTCACHE=cards;
RET_2_RUTC=1107081814
BOOTLDR=
BOOT=bootflash:c6sup22-dsv-mz.121-26.E8.bin,12
CONFIG_FILE=bootflash:AAA-BBB.XXX.cfg
RET_2_RTS=13:59:18 MET Fri Dec 18 2009
BSI=0
RET_2_RCALTS=
?=1

rommon 7 > confreg 0x2142


rommon 8 > reset

We've tried it over an over but the config would not skip.

Anyone a suggestion ??

5 REPLIES
Hall of Fame Super Blue

Re: confreg 0x2142 doesn't skip the config file

New Member

Re: confreg 0x2142 doesn't skip the config file

Thanks for your reply, I think you mean:

"The router reboots. However, it ignores its saved configuration due to the fact that the configuration register is set to 0x2142.
If you see that the router configuration is still present (still previous hostname), it indicates that the configuration register was not changed to 0x2142 in time prior to the crash.
If this is the case, start over again (Step 4, Power down and then power up the router with the help of the power switch.).
If the configuration register is correctly changed to 0x2142, you get the initial configuration questions after the reload. "

We've tried it over and over, and still it doesn't work....

Cisco Employee

Re: confreg 0x2142 doesn't skip the config file

Hello,

If setting the configuration register to 0x2142 does not help, try to rename the file AAA-BBB.XXX.cfg in your bootflash: filesystem to a different name (if that's possible using the ROMMON), or redefine the CONFIG_FILE environment variable to a different nonexistent file. That will hopefully make the device to skip loading the configuration and end up with the default settings.

Best regards,

Peter

New Member

Re: confreg 0x2142 doesn't skip the config file

Thanks for your reply,

Allready tried CONFIG_FILE=bootflash:CCC.DDD.XXX.cfg (non-existing file in bootflash:)

a rename you can't do in rommon:

rommon 2 > ?
alias               set and display aliases command
break               set/show/clear the breakpoint
confreg             configuration register utility
cont                continue executing a downloaded image
dev                 list the device table
dir                 list files in file system
dis                 disassemble instruction stream
frame               print out a selected stack frame
help                monitor builtin command help
history             monitor command history
meminfo             main memory information
repeat              repeat a monitor command
reset               system reset
set                 show all monitor variables
unalias             unset an alias
boot                boot up an external process
context             display the context of a loaded image
stack               produce a stack trace
sync                write monitor environment to NVRAM
sysret              print out info from last system return
tscope              timer scope loop
sleep               sleep command
xmodem              x/y modem download

regards,

René

Hall of Fame Super Blue

Re: confreg 0x2142 doesn't skip the config file

Rene

Can you try just entering "confreg" at the ROMMON prompt and then answering all the questions you get after that.

Jon

4264
Views
0
Helpful
5
Replies
CreatePlease to create content