cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2324
Views
0
Helpful
23
Replies

Connect two Catalyst 3750G

informatiquecns
Level 1
Level 1

Hello,

I try to connect two switch Catalyst 3750G without success.

switch1 (192.168.2.10 vlan 2) <=> (192.168.2.11 vlan2) switch2

I use this configuration for swich1 :

enable

configure terminal

enable password MDP

end

copy running-config startup-config

configure terminal

hostname switch1

interface vlan 2

ip address 192.168.2.10 255.255.255.0
exit

ip default-gateway 192.168.2.252

end

copy running-config startup-config

configure terminal

vlan 2

name zone_client

end

copy running-config startup-config

configure Terminal

interface Gi1/0/3

switchport mode trunk

switchport trunk encapsulation dot1q

switchport nonegotiate

switchport trunk native vlan 2

switchport trunk allowed vlan 1,2,3,4

end

copy running-config startup-config

I use this configuration for swich2 :

enable

configure terminal

enable password MDP

end

copy running-config startup-config

configure terminal

hostname switch1

interface vlan 2

ip address 192.168.2.11 255.255.255.0
exit

ip default-gateway 192.168.2.252

end

copy running-config startup-config

configure terminal

vlan 2

name zone_client

end

copy running-config startup-config


configure Terminal

interface Gi1/0/3

switchport mode trunk

switchport trunk encapsulation dot1q

switchport nonegotiate

switchport trunk native vlan 2

switchport trunk allowed vlan 1,2,3,4

end

copy running-config startup-config

when i use ping in console terminal, ping fail.

Somebody can help me?

23 Replies 23

Make a show run int gi 1/0/3 on both switch.

switch1#show running
Building configuration...

Current configuration : 1794 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname switch1
!
boot-start-marker
boot-end-marker
!
enable secret *********************

enable password **************************

!
no aaa new-model
switch 1 provision ws-c3750g-24ts-1u
system mtu routing 1500
ip subnet-zero
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 1-4
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
no ip address
!
interface Vlan2
ip address 192.168.2.10 255.255.255.0
!
ip default-gateway 192.168.2.252
ip classless
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
password ************************

login
line vty 5 15
password ***********************

login
!
end

switch1#

---------------------------------------------------------------------------------------------

---------------------------------------------------------------------------------------------

switch2#show running
Building configuration...

Current configuration : 1794 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname switch2
!
boot-start-marker
boot-end-marker
!
enable secret ***********************************
enable password *******************************
!
no aaa new-model
switch 1 provision ws-c3750g-24ts-1u
system mtu routing 1500
ip subnet-zero
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 1-4
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
no ip address
!
interface Vlan2
ip address 192.168.2.11 255.255.255.0
!
ip default-gateway 192.168.2.252
ip classless
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
password ********************
login
line vty 5 15
password **********************
login
!
end

---------------------------------------------------------------------------------------------

---------------------------------------------------------------------------------------------

I don't think so 

Can the OP post the same output for sw1.

switch1>sh int g1/0/3 switchport
Name: Gi1/0/3
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 2 (zone_client)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: 1-4
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Hi,

it didn't take the switchport mode trunk command because you configured it before switchport trunk encapsulation dot1q

so reenter this command switchport mode trunk and it should be good,  I still wonder how I didn't remark that before.

Regards.

Alain

Don't forget to rate helpful posts.

Hi,

    You need to add "switchport mode trunk" on Gi1/0/3 on both switches.

!

interface GigabitEthernet1/0/3

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport trunk allowed vlan 1-4

switchport mode trunk

!

HTH,

Toshi

i agree... switchport mode trunk on both switch and see if it work.

network_guy
Level 1
Level 1

A couple things I would suggest. First I noticed both of your switches are set to VTP Server, if your going to runt Client-Server I would fully configure it (domain and passwod matching). If these two are your only switches as of now I would use Transparent to troubleshoot. Also, where is the IP of the default gateway? Where does your ip default-gateway IP sit? It's not configured on your switches? If these are the only two switches on your network I would put the ip default-gateway as the other switches IP.         Switch 1: ip default-gateway 192.168.2.11

Switch 2: ip default-gateway 192.168.2.10

Thank you Cadet Alain and Thotsaphon for your assistance.

When i add "switchport mode trunk" on both switch, it's work.

The configuration who work :

PC<=>(Vlan 2 in access mode)switch1(vlan 2 in trunk mode)<=>(Vlan 2 in trunk mode)switch2(vlan 2 in access mode) <=> (old swich) <=> (vlan in untagged mode ) HP swich <=> Gateway

But this configuration doesn't work :

PC<=>(Vlan 2 in access mode)switch1(vlan 2 in trunk mode)<=> (vlan in tagged mode ) HP swich <=> Gateway

?!?!?

Joshua.peavy > I not sur that i understand what your need (my level in english is not hight).

The target configuration is the following.

Hi,

PC<=>(Vlan 2 in access mode)switch1(vlan 2 in trunk mode)<=> (vlan in tagged mode ) HP swich <=> Gateway

If on sw1 Vlan 2 is the native vlan , it will be sent on the trunk untagged so it must be untagged also on the HP switch or you can force tagging of vlan 2( the native vlan) on the Cisco with the global config command: vlan dot1q tag native

Regards.

Alain

Don't forget to rate helpful posts.

It's work!

Thank you for your assistance.

Review Cisco Networking products for a $25 gift card