Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Connecting 2 Routers via Ethernet

I am have a little trouble setting up my home lab.  I have a 3620 with two ethernet ports and a 3640 with four ethernet ports. I also have a 3500XL switch that I am using to connect the two together, but I can't seem to get each one to ping.  Please help:

Here are my configs:

3500XL

3500XL-BottomSwitch#show run

Building configuration...

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 3500XL-BottomSwitch

!

!

username woodjl1650 privilege 15 password 0 henry999

!

!

!

!

!

ip subnet-zero

!

!

!

interface FastEthernet0/1

switchport access vlan 500

!

interface FastEthernet0/2

!

interface FastEthernet0/3

switchport access vlan 300

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

switchport access vlan 500

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface FastEthernet0/25

!

interface FastEthernet0/26

!

interface FastEthernet0/27

!

interface FastEthernet0/28

!

interface FastEthernet0/29

!

interface FastEthernet0/30

!

interface FastEthernet0/31

!

interface FastEthernet0/32

!

interface FastEthernet0/33

switchport access vlan 300

!

interface FastEthernet0/34

duplex full

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/35

!

interface FastEthernet0/36

!

interface FastEthernet0/37

!

interface FastEthernet0/38

!

interface FastEthernet0/39

!

interface FastEthernet0/40

!

interface FastEthernet0/41

!

interface FastEthernet0/42

!

interface FastEthernet0/43

!

interface FastEthernet0/44

!

interface FastEthernet0/45

!

interface FastEthernet0/46

!

interface FastEthernet0/47

!

interface FastEthernet0/48

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/2

!

interface VLAN1

ip address 192.168.2.6 255.255.255.0

no ip directed-broadcast

no ip route-cache

!

snmp-server engineID local 0000000902000003E335E7C0

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps snmp authentication linkdown linkup coldstart

snmp-server enable traps vlan-membership

snmp-server enable traps config

snmp-server enable traps entity

snmp-server enable traps bridge

snmp-server enable traps hsrp

snmp-server enable traps c2900

snmp-server enable traps mac-notification

snmp-server enable traps vtp

snmp-server enable traps cluster

!

line con 0

transport input none

stopbits 1

line vty 0 4

privilege level 15

password henry999

login local

transport input telnet

line vty 5 15

password henry999

no login

!

end

3620

3620#show run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 3620

!

!

username woodjl1650 privilege 15 password 7 151A0E021633727D71

!

!

!

!

ip subnet-zero

ip domain-name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

!

ip dhcp pool D-ViewCam

   network 192.168.3.0 255.255.255.0

   dns-server 192.168.2.127 8.8.8.8

   domain-name home.jkkcc.com

!

!

!

!

process-max-time 200

!

interface Ethernet0/0

ip address 192.168.3.1 255.255.255.0

no ip directed-broadcast

ip nat inside

!

interface Ethernet0/1

ip address 10.0.1.10 255.255.255.252

no ip directed-broadcast

ip nat inside

!

router eigrp 1

network 192.168.0.0

network 192.168.2.0

!

no ip classless

ip route 0.0.0.0 0.0.0.0 192.168.2.1

ip http server

ip http authentication local

!

snmp-server engineID local 000000090200000C30C3E340

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps casa

!

line con 0

transport input none

speed 115200

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

!

end

3640

3640#show run

Building configuration...

Current configuration : 1788 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 3640

!

boot-start-marker

boot-end-marker

!

!

memory-size iomem 10

no aaa new-model

ip subnet-zero

!

!

ip cef

ip domain name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

ip dhcp excluded-address 192.168.1.1 192.168.1.150

!

ip dhcp pool 192.168.1.0/24

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 192.168.2.127 192.168.1.128

!

!

!

!

!

!

!

!

!

!

!

!

username woodjl1650 privilege 15 password 0 henry999

!

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip route-cache flow

shutdown

duplex auto

speed auto

!

interface Serial0/0

ip address 10.0.1.6 255.255.255.252

clock rate 2000000

no fair-queue

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/1

no ip address

clock rate 2000000

!

interface Ethernet1/0

ip address 10.0.1.13 255.255.255.252

half-duplex

!

interface Ethernet1/1

no ip address

shutdown

half-duplex

!

router eigrp 1

network 10.0.0.0

network 192.168.0.0

no auto-summary

!

ip nat inside source list 15 interface FastEthernet0/0 overload

ip http server

ip http authentication local

ip classless

ip route 0.0.0.0 0.0.0.0 10.0.1.5

!

!

access-list 15 permit 192.168.1.0 0.0.0.255

access-list 15 permit 192.168.2.0 0.0.0.255

access-list 15 permit 10.0.1.4 0.0.0.3

access-list 15 permit 10.0.1.8 0.0.0.3

!

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

!

!

!

!

!

dial-peer cor custom

!

!

!

!

line con 0

speed 115200

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

!

end

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Connecting 2 Routers via Ethernet

Jonathan

What you describe in your most recent post does not match what is in the configuration that you posted. And I am not sure which is correct.

If the config is correct then I understand your problem. In the config that you posted both port 15 and port 33 are in the default VLAN of VLAN 1. In this case when you connect Eth0/1 you have both router ports in the same VLAN and a layer 2 loop is created. If the config is not correct then perhaps you can post the correct config?

HTH

Rick

14 REPLIES
Hall of Fame Super Silver

Connecting 2 Routers via Ethernet

Jonathan

There are some things that you have not told us which might be part of the problem, such as which switch ports connect to the routers. So a more complete explanation of the topology of the network might be helpful.

But I do see a problem which would prevent the routers being able to communicate with each other. There is no subnet in common. I am assuming that your intention is to connect Eth0/1 on the 3620 to Eth1/0 on the 3640. But their IP addresses are in different subnets. 10.0.1.10 is in subnet 10.0.1.8 while 10.0.1.13 is in subnet 10.0.1.12. The easy fix would be to change the subnet mask on the interfaces to make it a larger subnet which would include both addresses.

HTH

Rick

New Member

Connecting 2 Routers via Ethernet

3620 is connected to swithport 1 and 3640 is switchport 15.  Once I change the ip address to be on the same subnet, I will be able to ping throughout the entire network, correct

New Member

Connecting 2 Routers via Ethernet

Jonathan,

Little more explanation requied on the topology.

What port of 3620 and 3640 are connected to swithport 1 and 15 respectively??

-Vijay

New Member

Connecting 2 Routers via Ethernet

3620 - Ethernet 0/1 to 3500XL Switch Port 0/1

3640 - Ethernet 1/0 t0 3500XL Switch Port 0/15

I also have a 3745 connected via serial connection to the 3640 that works just fine.  Once we get the 3620 connected to the 3640 will the 3620 be able to "talk" to the 3745?

Also, normal straight through cables is all I need, or do I need crossover or any other ethernet cable?

New Member

Re: Connecting 2 Routers via Ethernet

3620 - Ethernet 0/1 to 3500XL Switch Port 0/1

3640 - Ethernet 1/0 t0 3500XL Switch Port 0/15

I also have a 3745 connected via serial connection to the 3640 that works just fine. Once we get the 3620 connected to the 3640 will the 3620 be able to "talk" to the 3745?

Also, normal straight through cables is all I need, or do I need crossover or any other ethernet cable?

Sent from Cisco Technical Support iPhone App

Hall of Fame Super Silver

Connecting 2 Routers via Ethernet

Jonathan

switch ports 0/1 and 0/15 are both in vlan 500. So once you straighten out the subnet masking so that the 3620 and the 3640 are in the same subnet then they should communicate with each other.

There is at least one problem that will prevent the 3620 from communicating with the 3745. The configuration of EIGRP on the 3620 has 2 network statements. They are for 192.168.0.0 and 192.168.2.0. But neither of these are networks in the interface configuration. And there is no network statement for 10.0.0.0 so EIGRP will not run on interface Ethernet0/1. And without EIGRP running on that interface the 3620 will not have a route to get to the 3745. If you add a network statement for 10.0.0.0 (and assuming that the 3745 is participating in EIGRP) then I think that the 3620 should be able to talk to the 3745.

HTH

Rick

New Member

Re: Connecting 2 Routers via Ethernet

Ok, looks like I am going to need some help with the subnets (this is just a home lab, so if we have to change them all, I am fine with that).

I still can't ping anything from my 3620 router...Below are all my running configs:

3620

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 3620

!

!

username woodjl1650 privilege 15 password 7 151A0E021633727D71

!

!

!

!

ip subnet-zero

ip domain-name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

!

ip dhcp pool D-ViewCam

   network 192.168.3.0 255.255.255.0

   dns-server 192.168.2.127 8.8.8.8

   domain-name home.jkkcc.com

!

!

!

!

process-max-time 200

!

interface Ethernet0/0

ip address 192.168.3.1 255.255.255.252

no ip directed-broadcast

ip nat inside

!

interface Ethernet0/1

ip address 192.168.3.5 255.255.255.252

no ip directed-broadcast

ip nat inside

!

router eigrp 1

network 10.0.0.0

network 192.168.0.0

!

no ip classless

ip route 0.0.0.0 0.0.0.0 192.168.2.1

ip http server

ip http authentication local

!

snmp-server engineID local 000000090200000C30C3E340

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps casa

!

line con 0

transport input none

speed 115200

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

!

end

3640

Building configuration...

Current configuration : 1804 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 3640

!

boot-start-marker

boot-end-marker

!

!

memory-size iomem 10

no aaa new-model

ip subnet-zero

!

!

ip cef

ip domain name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

ip dhcp excluded-address 192.168.1.1 192.168.1.150

!

ip dhcp pool 192.168.1.0/24

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 192.168.2.127 192.168.1.128

!

!

!

!

!

!

!

!

!

!

!

!

username woodjl1650 privilege 15 password 0 henry999

!

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip route-cache flow

shutdown

duplex auto

speed auto

!

interface Serial0/0

ip address 10.0.1.12 255.255.255.248

clock rate 2000000

no fair-queue

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip route-cache flow

shutdown

duplex auto

speed auto

!

interface Serial0/1

no ip address

clock rate 2000000

!

interface Ethernet1/0

ip address 192.168.3.2 255.255.255.252

half-duplex

!

interface Ethernet1/1

no ip address

shutdown

half-duplex

!

router eigrp 1

network 10.0.0.0

network 192.168.0.0

no auto-summary

!

ip nat inside source list 15 interface FastEthernet0/0 overload

ip http server

ip http authentication local

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.2.1

!

!

access-list 15 permit 192.168.1.0 0.0.0.255

access-list 15 permit 192.168.2.0 0.0.0.255

access-list 15 permit 10.0.1.4 0.0.0.3

access-list 15 permit 10.0.1.8 0.0.0.3

!

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

!

!

!

!

!

dial-peer cor custom

!

!

!

!

line con 0

speed 115200

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

!

end

3745-Internet

Building configuration...

Current configuration : 2269 bytes

!

version 12.4

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 3745-Internet

!

boot-start-marker

boot system flash:

boot-end-marker

!

no logging buffered

!

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local

!

!

aaa session-id common

memory-size iomem 25

no network-clock-participate slot 2

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.2.1 192.168.2.150

!

ip dhcp pool HOME-Network

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   dns-server 192.168.2.127 192.168.1.128

!

ip dhcp pool home-network

!

!

ip domain name www.jkkcc.com

ip name-server 192.168.2.127

!

multilink bundle-name authenticated

parameter-map type regex sdm-regex-nonascii

pattern [^\x00-\x80]

!

!

!

!

!

!

!

username woodjl1650 privilege 15 password 0 henry999

archive

log config

  hidekeys

!

!

!

!

!

interface FastEthernet0/0

description $FW_OUTSIDE$

ip address dhcp

ip nat outside

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/0

description $FW_INSIDE$

ip address 10.0.1.9 255.255.255.248

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/1

description $FW_INSIDE$

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/1

description $FW_INSIDE$

ip address 10.0.1.5 255.255.255.248

ip nat inside

ip virtual-reassembly

!

router eigrp 1

network 10.0.0.0

network 192.168.0.0

network 192.168.2.0

network 192.168.3.0

no auto-summary

!

!

!

no ip http server

ip http authentication local

no ip http secure-server

ip nat inside source list 15 interface FastEthernet0/0 overload

ip nat inside source static tcp 192.168.2.128 80 interface FastEthernet0/0 8100

!

access-list 15 permit 192.168.2.0 0.0.0.255

access-list 15 permit 192.168.3.0 0.0.0.255

access-list 15 permit 10.0.1.4 0.0.0.3

access-list 15 permit 10.0.1.8 0.0.0.3

access-list 15 permit 192.168.1.0 0.0.0.255

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

!

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

transport input telnet

!

!

webvpn cef

!

end

3500XL-TopSwitch

Building configuration...

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 3500XL-TopSwitch

!

!

username woodjl1650 privilege 15 password 0 henry999

!

!

!

!

!

ip subnet-zero

!

!

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface FastEthernet0/25

!

interface FastEthernet0/26

!

interface FastEthernet0/27

!

interface FastEthernet0/28

!

interface FastEthernet0/29

!

interface FastEthernet0/30

!

interface FastEthernet0/31

!

interface FastEthernet0/32

!

interface FastEthernet0/33

!

interface FastEthernet0/34

!

interface FastEthernet0/35

!

interface FastEthernet0/36

!

interface FastEthernet0/37

!

interface FastEthernet0/38

!

interface FastEthernet0/39

!

interface FastEthernet0/40

!

interface FastEthernet0/41

!

interface FastEthernet0/42

!

interface FastEthernet0/43

!

interface FastEthernet0/44

!

interface FastEthernet0/45

!

interface FastEthernet0/46

!

interface FastEthernet0/47

!

interface FastEthernet0/48

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/2

!

interface VLAN1

ip address 192.168.2.2 255.255.255.0

no ip directed-broadcast

no ip route-cache

!

snmp-server engineID local 0000000902000003E335E7C0

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps snmp authentication linkdown linkup coldstart

snmp-server enable traps vlan-membership

snmp-server enable traps config

snmp-server enable traps entity

snmp-server enable traps bridge

snmp-server enable traps hsrp

snmp-server enable traps c2900

snmp-server enable traps mac-notification

snmp-server enable traps vtp

snmp-server enable traps cluster

!

line con 0

transport input none

stopbits 1

line vty 0 4

privilege level 15

password henry999

login local

transport input telnet

line vty 5 15

password henry999

no login

!

end

3500XL-BottomSwitch

Building configuration...

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 3500XL-BottomSwitch

!

!

username woodjl1650 privilege 15 password 0 henry999

!

!

!

!

!

ip subnet-zero

!

!

!

interface FastEthernet0/1       ------->3620 e0/0

switchport access vlan 500

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16     ----------> 3640 1/0

switchport access vlan 500

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface FastEthernet0/25

!

interface FastEthernet0/26

!

interface FastEthernet0/27

!

interface FastEthernet0/28

!

interface FastEthernet0/29

!

interface FastEthernet0/30

!

interface FastEthernet0/31

!

interface FastEthernet0/32

!

interface FastEthernet0/33

!

interface FastEthernet0/34

duplex full

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/35

!

interface FastEthernet0/36

!

interface FastEthernet0/37

!

interface FastEthernet0/38

!

interface FastEthernet0/39

!

interface FastEthernet0/40

!

interface FastEthernet0/41

!

interface FastEthernet0/42

!

interface FastEthernet0/43

!

interface FastEthernet0/44

!

interface FastEthernet0/45

!

interface FastEthernet0/46

!

interface FastEthernet0/47

!

interface FastEthernet0/48

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/2

!

interface VLAN1

ip address 192.168.2.6 255.255.255.0

no ip directed-broadcast

no ip route-cache

!

snmp-server engineID local 0000000902000003E335E7C0

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps snmp authentication linkdown linkup coldstart

snmp-server enable traps vlan-membership

snmp-server enable traps config

snmp-server enable traps entity

snmp-server enable traps bridge

snmp-server enable traps hsrp

snmp-server enable traps c2900

snmp-server enable traps mac-notification

snmp-server enable traps vtp

snmp-server enable traps cluster

!

line con 0

transport input none

stopbits 1

line vty 0 4

privilege level 15

password henry999

login local

transport input telnet

line vty 5 15

password henry999

no login

!

end

Hall of Fame Super Silver

Connecting 2 Routers via Ethernet

Jonathan

You have made quite a few changes but still do not seem to understand how the subnets work. Is the 3620 still connected to the 3640 Ether0/1 to switch and switch to Ether1/0? Or has that connection changed?

Assuming that this is the connection change the subnet mask from 255.255.255.252 to 255.255.255.0. This is not the only mask that would work, but it is the easiest and most simple fix. When you change the mask these routers should communicate with each other.

If the 3745 connects using its serial0/0 to the 3640 serial 0/0 then I would think that they can communicate with each other. Is that the case?  If the connection from the 3745 is serial 0/1 then it would be a problem. Can you clarify which one it is and whether it works.

There is another problem which prevents the 3620 from communicating with the 3745. One aspect of the problem is that you have configured static default route on both routers with a next hop of 192.168.2.1. But do these routers know how to get to 192.168.2.1? If you do show ip route 192.168.2.0 on either router do they have a route? I do not think that they do.

The other part of the problem with routing is the configuration of EIGRP. Both the 3620 and the 3640 have network statements under EIGRP for 192.168.0.0 and for 10.0.0.0. But they do not have any interfaces in those networks. And the interfaces that they do have do not have network statements under EIGRP. Note that 192.168.3.0 is a very different network from 192.168.0.0. So if you put a network statement for 192.168.3.0 under both router's EIGRP then they should exchange routes.

HTH

Rick

New Member

Re: Connecting 2 Routers via Ethernet

Sorry, didn't mean to make the changes, I thought I had it figured out but I didn't.... here is what is connected to what...

3620 connected to 3500XL Switch F0/1     -----> E0/0    192.168.3.1   255.255.255.252

3640 connected to 3500XL Switch F0/16   -----> E1/0    192.168.3.2   255.255.255.252

3640 serial 0/0 10.0.1.10 255.255.255.252   ----> 3745 serial 10.0.1.9 255.255.255.252

From the 3640 to the 3745 connection is good, I am able to ping 192.168.2.1 (3745 F0/1) and 10.0.1.9 (3745 S0/0)

Could you help with the config, so that the 3620 and 3640 communicate and can talk to the 3745 as well...Like I stated before this is just a home lab, so no big deal if I need to change configs completely.  What should the 3620 and 3640 config look like just so that they communicate?

Thanks?

New Member

Re: Connecting 2 Routers via Ethernet

Ok, I figured it out...but one last issue...I am able to talke to each router, but when I enable e0/1 I loose connection.  Why?

Here is what I have:

3620:

E0/0 192.168.3.6 255.255.255.252 ------> connected to switch port 33/vlan 500

E0/1 192.168.4.1 255.255.255.0    ------->what this it be the DHCP server pool ---->connected to switchport 15 vlan 300

3640:

S0/0 10.0.1.10 255.255.255.248

E1/0 192.168.3.5 255.255.255.252 -------> connected to switchport 16/vlan 500

3745:

S0/0 10.0.1.9 255.255.255.248

S0/1 10.0.1.5 255.255.255.248

F0/0 DHCP via ISP

F0/1 192.168.2.1.255.255.255.0

EIGRP 1:  ----> set on all routers

network 10.0.0.0

network 192.168.2.0

network 192.168.3.0

network 192.168.4.0

Switch:

Ports 1 and 15 are vlan 300

Ports 16 and 33 are vlan 500

Wireless AP connected to switchport 15/vlan 300 to pull from the 192.168.4.0 DHCP pool

Hall of Fame Super Silver

Connecting 2 Routers via Ethernet

Jonathan

What you describe in your most recent post does not match what is in the configuration that you posted. And I am not sure which is correct.

If the config is correct then I understand your problem. In the config that you posted both port 15 and port 33 are in the default VLAN of VLAN 1. In this case when you connect Eth0/1 you have both router ports in the same VLAN and a layer 2 loop is created. If the config is not correct then perhaps you can post the correct config?

HTH

Rick

New Member

Connecting 2 Routers via Ethernet

your router interfaces are in diferent subnetworks:

ip address 192.168.3.1 255.255.255.0  vs  ip address 192.168.1.1 255.255.255.0

ip address 10.0.1.10 255.255.255.252  vs ip address 10.0.1.13 255.255.255.252

New Member

Re: Connecting 2 Routers via Ethernet

Figured it out...my subnetting was way off....thanks for the help and guidance.  Still learning...

Hall of Fame Super Silver

Connecting 2 Routers via Ethernet

Jonathan

I am glad that you got it worked out and that my suggestions were helpful in that process. Thank you for using the rating system to mark this question as resolved. This forum is an excellent place to share what we know and to get advice as we try to work out problems. Good luck as you continue to learn about Cisco networking. I hope you continue to be active in the forum

HTH

Rick

5314
Views
0
Helpful
14
Replies