Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

connecting 3020 blade switch to 6513

I have 2 hp c-Class enclosures..each have 2 cisco 4 total. these 4 switches connect back to 2 6513s. I am trunking between the 3020s and 6513s...however I am seeing something weird. On the 3020s, I am seeing the interfaces as up and on the 6513s I am seeing the interfaces as down. All my uplinks are fiber. The 6513s are running UDLD Aggressive. I've experimented with aggressive, non-agressive and disabled on the 3020s and have had no luck getting any link on the 6513s. I have confirmed the configurations on both both sides are exactly the same. They are also configured in channel-groups. But I have tried remving the channel-groups from the interfaces and they still did not come up on the 6513 side. Anybody ever run into a problem like this or have any suggestions on what I could try to resolve the issue?

Cisco Employee

Re: connecting 3020 blade switch to 6513

If you are running IOS on the 6500, trying using " speed nonegotiate" under the interface configuration.If your cable and GBIC modules are fine, then it should help you.

-amit singh

Community Member

Re: connecting 3020 blade switch to 6513

Thank you. This did work on getting the physical link up. I am now having a problem passing traffic. It appreas that the 3020 is not receiving traffic from the 6513.

6513 should be the root bridge for the VLAN, but both devices are showing as root. It appears that there is no communication at layer 2. i am also not seeing the CDP neighbors.

I have tried configuring the links as etherchannel, and removing the etherchannel-leaving just the trunk configured, and also configured the ports as an acess port. all 3 tries gave me the same result.

also, another thing that seemed odd was when I reloaded the 3020 and when it came back up, I had the opposite problem as the first. I saw link up on the 6513 and link down on the 3020. I had to go back on the 6513 and do a 'no speed nonegotiate' then a 'speed nonegotiate' to get the physical link back up.

Any other suggestions?


Re: connecting 3020 blade switch to 6513

Were you ever able to get traffic to go between your 6513 and your 3020? I'm having the exact same problem but I have a pair of 4500's connecting to my 3020's.


Community Member

Re: connecting 3020 blade switch to 6513

Actually I did. I found out there was a bug in the IOS that the 3020 was running. My 3020 was running 12.2(25)SEF1.

See the following link for the Software Advisory Notice.

Once I upgraded to the newest IOS available everything worked like a charm.

Another thing I would like to note is that even with the original firmware, I was able to pass traffic over copper...just not fiber.

Hopefully this solution works for you.

CreatePlease to create content