Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Connecting 3570 Switches to Nexus 2232 to migrate Server Subnets

Hello I am in the process of migrating our existing server farm subnets to our new Nexus server farm and I discovered something I wasn’t expecting. My intention is to migrate our existing legacy server farm which is comprised of for paired 3750 switches off of our core 6509s and onto the Nexus and connect them to the 2232s via multi gig port-channel connections, two port channels per switch stack. 

NOTE this is expected to be a temporary move as next year we intend to install additional N2Ks and move servers over to these directly. But to minimize the outage/downtime it will be better to move the subnets and switchs all at once.

These connections would be grouped 1 gig connections as port channels, one from each switch into one of the two 2232s.

Problem I discovered is Cisco does not intend to have switches connected to the Nexus and it immediately disables the ports when they see BPDUs.

I found a config that does work and it does fail over from one port-channel connection to the other but with the limitation that when the original port channel comes back online it does not fail back over to the original one, an acceptable situation for us. But I am wondering if Cisco would support this design if we did experience issues down the road.

The only issue I really see is to get it to work the config is different on the two N5Ks, please see the pert config below for the connections. Both are running the same OS

augs1-ba-ar17# sh ver

Cisco Nexus Operating System (NX-OS) Software

TAC support: http://www.cisco.com/tac

Copyright (c) 2002-2011, Cisco Systems, Inc. All rights reserved.

The copyrights to certain works contained herein are owned by

other third parties and are used and distributed under license.

Some parts of this software are covered under the GNU Public

License. A copy of the license is available at

http://www.gnu.org/licenses/gpl.html.

Software

  BIOS:      version 3.5.0

  loader:    version N/A

  kickstart: version 5.0(3)N2(1)

  system:    version 5.0(3)N2(1)

  power-seq: Module 1: version v3.0

             Module 3: version v5.0

  uC:        version v1.2.0.1

  BIOS compile time:       02/03/2011

  kickstart image file is: bootflash:/n5000-uk9-kickstart.5.0.3.N2.1.bin

  kickstart compile time:  6/13/2011 6:00:00 [06/13/2011 09:43:33]

  system image file is:    bootflash:/n5000-uk9.5.0.3.N2.1.bin

  system compile time:     6/13/2011 6:00:00 [06/13/2011 11:33:42]

augs1-ba-ar17# sh run

interface Ethernet101/1/31

  description Eth101/1/31 Portchannel_31 Int 1 of 2 augs1-ba-sw90_G2-0-25

  switchport trunk allowed vlan 1,105,107

  speed 1000

  channel-group 31

interface Ethernet101/1/32

  description Eth101/1/32 Portchannel_31 Int 2 of 2 augs1-ba-sw90_G2-0-26

  switchport trunk allowed vlan 1,105,107

  speed 1000

  channel-group 31

interface port-channel31

  description Eth101/1/31-32 to augs1-ba-sw90

  switchport mode trunk

  switchport trunk allowed vlan 1,105,107

  speed 1000

augs1-ba-ar18# sh run

interface Ethernet102/1/31

  description Eth102/1/31 Port_Ch_32 Int 2 of 2 augs1-ba-sw90_G2-0-28

  switchport mode trunk

  switchport trunk allowed vlan 1,105,107

  speed 1000

  channel-group 32

interface Ethernet102/1/32

  description Eth102/1/31-32 to augs1-ba-sw90

  switchport mode trunk

  switchport trunk allowed vlan 1,105,107

  speed 1000

  channel-group 32

interface port-channel32

  description Eth101/1/31-32 to augs1-ba-sw90

  switchport mode trunk

  switchport trunk allowed vlan 1,105,107

THIS IS THE SWITCH CONNECTED to the NEXUS

Augs1-ba-sw90

!

interface GigabitEthernet2/0/25

description PC1 augs1-ba-ar17_E1-9

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet2/0/26

description PC1 augs1-ba-ar17_E1-10

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet2/0/27

description PC2 augs1-ba-ar18_E1-9

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode on

!

interface GigabitEthernet2/0/28

description PC2 augs1-ba-ar18_E1-10

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode on

!

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree guard none

!

interface Port-channel2

switchport trunk encapsulation dot1q

switchport mode trunk

switchport backup interface Po1

spanning-tree guard none

!

Note no switchport mode trunk on the ports on the AR17 box.  When I attempt to add it I I have to first remove the channel-gr command and then when I go to add channel-gr command back I get an error saying the port is not compatible??  Any thoughts on why this is on AR17 and not on AR18?

augs1-ba-ar17(config)# int eth101/1/31

augs1-ba-ar17(config-if)# switchport mode trunk

                                       ^

% Invalid command at '^' marker.

augs1-ba-ar17(config-if)# switchport ?

  host     Set port host

  monitor  Monitor session related traffic

augs1-ba-ar17(config-if)# no channe-gr 31

                                   ^

% Invalid command at '^' marker.

augs1-ba-ar17(config-if)# no channel-group 31

augs1-ba-ar17(config-if)# switchport ?

  <CR>

  access       Set access mode characteristics of the interface

  autostate    Include or exclude this port from vlan link up calculation

  block        Block specified outbound traffic for all VLANs

  description  Enter description of maximum 80 characters

  host         Set port host

  mode         Enter the port mode

  monitor      Configures an interface as span-destination

  monitor      Monitor session related traffic

  priority     CoS Priority parameter

  trunk        Configure trunking parameters on an interface

  voice        Set voice mode characterestics of the interface

augs1-ba-ar17(config-if)# switchport mode trunk

augs1-ba-ar17(config-if)# channel-gr 31

command failed: port not compatible [port mode]

augs1-ba-ar17(config-if)#

Any thoughts as to why the config has to be different from one 5548 to the other?

Do you think Cisco TAC will support this setup if I call in for an issue?

Thanks

~ Phil

5 REPLIES
Bronze

Connecting 3570 Switches to Nexus 2232 to migrate Server Subnets

Hi Phil,

We've not had any problems linking 3750s (Specifically 3750-E and 3750-X) to Nexus via PVCs and Portchannels, however we always link them to the 5K directly rather than to one of the FEX's

Is it possible for you to connect to the main NEXUS chassis (5K/7K etc) instead of a fabric extender?

Cheers,

Nick

New Member

Connecting 3570 Switches to Nexus 2232 to migrate Server Subnets

Hi Nick thanks for the response, so first as far as my config goes do you see where one has the switchport trunk command on the physical interfaces and the other N5K does not?  Any idea on that?

As for plugging directly into the N5K that is what I first attempted but when I would look at the interface it did not recognize the SFP.  I am using regular 1G SFPs adn the N5K does not recognize them, the port would not come up so I tried it on the 2232 and it worked there but with the wierd difference in configuration.

Thanks

~ Phil

Bronze

Connecting 3570 Switches to Nexus 2232 to migrate Server Subnets

Hi Phil,

Several ports on the 5K can only take SFP+ modules, while some can take both SFP and SFP+. I don't remember offhand which are which, but that is likely the cause of that particular issue.

I'd imagine that in order to get the port channel working properly you need to default the config on the interfaces you want to add, then add them to the port channel, then set the port channel to be a trunk and see if that works.

I'd also advise against using etherchannel set ON, and would use LACP instead (mode active) as this gives you better protection against misconfiguration, and more troubleshooting options when something doesn't work, but that is just my personal preference.

Nick

Bronze

Connecting 3570 Switches to Nexus 2232 to migrate Server Subnets

Hi Again,

Just spoke to my Colleague who is more NEXUS that I and he said that ports 1-20 on the Nexus 5020 can take SFP.  I'm not sure if that helps at all...

Nick

New Member

Connecting 3570 Switches to Nexus 2232 to migrate Server Subnets

Hi Nick thanks a lot, that could be my problem, I am using standard SFPs and I was trying to use the LAST ports for my testing so it would be obvious they were for testing.  I will give it another go in a closer port.

Also, As for the channel group ON setting.  I am pretty sure that was the only way I could get it to work with a 3750 switch, I thought I saw that in another thread somewhere to use that config and it came up.

Ill re-visit it, unfortunatly we are in a change freeze till the end of the year so I cant play.

~ Phil

953
Views
0
Helpful
5
Replies
CreatePlease login to create content