Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

connecting a 2960s and 3750 switch

hi

i have 1 stack of 4x 3750 switches with a data and voip vlan (vlan3 and vlan 33)


i recently purchased 2x 2960s switches which are stacked and have 2 vlans (vlan3 and vlan103)

vlan 103 is for iscsi/san storage

I would like to connect ports 1/0/1 and 2/0/1 (vlan3) of the 2960s switches to port 1/0/1 and 2/0/1 of the 3750 stack  (just to clarify i do not want to stack these together but just connect them using an ethernet cable and by connecting 2 cables have a redundant setup)

i only want vlan3 traffic to go between the 3750 and 2960 switches and none of the other vlans


how do i configure each of the ports on the 2960s and the 3750 to make this work. i have read the 2960s admin guide but i could not figure this out

many thanks for your help

cheers

Everyone's tags (4)
10 REPLIES
VIP Super Bronze

Re: connecting a 2960s and 3750 switch

Hi,

Connect the switches together and put both links in each switch in an Etherchannel.  If you only want vlan 3 to go over it, then you don't need to trunk the Etherchannel.

Refere to this document for configuring L-2 etherchannel

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a0080094647.shtml

HTH

Reza

New Member

Re: connecting a 2960s and 3750 switch

hi

thanks for the link

i have done some reading on this (chapter 35 for 3750 and 37 for 2960) and found some interesting insights and configured the switches and connected them but nothing happens at all, the interfaces stay down (line as well)

i have pasted the relevant config of both the 3750 and the 2960 switch and perhaps you can see the obvious thing i am doing wrong here

3750 config

no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
!
interface GigabitEthernet1/0/1
description switch_2960-1/0/1
switchport access vlan 3
switchport mode access
speed 1000
duplex full
channel-group 1 mode on
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/2
description switch_2960-2/0/2
switchport access vlan 3
switchport mode access
speed 1000
duplex full
channel-group 1 mode on
spanning-tree portfast
spanning-tree bpduguard enable

interface GigabitEthernet2/0/1
description switch_2960-2/0/1
switchport access vlan 3
switchport mode access
speed 1000
duplex full
channel-group 1 mode on
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/2
description switch_2960-1/0/2
switchport access vlan 3
switchport mode access
speed 1000
duplex full
channel-group 1 mode on
spanning-tree portfast
spanning-tree bpduguard enable
!
interface Vlan1
no ip address
shutdown
!
interface Vlan3
ip address 10.3.1.3 255.255.0.0
ip broadcast-address 10.3.255.255
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.3.1.1
ip http server
ip http secure-server
!
!
control-plane
!

2960 config


!
interface GigabitEthernet1/0/1
description switch_3750-1/0/1
switchport access vlan 3
switchport mode access
speed 1000
duplex full
channel-group 1 mode on
!
interface GigabitEthernet1/0/2
description switch_3750-2/0/2
switchport access vlan 3
switchport mode access
speed 1000
duplex full
channel-group 1 mode on

!
interface GigabitEthernet2/0/1
description switch_3750-2/0/1
switchport access vlan 3
switchport mode access
speed 1000
duplex full
channel-group 1 mode on
!
interface GigabitEthernet2/0/2
description switch_3750-1/0/2
switchport access vlan 3
switchport mode access
speed 1000
duplex full
channel-group 1 mode on
!
interface Vlan1
no ip address
shutdown
!
interface Vlan3
ip address 10.3.1.4 255.255.0.0
!
ip default-gateway 10.3.1.2
ip http server
ip http secure-server
ip sla enable reaction-alerts

i went for the channel-group mode on as this seems to be the easiest to configure (as long as you make sure it is in the same vlan, speed, duplex etc) which i think it is,

the only difference i can see is the 3750 has this configured on the ports

spanning-tree portfast
spanning-tree bpduguard enable

and the 2960 hasn't.

the consultants that came in when installing the 3750 configurd all the ports with this

when i connect the 2 switch stacks via the ehterchannel ports no lights come on the switch at all (using a straight thru cable btw but also tried crossover) but nothing happens

when i do a show interfaces gigabitEthernet 1/0/1 on the 3750 i get the following:


GigabitEthernet1/0/1 is down, line protocol is down (notconnect)
  Hardware is Gigabit Ethernet, address is 0023.5d83.be81 (bia 0023.5d83.be81)
  Description: switch_2960-1/0/1
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  Media-type configured as  connector
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 5w1d, output 3w4d, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     7997664 packets input, 2176348526 bytes, 0 no buffer
     Received 47574 broadcasts (0 multicasts)
     0 runts, 1 giants, 0 throttles
     1 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 26538 multicast, 0 pause input
     0 input packets with dribble condition detected
     28174176 packets output, 33210654757 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

and this is the output from the 2960

show interfaces gigabitEthernet 1/0/1
GigabitEthernet1/0/1 is down, line protocol is down (notconnect)
  Hardware is Gigabit Ethernet, address is 1c17.d3f4.8f81 (bia 1c17.d3f4.8f81)
  Description: switch_3750-1/0/1
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 1w0d, output 1w0d, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     770 packets input, 85015 bytes, 0 no buffer
     Received 98 broadcasts (29 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 29 multicast, 0 pause input
     0 input packets with dribble condition detected
     893 packets output, 556254 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

is there anything obvious i am doing wrong here?

many thanks

Cisco Employee

Re: connecting a 2960s and 3750 switch

Hello,

What kind of cable you are using to connect these two interfaces? Can you

try a crossover cable and see if that helps? Also, you do need to remove

"spanning-tree bpduguard enable" from the interfaces as they would force the

ports to go errdisabled.

Hope this helps.

Regards,

NT

New Member

Re: connecting a 2960s and 3750 switch

i have tried both crossover and straight thru cable, makes no difference

also removed the spanning-tree portfast and spanning-tree bpduguard enable from the interface but does not make a difference

no lights come on on either end and the interfaces remain down.

Cisco Employee

Re: connecting a 2960s and 3750 switch

Hello,

This seems more like a physical layer issue. Can you try setting the

speed/duplex to auto on both ends?

interface gi 1/0/1

speed auto

duplex auto

Also, if you are using any patch panels, please bypass them and see if you

get the link.

Hope this helps.

Regards,

NT

Hall of Fame Super Gold

Re: connecting a 2960s and 3750 switch

If both switches are connected using copper, then why not use the "test cable tdr" function of both?  This will validate if you indeed have a cable problem or not.

New Member

Re: connecting a 2960s and 3750 switch

the 2 switches are connected directly with 4x straigh thru ethernet cables

i ran the tdr tests and everything is showing up as normal

only difference is that the 3750 reports the length to be +- 4 meters and the 2960 +-0 meters

Interface Speed Local pair Pair length        Remote pair Pair status
--------- ----- ---------- ------------------ ----------- --------------------
Gi1/0/1   1000M Pair A     1    +/- 0  meters N/A         Normal
                Pair B     2    +/- 0  meters N/A         Normal
                Pair C     2    +/- 0  meters N/A         Normal
                Pair D     2    +/- 0  meters N/A         Normal

Interface Speed Local pair Pair length        Remote pair Pair status
--------- ----- ---------- ------------------ ----------- --------------------
Gi1/0/1   1000M Pair A     2    +/- 4  meters N/A         Normal
                Pair B     2    +/- 4  meters N/A         Normal
                Pair C     2    +/- 4  meters N/A         Normal
                Pair D     2    +/- 4  meters N/A         Normal

as i have a support contract with the company that did the installation they are testing this in their lab and will get back to me with any changes i need to make, i will report back as soon as i hear from them

cheers!

New Member

Re: connecting a 2960s and 3750 switch

Hi,

Did you check the status of the STP? Maybe you have to do an extra config on the 3750 to get the channel up and running.

I had strange issues when connecting 2 3750 stacks together with a channel master-master  slave-slave, but they work now....

Try switching off any 'optional' features on the ports when setting up the channel, and when connected, work your way 'up'

Regards,


Quirijn

New Member

Re: connecting a 2960s and 3750 switch

hi

i could not get it to work with straight thru cables and when i tried with a cross over cable it initially did not work either, until i bought 4 brand new crossover cables and now it is working fine.

there must have been some cabling fault in the crossover cable because with the brand new ones it is working fine and i have a 4gb connection between the 2 servers.

cheers

New Member

Re: connecting a 2960s and 3750 switch

quick comment..... on the 3750 you have 'port-channel 1' interface defined - because the

IOS will make a dumb config for it when you assign an interface to that channel-group if it

doesnt exist... .however, you dont have a port-channel defined on the 2960s - so those

interfaces are tagged to a virtual interface that doesnt exist.  define the port-channel interface

on the 2960 and it should spring to life.

alan

4610
Views
0
Helpful
10
Replies
CreatePlease to create content