Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Blue

Connecting a Router to L3 Switch

I am confused about something...

Presently, a 7200 router's fa0/0 interface is connected to a L3 hybrid 6509 switch's 2/1 interface. The configs are as follows:

(router)

interface faste 0/0

ip address 10.10.10.4/24

(switch)

set vlan 5

set vlan 5 2/1

(msfc)

interface vlan 5

ip address 10.10.10.1/24

So, by placing the switchport in a vlan and creating an SVI, an L3, routed connection is facilitated between the router and the switch. Correct?

OK, I need to migrate from the hybrid 6509 switch to a fully NATIVE-IOS 6509 switch.

How do I configure the fastE port? The router must exhange routing updates with the L3 switch's eigrp process, as is already the case with the hybrid switch architecture.

Should the L3 fastE switch port be configured like this:

vlan 5

name WAN_xport

interface fastE 2/1

ip address 10.10.10.1/24

(just like a regular router)

OR

should I create the vlan SVI interface and then simply place the switchport in the vlan as you do in a hybrid switch (see below):

vlan 5

name WAN_xport

interface vlan 2

ip address 10.10.10.1/24

interface faste 2/1

switchport

switchport access vlan 5

switchport mode access

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Connecting a Router to L3 Switch

Hi Andrea,

No apologies my friend :) This happens to me a lot ... it doesn't matter you solve the problem or me, as long as we are helping the original poster.

BR,

Mohammed Mahmoud.

5 REPLIES

Re: Connecting a Router to L3 Switch

Hi,

You can go with any of both approaches, according to your topology, if you require more ports to use this VLAN and have an SVI interface to route this VLAN traffic go with the second solution, while if you require only point to point connectivity between the switch and the router go with the first solution.

HTH, pleas do rate all helpful replies,

Mohammed Mahmoud.

Silver

Re: Connecting a Router to L3 Switch

Hi,

both configurations work, but the first in your design could have more sense. If you need just a routed port, the first is enough. If you would that router will be the vlan5 default gateway, so use the second (without SVI if you please, that's not necessary).

The difference between configurations is: the first is a routed port, so consider that just a L3; the second is a switchport (in your case in access mode, but could be have more sense in another scenario in case of trunk mode, carrying more vlans), so a L2 port that has a L3 virtual interface corresponding the vlan in access.

more infos about difference between routed port and SVI:

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_guide_chapter09186a00801cdea4.html#1288561

HTH

Andrea

[edit] I'm sorry, Mohammed, I've seen your post late

Re: Connecting a Router to L3 Switch

Hi Andrea,

No apologies my friend :) This happens to me a lot ... it doesn't matter you solve the problem or me, as long as we are helping the original poster.

BR,

Mohammed Mahmoud.

Silver

Re: Connecting a Router to L3 Switch

correct ;)

thanks Mohammed

Andrea

Blue

Re: Connecting a Router to L3 Switch

Thank you to the both of you.

Mohammed, you hit the nail on the head. Not only did you answer the question, but you preempted me asking the follow-up, which would have been regarding the case of adding more router connections in the same vlan. :-)

In fact, there are several router connections that the client has placed in the same vlan, so I would use the second scenario.

Andrea, thank you for your input and the link. I will check it out further.

136
Views
13
Helpful
5
Replies
CreatePlease to create content