Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

connecting a WS-C4948 to a Nexus 5010

is it possible to connect a WS-C4948 switch to a Nexus 5010? I have a flat network with no vlans.I know you are suppose to use the first 8 ports of the Nexus to get it to be on a 1GB port. What gbic am i to use on the ws-c4948 switch? if using a fiber cable or a rj45 cable?

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

connecting a WS-C4948 to a Nexus 5010

You config on the Nexus is not correct.  You need to remove the ip address on the managment interafce and assign it to vlan 1 and add interface e1/1 to vlan 1, which should be default.

configuration on Nexus 5010:

interface Ethernet1/1

speed 1000

vrf context management

ip route 0.0.0.0/0 10.x.x.1

interface mgmt0

no ip address 10.x.x.223/8

interface vlan 1

ip address 10.x.x.238/8

no sh

now, you should be able to ping from the 5k to the 4849

HTH

6 REPLIES
Hall of Fame Super Gold

connecting a WS-C4948 to a Nexus 5010

Yes you can.

You must be aware that Nexus has BPDU Guard PERMANENTLY turned on.  So when you connect your switch to Nexus 5K the port will immediately go into "error disable".

The only way around this is to disable STP portfast on the Nexus 5K side.

New Member

Re: connecting a WS-C4948 to a Nexus 5010

WS-C4849 <---------------> Nexus 5010 (connected with a cat 6 ethernet cable)

WS-C4849 interface GigabitEthernet1/48

Nexus 5010 interface Ethernet1/1 (using a Cisco 1000BASE-T SFP Transceiver Module for Category 5 copper wire, spare

Mfg. Part#: GLC-T )

configuration on WS-C4849:

interface GigabitEtherenet1/48

media-type rj45

interface Vlan1

ip address 10.x.x.226 255.0.0.0

ip default-gateway 10.x.x.1

configuration on Nexus 5010:

interface Ethernet1/1

speed 1000

vrf context management

ip route 0.0.0.0/0 10.x.x.1

vlan 1

interface mgmt0

ip address 10.x.x.223/8

I have green lights on these ports, and showing interface is saying that the interface is up and connected.

what else would I need to configure to pass traffic between them?

Hall of Fame Super Gold

connecting a WS-C4948 to a Nexus 5010

Configure the ports to be 802.1q Trunking.

VIP Super Bronze

connecting a WS-C4948 to a Nexus 5010

You config on the Nexus is not correct.  You need to remove the ip address on the managment interafce and assign it to vlan 1 and add interface e1/1 to vlan 1, which should be default.

configuration on Nexus 5010:

interface Ethernet1/1

speed 1000

vrf context management

ip route 0.0.0.0/0 10.x.x.1

interface mgmt0

no ip address 10.x.x.223/8

interface vlan 1

ip address 10.x.x.238/8

no sh

now, you should be able to ping from the 5k to the 4849

HTH

New Member

connecting a WS-C4948 to a Nexus 5010

I was able to get it to work.....thank  you for the guys who responded!!

configuration on the WS-C4948:

interface GigabitEthernet1/48

description connection to nexus5010

media-type rj45

interface Vlan1

ip address 10.x.x.226 255.0.0.0

ip default-gateway 10.x.x.1

configuration on the Nexus 5010:

vrf context management

vlan 1

interface Vlan1

  no shutdown

  ip address 10.x.x.223/8

interface Ethernet1/1

  switchport mode trunk

  speed 1000

steps on adding vlan 1 and adding an IP address on the Nexus 5010:

- remove int mgmt 0, ip address and vrf context management

nexus5010(config)# int mgmt 0

nexus5010(config-if)# no ip address

nexus5010(config-if)# vrf context management

nexus5010(config-vrf)# no ip route 0.0.0.0/0 10.x.x.1

nexus5010(config-vrf)# exit

- turn on feature interface-vlan, create int vlan 1, add IP address, no shut, add vrf context default

nexus5010(config)# feature interface-vlan

nexus5010(config)# int vlan 1

nexus5010(config-if)# ip address 10.x.x.223/8

nexus5010(config-if)# no shut

nexus5010(config-if)# exit

nexus5010(config)# vlan 1

nexus5010(config-vlan)# exit

nexus5010(config)# vrf context default

nexus5010(config)# ip route 0.0.0.0/0 10.x.x.1

nexus5010(config)# exit

VIP Super Bronze

connecting a WS-C4948 to a Nexus 5010

Your Nexus config looks good now.

If you ever want to manage the switch using the out of band port (mgmt0) you need to give it an IP address:

Example:

nexus5010(config)# int mgmt 0

nexus5010(config-if)#ip address 192.168.1.1/24

HTH

364
Views
0
Helpful
6
Replies
CreatePlease login to create content