Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Connecting Catalyst 4507R and Catalyst 2950 - Vlans and Trunking

I am having an issue networking a Cisco 4507R and Catalyst 2950 Series.

I have only worked with simple vlans so please forgive me. They have

the same encapsulation and everything seems fine to me but I can't ping

between them. Here are my configs

Catalyst 2950 Series

interface GigabitEthernet0/1

switchport access vlan 405

switchport trunk native vlan 405

switchport mode trunk

!

Catalyst 4507R

interface GigabitEthernet2/1

switchport access vlan 405

switchport trunk encapsulation dot1q

switchport trunk native vlan 405

switchport mode trunk

switchport nonegotiate

!

Here is what else I have

--Catalyst 4507R--

show int g2/1 switchport

Name: Gi2/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Off

Access Mode VLAN: 405 (N-1-Connect)

Trunking Native Mode VLAN: 405 (N-1-Connect)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Voice VLAN: none (Inactive)

Appliance trust: none

Surveillance#

Here is what I have for my Catalyst 2950 Series

Name: Gi0/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 405 (VLAN0405)

Trunking Native Mode VLAN: 405 (VLAN0405)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Unknown unicast blocked: disabled

-Unknown multicast blocked: disabled

Appliance trust: none

AL-SURV-L2#

The vlan 405 is in the vlan database of the Catalyst 4507R with an ip

address 192.168.122.4. It is apply to the g2/1 interface. Do I have

to create a 405 vlan with an IP address on the 2950 and apply it to the

g0/1 interface?

Any help is greatly appreciated. Thanks.

13 REPLIES

Re: Connecting Catalyst 4507R and Catalyst 2950 - Vlans and Trun

You need to create two layer-3 vlan interfaces.

Example-

switch#(config)interface vlan 405

switch#(config-if)ip address 192.168.122.4 255.255.255.0

switch#(config-if)no shut

This will allow hosts on vlan 405 to use 192.168.122.4 as a gateway.

New Member

Re: Connecting Catalyst 4507R and Catalyst 2950 - Vlans and Trun

Thanks for the reply. But can I do this when the Catalyst 2950 is a layer 2 switch?

Re: Connecting Catalyst 4507R and Catalyst 2950 - Vlans and Trun

You should do it on the 4500.

New Member

Re: Connecting Catalyst 4507R and Catalyst 2950 - Vlans and Trun

I believe I have done that. Here it is in the config of the 4507R, sorry I didn't post it earlier.

interface Vlan405

description Connection to XXXXXXXXX

ip address 192.168.122.4 255.255.255.0

!

Then I applied this vlan to the g2/1 on the 4507R

Purple

Re: Connecting Catalyst 4507R and Catalyst 2950 - Vlans and Trun

Is there a reason you are trunking if you are only passing vlan 405 between the boxes ????

New Member

Re: Connecting Catalyst 4507R and Catalyst 2950 - Vlans and Trun

It's vendor specific. Streaming video traffic will be going between these switches and that's the only way the vendor says it will work. Also don't I need it if I want to route other vlan traffic between the switches?

New Member

Re: Connecting Catalyst 4507R and Catalyst 2950 - Vlans and Trun

Please disregard the last paragraph. I thought I deleted it out. I realize that the Catalyst is a Layer 2 device. Sorry for the confusion. Thanks.

Bronze

Re: Connecting Catalyst 4507R and Catalyst 2950 - Vlans and Trun

Rob,

Is quite simple to understand a typical scenario. You will have the 4507 switch as the core of your network. On this switch, you going to create the VLAN in the VLAN database or through the VTP.

After that, you have to create the VLAN interface for that VLAN, specify an IP address for that and enable it by issue the 'no shut' command.

Once you have done it, the interfaces that connects the switch 4507 and 2950 should have the 802.1q (VLAN Trunking) enabled. On the 2950 you may check if the VTP already propagated the VLAN information. If you are not using the VTP, you have to create by yourself manually.

Ok! This is the typical environment. Certify that the VLAN 1 have a interface VLAN created in the 4597 too with an IP address. Check if the workstations you're using have the default gateway correctly configured.

If it is okay, the ping should work.

If you're in doubt with something I told you. Please ask. And if it resolved your problem, please rate.

Best regards,

Rafael Lanna

Re: Connecting Catalyst 4507R and Catalyst 2950 - Vlans and Trun

Hi Rob,

In addtion to the above post, you dont need an IP address on the 2960 switches as such as your 4500 will be doing the routing. As it is layer 2 switch you need an IP addess on 2960, just to manage it remotely. If you have trunk setup correctly between the switches and you have the Layer 3 interfaces ie SVI created for all the vlans on 4500 your routing should work fine.

HTH,

-amit singh

New Member

Re: Connecting Catalyst 4507R and Catalyst 2950 - Vlans and Trun

Thanks for the reply. I have done the second and third paragraphs. I created the vlan 405 and gave it an IP address. I verified the vlan in the vlan database of the 4507R. I then applied the 405 vlan to the correct interface. I have dot1q encapsulation on both interfaces that I am trying to trunk. So your saying if they are talking via VTP, it should propagate vlan information from the 4507R to the 2950? When I set 4507R into trunk mode does it automatically turn on VTP? Or do I have to enable it? Also how can I check if the vlan information propagated to the 2950?

Also I am trying to ping from insided the switches, not from a workstation. Again thanks for the help.

Catalyst 2950 Series

interface GigabitEthernet0/1

switchport access vlan 405

switchport trunk native vlan 405

switchport mode trunk

!

Catalyst 4507R

interface GigabitEthernet2/1

switchport access vlan 405

switchport trunk encapsulation dot1q

switchport trunk native vlan 405

switchport mode trunk

switchport nonegotiate

!

interface Vlan405

description Connection to XXXXXXXXXXXX

ip address 192.168.122.4 255.255.255.0

!

New Member

Re: Connecting Catalyst 4507R and Catalyst 2950 - Vlans and Trun

Check Vlan propagation with the:

show VLAN BRIEF command

If the VLAN propagated you will see Vlan 405 on the 2950. You will also see which switchports have been assigned to Vlan 405. The port you used to trunk (Gi0/1) WON'T belong to ANY Vlan, that's because it's trunking.

Also, did you assign/configure any switchports into Vlan 405?

switchport access vlan 405

Is the 2950 in the same VTP Domain with your 4507 switch? You verify it with this command:

Show VTP STATUS

If the VTP domain is different (case sensitive also), the Vlan information will NOT propagate to the 2950. Also, put the 2950 into Client mode if it is in Server Mode, you can inadvertenly wipe out all your VLANs if the VTP configuration number is higher, belongs to the same domain, is a VTP Server and does not have any of your existing VLANS. If the switch is in Transparent mode change it to Client, Transparent mode will not accept Vlan information/propagations from any other switch. In Transparent mode the Vlans are created locally and not learned from propagated VTP advertisements.

HTH

Re: Connecting Catalyst 4507R and Catalyst 2950 - Vlans and Trun

Hi Rob,

When you set the switches on trunk, it doesnot enable the VTP automatically. You have to configure the VTP manually on the switches and then it starts working. You configure one switch as the VTP server and the other switches as VTP clients. You configure the Vlans on the server and if your trunks are working properly the Vlan information via VTP will travel automatically to all the switches configured as Clients.

To check a proper VTP information on the server and client switches run the following commands"

Show vtp status, this will give you info about the

VTP revision number, which should match on all the switches and denotes that the VTP database is sync'd.

Number of vlan, which should be consistent.

Also take out the " switchport access vlan 405 " command from the trunk interfaces, you dont need it. The trunk interfaces should be configured as below:

Catalyst 2950 Series

interface GigabitEthernet0/1

switchport trunk native vlan 405

switchport mode trunk

Catalyst 4507R

interface GigabitEthernet2/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 405

switchport mode trunk

switchport nonegotiate

Also, as you are trying to ping from the 2950 switch in that case you need an IP address on the switch interface.Without any Ip address on the switch it will not be able to ping anywhere.

Do you have any ip configured on the switch interface? If not, then do the following on 2950 switch:

interface Vlan405

ip address 192.168.122.10 255.255.255.0

no shut

HTH, Please rate if it does.

-amit singh

New Member

Re: Connecting Catalyst 4507R and Catalyst 2950 - Vlans and Trun

Thanks for the reply. The 2950 Series has an ip address on it. It's 192.168.122.31. I changed the config and took the switchport access vlan 405 out. Here is what the config says

Catalyst 2950

interface GigabitEthernet0/1

switchport trunk native vlan 405

switchport mode trunk

Catalyst 4507R

interface GigabitEthernet2/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 405

switchport mode trunk

switchport nonegotiate

interface Vlan405 (On the 4507R)

description Connection to XXXXXXX

ip address 192.168.122.4 255.255.255.0

When I am telneted into the 2950 Series I can't ping 192.168.122.4, which is the Vlan 405 interface on the 4507R Catalyst.

On the 2950 Series I created a vlan 405 and gave it an ip address of 192.168.122.10, but when I try to apply it to the g0/1 interface of the 2950 series, it tells me the ip address overlaps with vlan1, which is 192.168.122.31.

Thanks for the help.

904
Views
5
Helpful
13
Replies
CreatePlease to create content