Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Connecting Nexus 5000 to VSS

Hello,

I tried to connect a new 5020 to our pair of 6500's that are running VSS. The VSS has been in production for a long time and has been working great. I created a new port-channel group on the VSS and bound two ten gig interfaces to it. I also did the same on the n5k and enabled VPC and LACP features. The problem is the VSS port-channel will never come up, it always shows a down state. Any ideas as to what configuration steps I am missing? Do I have to configure a VPC in order to communicate with the VSS??

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Connecting Nexus 5000 to VSS

Only thing I can think of here is to remove all 'channel-group' commands from interface t1/1/1 and t2/1/1, then reconfigure using 'mode active'.  Not sure but if you were trying 1 at a time, so that 1 interface is using PAGP while other is LACP, that could have causes problems.

If that doesn't work I'd suggest the same thing, but also delete interface po11 before re-configuring.

5 REPLIES
Bronze

Re: Connecting Nexus 5000 to VSS

Can you attach the interface configurations from both sides for the physical ports and the portchannel port?

Community Member

Re: Connecting Nexus 5000 to VSS

From the VSS side:

interface Port-channel11
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 411
switchport trunk allowed vlan 2,38,155,158,159,162-164,411,445,650,816,852-854
switchport trunk allowed vlan add 880,882,883,885-891,900
switchport mode trunk

interface TenGigabitEthernet1/1/1

switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 411
switchport trunk allowed vlan 2,38,155,158,159,162-164,411,445,650,816,852-854
switchport trunk allowed vlan add 880,882,883,885-891,900
switchport mode trunk
channel-group 11 mode auto

interface TenGigabitEthernet2/1/1

switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 411
switchport trunk allowed vlan 2,38,155,158,159,162-164,411,445,650,816,852-854
switchport trunk allowed vlan add 880,882,883,885-891,900
switchport mode trunk
channel-group 11 mode auto

From N5k:

interface port-channel11
  switchport mode trunk
  switchport trunk native vlan 411
  switchport trunk allowed vlan 2,38,155,158-159,162-164,411,445
  switchport trunk allowed vlan add 650,816,852-854,880,882-883,885-891
  switchport trunk allowed vlan add 900

interface Ethernet1/1
  switchport mode trunk
  switchport trunk native vlan 411
  switchport trunk allowed vlan 2,38,155,158-159,162-164,411,445
  switchport trunk allowed vlan add 650,816,852-854,880,882-883,885-891
  switchport trunk allowed vlan add 900
  channel-group 11 mode active

interface Ethernet1/2
  switchport mode trunk
  switchport trunk native vlan 411
  switchport trunk allowed vlan 2,38,155,158-159,162-164,411,445
  switchport trunk allowed vlan add 650,816,852-854,880,882-883,885-891
  switchport trunk allowed vlan add 900
  channel-group 11 mode active

When I change the channel-group mode on the VSS from auto to active, it changes back to auto for some reason??

Cisco Employee

Re: Connecting Nexus 5000 to VSS

Only thing I can think of here is to remove all 'channel-group' commands from interface t1/1/1 and t2/1/1, then reconfigure using 'mode active'.  Not sure but if you were trying 1 at a time, so that 1 interface is using PAGP while other is LACP, that could have causes problems.

If that doesn't work I'd suggest the same thing, but also delete interface po11 before re-configuring.

Community Member

Re: Connecting Nexus 5000 to VSS

I will try that and let you know. Is there anything else you can think of? I will not be able to try this until our change night on Thursday so any suggestions ahead of time are greatly appreciated!

Community Member

Re: Connecting Nexus 5000 to VSS

Thanks Chad! Starting from scratch on the port-channel did the trick.

490
Views
0
Helpful
5
Replies
CreatePlease to create content