Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Connecting two 3550 switches with VLAN IP routing

Hi, our subcontractors have finished the switch install, consisting of two Catalyst 3550 switches connected to each other via a trunk on port 47, with clients and other switches tagged off these switches.

Im having a little trouble understanding the configuration, why has the client switch got an ip address of 192.168.2.10? From my understanding it shouldnt need an address as any packets arriving on its interface will be routed across trunk between the client and core switch, where the core switch will handle the routing?? Or am i totally offtrack? When i remove VLAN3 ip address from the client switch the entire lot goes down, it is obviously needed but i dont understand why.

CORE CONFIG

version 12.2

no service pad

service timestamps debug uptime

service timestamps log datetime

no service password-encryption

service sequence-numbers

!

hostname core

!

no aaa new-model

ip subnet-zero

ip routing

!

no file verify auto

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree vlan 1-3 priority 0

!

vlan internal allocation policy ascending

!

interface GigabitEthernet0/1-20

spanning-tree portfast

!

interface GigabitEthernet0/21-35

spanning-tree portfast

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet0/36-46

spanning-tree portfast

switchport access vlan 3

switchport mode access

!

interface GigabitEthernet0/47

description connected to client as a trunk to port 47

switchport access vlan 3

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/50

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/51

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/52

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Vlan1

ip address 192.168.0.2 255.255.255.0

ip helper-address 192.168.0.31

ip helper-address 192.168.0.28

!

interface Vlan2

ip address 192.168.1.1 255.255.255.0

ip helper-address 192.168.0.31

ip helper-address 192.168.0.28

!

interface Vlan3

ip address 192.168.2.1 255.255.255.0

ip helper-address 192.168.0.31

ip helper-address 192.168.0.28

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.0.1

ip http server

!

end

CLIENT CONFIG

version 12.2

no service pad

service timestamps debug uptime

service timestamps log datetime

no service password-encryption

service sequence-numbers

!

hostname client

!

no aaa new-model

vtp domain cisco

vtp mode transparent

ip subnet-zero

ip routing

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 3

name UsersAccess

!

interface GigabitEthernet0/1-46

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/47

description connected to Core Switch As a trunk port

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Vlan1

ip address 192.168.0.5 255.255.255.0

ip helper-address 192.168.0.31

ip helper-address 192.168.0.28

!

interface Vlan3

ip address 192.168.2.10 255.255.255.0

ip helper-address 192.168.0.31

ip helper-address 192.168.0.28

!

ip classless

ip http server

!

end

Many thanks in advance,

Chris

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Connecting two 3550 switches with VLAN IP routing

Hi Friend,

HSRP is for redundancy and load sharing when you have two l3 device so that if one goes down another can handle the network.

But because you have one core switch only HSRP is not for your network.

HTH, if yes please rate all helpfull post

Ankur

17 REPLIES
Cisco Employee

Re: Connecting two 3550 switches with VLAN IP routing

Hi Chris,

In your setup I do not think you need to have layer 3 interface for vlan 3 at all on your client switch. You can only have vlan 1 for mnagement purpose.

The person who had configured your network had confiured both the switches as relay agent and had configured ip helper address on both the switch under interface vlan 3.

In your setup both the switches are configured for routing which I do not think is required.

Consult them and you can remove interface vlan 3 from your client switch or for trail before removing just shut your interface vlan 3.

Also from your core switch under interface gig0/47 remove this command "switchport access vlan 3". To do this run this command "switchport access vlan 3" under interface gig0/47 on core switch.

Now any machine on your client switch which is connected on vlan 3 will hit the core switch which will act as a DHCP relay agent and will get an ip address and for any routing part it will hit the core and core will take care of routing.

HTH

Ankur

*pls rate all helpfull post

Re: Connecting two 3550 switches with VLAN IP routing

Hi Chris,

You certainly dont need any IP on vlan 3 on the client switch. You can give it an IP just only to manage it remotely and in that case it can be managed by the Vlan IP.

What is the default-gateway for the clients sitting on the vlan 3 on the client. Please let us know the ip address on one of the client. If you remove the IP from the vlan 3 interface on the client switch the default gateway for the clients should be 192.168.2.1.

Let us know this and we will take it from there.

HTH,

-amit singh

New Member

Re: Connecting two 3550 switches with VLAN IP routing

Thanks for the reply, just as i thought but when i configure on the client switch:

interface vlan 3

no ip address

and then telnet is lost. i then need to go back through the core switch (192.168.0.2) and telnet from the ios to 192.168.0.5, that does allow me back in where i can reconfigure the vlan 3 ip address. For some reason it is needed, but doesnt make sense to me.

The users sitting on the vlan 3 client switch have 192.168.2.1 as their default gateway.

Thanks,

Chris

New Member

Re: Connecting two 3550 switches with VLAN IP routing

One other thing i would like to keep trunking between the two switches as someday we may stick other vlans on the client switch (rather than all ports as vlan 3), so removing trunk is not an option.

Cheers,

Chris

Cisco Employee

Re: Connecting two 3550 switches with VLAN IP routing

Hi Chris,

When you can telnet to 192.168.0.2 why can't u telnet directly to 192.168.0.5? Do you have a specific route to reach only 192.168.0.2?

Also no one asked you to remove trunk as it is very well necessary.

Can you update which network/vlan you are into from where you try to telnet?

Regards,

Ankur

New Member

Re: Connecting two 3550 switches with VLAN IP routing

No when i remove the client switches ip address on vlan 3 (192.168.2.10) i can no longer telnet to the client switch on 192.168.0.5?!

Re: Connecting two 3550 switches with VLAN IP routing

Chris,

Cna you attach the full config of both the switch. let us have a look at it and see what's wrong is in there.

-amit singh

New Member

Re: Connecting two 3550 switches with VLAN IP routing

Please find attached files,

Cheers,

Chris

Cisco Employee

Re: Connecting two 3550 switches with VLAN IP routing

Hi Chris,

As I asked in my previous post which VLAN you are from ? Or on which switch you are connected or on which port you are connected from where you ae trying to telnet?

Ankur

New Member

Re: Connecting two 3550 switches with VLAN IP routing

Sorry for delayed reply, i am on VLAN3, on the core switch.

New Member

Re: Connecting two 3550 switches with VLAN IP routing

interface GigabitEthernet0/47

description connected to client as a trunk to port 47

switchport trunk encapsulation dot1q

switchport mode trunk

once u change the config on the core switch port as above, does it solve ur problem ?

New Member

Re: Connecting two 3550 switches with VLAN IP routing

unfortunatly not im afraid. is this something to do with ip routing being enabled on the client? my knowledge is a bit limited so sorry for the silly questions.

Cisco Employee

Re: Connecting two 3550 switches with VLAN IP routing

Hi Chris,

I got where the problem is when you updated you are in vlan 3. Now when you remove the ip address on vlan 3 on client switch and you try to telnet to vlan 1 ip address from your machine you get routed on your core from vlan 3 to vlan 1 and will reach the client switch but your source ip address will be of vlan 3 subnet and your client switch does not know where to send a reply and is the reason you loose the connectivity when you remove an ip addrses from vlan 3.

Try this out and I am sure you will be good to go

interface vlan 3

shutdown

Then add a default route on your client switch

ip default-gateway

Update us if this resolves your issue and doubt.

HTH

Ankur

New Member

Re: Connecting two 3550 switches with VLAN IP routing

thanks for the help, that works. i have also read about HSRP... would that be of use in my situation because at the moment the core switch holds everything if that goes ill be up the creek without a paddle!!

Cisco Employee

Re: Connecting two 3550 switches with VLAN IP routing

Hi Friend,

HSRP is for redundancy and load sharing when you have two l3 device so that if one goes down another can handle the network.

But because you have one core switch only HSRP is not for your network.

HTH, if yes please rate all helpfull post

Ankur

New Member

Re: Connecting two 3550 switches with VLAN IP routing

thanks for the reply. when you say core switch what do you mean by that? both switches are the same models.

cheers, i will rate your post.

thanks,

chris

Cisco Employee

Re: Connecting two 3550 switches with VLAN IP routing

Hi Chris,

By Core switch I mean the switch which is handling your core traffic. It does not matter if they are of same model.

Your switch which you have named as client should and is working as a layer 2 switch and your switch to which you have named a core switch is working as layer 3 switch.

The design where you can implement HSRP is like when a layer 2 switch is connected to 2 uplink layer 3 switches and HSRP is configured on both the uplink switches. Your users will sit on layer 2 switch with HSRP ip address as gateway ip address and if incae your core layer 3 switch goes down your second layer 3 switch will take care of your network.

Pls look at the link and this pic will explain you the way HSRP can be implemented

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3750/12225see/scg/swhsrp.htm#wp1044171

HTH

Ankur

247
Views
0
Helpful
17
Replies