Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Consolidating VLANS

We have three VLANS and would like to combine two.  We are using "ip pim sparse-dense-mode" on each VLAN to manage multicast traffic.  We would like to run two different subnets on one VLAN.  We really don't want to readdress all of our devices.  Can I choose one of the subnet addrsses for the VLAN managment address?  Do you see any pitfalls with this configuration?

Thanks,

~c

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: Consolidating VLANS

gdwingnuts wrote:

The initial design was to keep video traffic isolated on one vlan.  Our leads wanted to simplify the overall design for our customer.  We have found over time that the video traffic is minimal with occasional bursts.  So are you saying we would need to add the second subnet to the VLAN configuration?  Take a look at our current VLAN configuration and tell me what you think:

!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
description alpha_VLAN
ip address 172.x.x.x 255.255.255.0
ip pim sparse-dense-mode
no ip proxy-arp
no shutdown
!
interface Vlan20
description beta_VLAN
ip address 192.x.x.x 255.255.255.0
ip pim sparse-dense-mode
no ip proxy-arp
no shutdown
!
interface Vlan100
description delta_VLAN
ip address 192.x.x.x 255.255.255.0
no ip proxy-arp
no shutdown
!
!
router eigrp 101
no auto-summary
network 10.x.x.x
network 172.x.x.x
network 192.x.x.x
network 192.10.x.x

Scrubbed IPs.

~c

You would need to add a secondary address to the L3 vlan interface (if supported) as this is the clients default-gateway and they still need that to route traffic.

Personally i wouldn't bother. I think using secondary addressing etc. on a L3 switch is actually not simplifying but making it more complicated because it's not what you would normally see. I can't see how removing one vlan is really making it that much more simple.

Jon

4 REPLIES
Hall of Fame Super Blue

Re: Consolidating VLANS

gdwingnuts wrote:

We have three VLANS and would like to combine two.  We are using "ip pim sparse-dense-mode" on each VLAN to manage multicast traffic.  We would like to run two different subnets on one VLAN.  We really don't want to readdress all of our devices.  Can I choose one of the subnet addrsses for the VLAN managment address?  Do you see any pitfalls with this configuration?

Thanks,

~c

Well you are going to need a secondary address on the L3 interface for the 2nd subnet. Any particular reason why you want to do this ?

Jon

New Member

Re: Consolidating VLANS

The initial design was to keep video traffic isolated on one vlan.  Our leads wanted to simplify the overall design for our customer.  We have found over time that the video traffic is minimal with occasional bursts.  So are you saying we would need to add the second subnet to the VLAN configuration?  Take a look at our current VLAN configuration and tell me what you think:

!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
description alpha_VLAN
ip address 172.x.x.x 255.255.255.0
ip pim sparse-dense-mode
no ip proxy-arp
no shutdown
!
interface Vlan20
description beta_VLAN
ip address 192.x.x.x 255.255.255.0
ip pim sparse-dense-mode
no ip proxy-arp
no shutdown
!
interface Vlan100
description delta_VLAN
ip address 192.x.x.x 255.255.255.0
no ip proxy-arp
no shutdown
!
!
router eigrp 101
no auto-summary
network 10.x.x.x
network 172.x.x.x
network 192.x.x.x
network 192.10.x.x

Scrubbed IPs.

~c

Hall of Fame Super Blue

Re: Consolidating VLANS

gdwingnuts wrote:

The initial design was to keep video traffic isolated on one vlan.  Our leads wanted to simplify the overall design for our customer.  We have found over time that the video traffic is minimal with occasional bursts.  So are you saying we would need to add the second subnet to the VLAN configuration?  Take a look at our current VLAN configuration and tell me what you think:

!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
description alpha_VLAN
ip address 172.x.x.x 255.255.255.0
ip pim sparse-dense-mode
no ip proxy-arp
no shutdown
!
interface Vlan20
description beta_VLAN
ip address 192.x.x.x 255.255.255.0
ip pim sparse-dense-mode
no ip proxy-arp
no shutdown
!
interface Vlan100
description delta_VLAN
ip address 192.x.x.x 255.255.255.0
no ip proxy-arp
no shutdown
!
!
router eigrp 101
no auto-summary
network 10.x.x.x
network 172.x.x.x
network 192.x.x.x
network 192.10.x.x

Scrubbed IPs.

~c

You would need to add a secondary address to the L3 vlan interface (if supported) as this is the clients default-gateway and they still need that to route traffic.

Personally i wouldn't bother. I think using secondary addressing etc. on a L3 switch is actually not simplifying but making it more complicated because it's not what you would normally see. I can't see how removing one vlan is really making it that much more simple.

Jon

New Member

Re: Consolidating VLANS

Thanks Jon, as always you are a huge help!  I did not consider a secondary address for the VLAN interface.  This helped tremendously.

~c

432
Views
5
Helpful
4
Replies