Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

copy running-config startup-config not saving

hi,

 we bought a  cisco 3945 router recently. i did the initial configuration and saving is using copy running-config startup-config. but it is not getting saved properly. whenever i restart the router, it asks for initial configuration. that is every time i have to give IP address and other configuration after i switch off and on the router.

kindly help me

thanks and regards

Jeni A

3 REPLIES
VIP Purple

There is a configuration

There is a configuration-register that controls if the startup-config is loaded on startup or not. It's likely that the config is saved but not loadad. If this is the case, you can see your config with "show startup-config".

You can see the actual value of the config-register with "show version". You set the default-value with

config-register 0x2102

 

More on this topic is found in the config-guides:

http://www.cisco.com/c/en/us/td/docs/routers/access/1900/software/configuration/guide/Software_Configuration/appendixDconfigreg.html

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/fundamentals/command/Cisco_IOS_Configuration_Fundamentals_Command_Reference/C_commands.html#wp5236362650

 


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
New Member

I also have this problem

I also have this problem except mine is on a 3650. How do I go about changing this?

 

Thanks,

Hellosh versionsh bootsh

Hello

sh version
sh boot
sh flash:

 

res

Paul

Please don't forget to rate any posts that have been helpful. Thanks.
936
Views
0
Helpful
3
Replies