Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

COS Value

I recently came across this question:

Q) Sort the associated traffic types give below in the correct order, based on priority (highest to lowest priority COS value)

call signalling     
voice
network management              
video interactive     
video streaming                      
ip routing

I tried searching the correct order, i am confused on what is the right order.

In the link http://www.cisco.com/en/US/docs/solutions/Enterprise/WAN_and_MAN/QoS_SRND/QoSIntro.html

at section “Figure 1-5 Example Strategy for Expanding the Number of Classes of Service over Time ” it says the order as

voice
video interactive
video streaming
call signalling
ip routing
network management

Whereas in the same link on section “Table 1-1 Cisco QoS  Baseline/Technical Marketing (Interim) Classification and Marking  Recommendations” it says the order as

ip routing
voice
video interactive
video streaming
call signalling
network management

I’M Really confused on which is the appropriate answer w.r.t the  question which is asking “based on priority(highest to lowest COS  vlaue)”

Can someone help me to identify which one is right please……

Thank you.

Manjunath

10 REPLIES

COS Value

Hi Manju,

The Figure 1-5 is basically a classification of Qos models in offereing. i.e how granular you would like you classes to be. you can have different class models. It depends on the requirements that your company might have.

For eg;: I can have just 3 classes

                   Realtime   - Voice, Video,

                   Critical      -  Network, Routing protocols,call signalling etc

                   Best Effort  - www, email, business data.

It doesnt mean that voice is more important than routing protocols but its just a classification. The table 1-1 seems correct to me. put it this way without ip routing and protocols etc how will you get end-end IP reachability? without this how will you send your voice or data across.

HTH

Kishore

Bronze

COS Value

Hi Kishore,

So do you means below sequence is valid and not the other one ??

ip routing

voice

video interactive

video streaming

call signalling

network management

Does the IOS recognize the routing protocols and mark them to priority of 6 automatically without any manual configuration from CLI ??

COS Value

Hi Manju,

Both are talking about different aspects of Qos so both are correct in what they re saying.

Fig 1-5 is talking about how many classes you need etc

the table is talking about prioritizatiion

When you design qos, its recommended that your qos doesnt go above 75% of the total bandwith and leave the rest 25% for signaling traffic routing protocols etc. however, if you decide that you want to use 100% bandwidth for your data then you need to prioritise your network traffic too(routing protocols, signalling)etc

HTH

Regards,

Kishore

Super Bronze

COS Value

Disclaimer

The        Author of this posting offers the information contained within   this      posting without consideration and with the reader's   understanding   that    there's no implied or expressed suitability or   fitness for any    purpose.   Information provided is for informational   purposes only  and   should not   be construed as rendering  professional  advice of any  kind.   Usage of  this  posting's  information is solely  at reader's own  risk.

Liability Disclaimer

In        no event shall Author be liable for any damages whatsoever      (including,   without limitation, damages for loss of use, data or      profit) arising  out  of the use or inability to use the posting's      information even if  Author  has been advised of the possibility of     such  damage.

Posting

In answer to:

Q) Sort the associated traffic types give below in the correct order, based on priority (highest to lowest priority COS value)

Normally the "correct" answer is:

  • ip routing
  • voice
  • video interactive
  • video streaming
  • call signaling
  • network management

However although the CoS values would normally be applied highest to lowest as I've listed above, it doesn't really matter as the CoS (or DSCP) are but tags for you to classify traffic into groups so that you can treat them differently.

In earlier QoS, there were relative priorities, i.e. CoS (or IP Prec) 7 is "better" than CoS (or IP Prec) 1, but newer QoS models often treat the traffic differently based on the marking with no assumed (for the most part) preference because of the marking itself.  For example in current DSCP, scavenger traffic has a "better" marking than best effort but it normally receives less resources than best effort.

Ranking application traffic types, today, is done mainly to (hopefully) preserve the traffic treatment we desire if the traffic transits a device using the old IP Prec or CoS precedence QoS model.

Real world QoS doesn't work too well just based on relative priorities.  For example, Voice (bearer) traffic has a higher marking than voice signally.  In fact, the latter has a lower marking than most all other "special" traffic yet if voice signally doesn't get the network resources it needs usually the call will drop.  Of course, the sound quality might be great right up to moment you get disconnected.

If the above we also see network management at the bottom, but if network management has insufficient resource, we might lose visibility into our network and then not know why network management stopped working and additionally not be able to tell why other applicaitions are no longer working too.

Bronze

COS Value

Hii Kishore and Joseph,

Thanks for explaning this

So its like we can play with cos vlaues however we want giving good treatment to traffic which are classified as low priority

But still i would like to get answer to this below question for better understanding...

The cos value/priority for ip routing is 6. So  does the IOS recognize the routing protocols and mark them to cos value  6 automatically without any manual configuration from CLI ??

I think yes is the answer for my above question, but i am not confident.

Super Bronze

COS Value

Disclaimer

The         Author of this posting offers the information contained within    this      posting without consideration and with the reader's    understanding   that    there's no implied or expressed suitability or    fitness for any    purpose.   Information provided is for  informational   purposes only  and   should not   be construed as  rendering  professional  advice of any  kind.   Usage of  this   posting's  information is solely  at reader's own  risk.

Liability Disclaimer

In         no event shall Author be liable for any damages whatsoever       (including,   without limitation, damages for loss of use, data or       profit) arising  out  of the use or inability to use the posting's       information even if  Author  has been advised of the possibility of      such  damage.

Posting

Don't recall IOS auto marking CoS but it does auto mark at least some routing protocols with IP Prec 6.

COS Value

Hi Manju ,

By default the routing protocols are not Cos marked. You can check it by doing a wireshark capture and can check the DSCP settings.on the IP packet.

HTH

Kishore

Super Bronze

COS Value

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

Kishore Chennupati wrote:

Hi Manju ,

By default the routing protocols are not Cos marked. You can check it by doing a wireshark capture and can check the DSCP settings.on the IP packet.

HTH

Kishore

Yes, try that for BGP and examine the ToS.

Router#sh ip bg neighbors

BGP neighbor is 192.168.2.1,  remote AS 20, external link

  BGP version 4, remote router ID 192.168.1.2

  BGP state = Established, up for 00:01:31

  Last read 00:01:31, last write 00:01:31, hold time is 180, keepalive interval is 60 seconds

  Neighbor capabilities:

    Route refresh: advertised and received(new)

    Address family IPv4 Unicast: advertised and received

  Message statistics:

    InQ depth is 0

    OutQ depth is 0

                         Sent       Rcvd

    Opens:                  1          1

    Notifications:          0          0

    Updates:                0          0

    Keepalives:             2          2

    Route Refresh:          0          0

    Total:                  3          3

  Default minimum time between advertisements runs is 30 seconds

For address family: IPv4 Unicast

  BGP table version 1, neighbor version 6/0

  Output queue size : 0

  Index 1, Offset 0, Mask 0x2

  1 update-group member

                                 Sent       Rcvd

  Prefix activity:               ----       ----

    Prefixes Current:               0          0 (Consumes 0 bytes)

    Prefixes total:                 0          0

    Implicit Withdraw:              0          0

    Explicit Withdraw:              0          0

    Used as bestpath:             n/a          1

    Used as multipath:            n/a          0

                                       Outbound    Inbound

      Local Policy Denied Prefixes:    --------    -------

        Total:                                0          0

      Number of NLRIs in the update sent: max 3, min 1

  Address tracking is enabled, the RIB does have a route to 192.168.2.1

  Connections established 1; dropped 0

  Last reset never

  Transport(tcp) path-mtu-discovery is enabled

Connection state is ESTAB, I/O status: 1, unread input bytes: 0

Connection is ECN Disabled, Minimum incoming TTL 0, Outgoing TTL 1

Local host: 192.168.2.2, Local port: 1025

Foreign host: 192.168.2.1, Foreign port: 179

Connection tableid (VRF): 0

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0xC69F4):

Timer          Starts    Wakeups            Next

Retrans             0          0             0x0

TimeWait            0          0             0x0

AckHold             2          0             0x0

SendWnd             0          0             0x0

KeepAlive           2          0             0x0

GiveUp              0          0             0x0

PmtuAger            0          0             0x0

DeadWait            0          0             0x0

Linger              0          0             0x0

ProcessQ            0          0             0x0

iss: 2057115318  snduna: 2057115748  sndnxt: 2057115748     sndwnd:  15955

irs: 3480424370  rcvnxt: 3480424751  rcvwnd:      16004  delrcvwnd:    380

SRTT: 259 ms, RTTO: 579 ms, RTV: 320 ms, KRTT: 0 ms

minRTT: 16 ms, maxRTT: 300 ms, ACK hold: 200 ms

Status Flags: passive open, gen tcbs

Option Flags: nagle, path mtu capable

IP Precedence value : 6

Datagrams (max data segment is 1460 bytes):

Rcvd: 3 (out of order: 0), with data: 0, total data bytes: 0

Sent: 3 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 0, total data bytes: 0

Packets received in fast path: 0, fast processed: 0, slow path: 0

fast lock acquisition failures: 0, slow path: 0

COS Value

Hi JD,

Thanks for that. check this one out. 

dis bgp routing-table 10.36.33.0

BGP local router ID : 192.168.240.48
Local AS number : 65011
Paths:   2 available, 1 best, 1 select
BGP routing table entry information of 10.36.33.0/24:
Network route.
From: 0.0.0.0 (0.0.0.0)
Route Duration: 00h00m45s
Direct Out-interface: Ethernet0/0/1
Original nexthop: 10.36.32.1
Qos information : 0x0
AS-path Nil, origin igp, MED 0, pref-val 0, valid, local, best, select, pre 60
Advertised to such 1 peers:
    172.30.0.230
BGP routing table entry information of 10.36.33.0/24:
From: 172.30.0.230 (172.30.0.222)
Route Duration: 00h00m45s
Direct Out-interface: Ethernet0/0/1
Original nexthop: 172.30.0.230
Qos information : 0x0
AS-path 55410 55410 55410, origin igp, pref-val 0, valid, external, pre 255, not preferred for route type
Not advertised to any peer yet

Super Bronze

Re: COS Value

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

I've setup a link between two test routers and enabled RIPv1, OSPF and BGP across it. Nothing else in config.  Configs are:

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

!

router ospf 10

log-adjacency-changes

network 192.168.1.0 0.0.0.255 area 0

!

router rip

network 192.168.1.0

!

router bgp 10

no synchronization

bgp log-neighbor-changes

neighbor 192.168.1.2 remote-as 20

no auto-summary

===============================

interface FastEthernet0/0

ip address 192.168.1.2 255.255.255.0

duplex auto

speed auto

!

router ospf 10

log-adjacency-changes

network 192.168.1.0 0.0.0.255 area 0

!

router rip

network 192.168.1.0

!

router bgp 20

no synchronization

bgp log-neighbor-changes

neighbor 192.168.1.1 remote-as 10

no auto-summary

Did a packet capture.  Looks to me like IP Predence 6 (or DSCP CS6) set on all routing packets.  Also did a ping across the link which shows ToS with BE.  IOS version: Version 12.4(15)T14

2041
Views
0
Helpful
10
Replies
CreatePlease login to create content