Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Bronze

COS values and outgoing interface queues.

Hi everybody.

The switch uses its queues, which are available on a per-port basis, to  buffer incoming and outgoing frames. The switch can use the CoS values  to place the frames in the appropriate queues. Voice frames should be  placed in the priority queue for minimal delay.

Let say i a switch trust cos of incoming frames and places in the priority queue for minimal delay. The switch does not alter cos values. Will this switch also place these frames with cos values in the appropriate queues for outgoing interface ?

thanks and have a great weekend.

Everyone's tags (3)
13 ACCEPTED SOLUTIONS

Accepted Solutions
Gold

Re: COS values and outgoing interface queues.

Hello Sarah,

as you already now, trusting CoS value itself has nothing to do with the way qos and traffic management behaves. the important part in how classified packets get serviced depends on the QoS setting that you apply on the switch.

for example, if you put a traffic flow with CoS 5, in an ingress priority queue, this flow doesnt necessarily go to an egress priority queue too, unless you set it so.

but using certain features such as Auto qos for voice, makes the switch manage both ingress and egress queues at the same time

Hope it Helps,

Soroush.

Hope it Helps, Soroush.
Gold

Re: COS values and outgoing interface queues.

Sarah, if QoS is disabled this is different case i believe we both assumed where u have qos enabled coz we were talking abt priority packets n stuff, in case it is Enabled u have to set trust states, all along the way.

if QoS is disabled, then switch simply doesnt care! it doesnt look for 802.1p header then. think of it like a dumb hub (QoS-wise), would a hub care what header information is attached to a PDU ? No!

HTH,

Soroush.

Hope it Helps, Soroush.
Silver

COS values and outgoing interface queues.

"May be i should keep my book"

.

As descibed in your book, if QoS is not enabled on your switches it won't care about the QoS markings but they will loose their markings when they cross any layer 3 device.

.

Siddhartha

Siddhartha
Silver

Re: COS values and outgoing interface queues.

The switches will calulate both COS and DSCP values, for example if you trust the COS value on a port it will also calculate the respective DSCP value based on the COS-to-DSCP mapping and in the same way if you trust the DSCP value it will calulate the respective COS value based on the DSCP-to COS map.

On the route we can configure using MQC - class maps and policy maps- with class map you can either match the incomming packets based on COS or based on DSCP not on both at the same time, for example

class-map match any voice

cos 5

or

class-map match any voice

dscp 46

Then you can use a policymap and set the value for the outgoing packets

policy-map qos

class-map match-any Platinum-Voice

priority percent 20

set ip dscp ef

At which node should  we perform mapping cos to dscp?

Router and switches

Cos marking  will travel over the trunk link. to Sw1.   Can Sw1 map the cos to Dscp  and send it  over trunk port to R2 ?

Yes

Can Sw1 retain COS value and  let  R2 map the Cos to Dscp before sending it to R1?

Routers can map cos to DSCP and vice versa, so it depends where you want to perform the conversion and it really doesn't matter.

The only requirement is QoS needs to be a end to end configuration.

Siddhartha

Siddhartha
Gold

Re: COS values and outgoing interface queues.

Hi Sarah,

i aint Sidd thou!

this is the QoS chart on most of the devices, but note that this could be slightly different in different routers or switches:

Ingress Traffic ----> Classify ---> Policer ----> Marker (Set Cos) ----> Normal / Priority Queue ---> to the egress point

so its a Yes to what you said

HTH,


Soroush.

Hope it Helps, Soroush.
Gold

Re: COS values and outgoing interface queues.

Hi Sarah,

I hope i'll be a good help for u to get it this time;

1) many ip phones have a built-in three port switch in them, one for PC, one for the phone itself, and one for upstream connection. when using separate voice n data van for ip phones the internal switch will tag voice traffic with the respective voice van ID and applies a COS 5 value.

since the ip phone connection to upstream switch is 802.1q trunk, it considers the Data vlan, its native vlan and send PC traffic untagged. (Correct)

2) using 802.1p, my understanding is that the ip phone sends the voice and data traffic with 802.1p header set and the frames carry a vlan ID equal to Zero (not literally VLAN 0) and switch accepts the frames with VLAN zero as if they are in the access vlan set on the switchport.

3) u r right, this is probably IP Precedence 5, not the CoS 5.

4) This feature is complementary to the "port prioritization for untagged packets" available on supported Cisco Catalyst switches.

whats the use of it? it lets us make sure that the traffic coming from a PC connected to the iphone will never get as high priority as Voice packets generated from the ip phone itself.

me not in the States but Happy 4th of july to U

HTH,

Soroush.

Hope it Helps, Soroush.
VIP Super Bronze

Re: COS values and outgoing interface queues.

Hi Sarah,

1) My book says this command tells ip phone to use native vlan 22 ( also called data vlan) and vlan 24 for voip frames.

ip phone will send pc data without any tag and hence the word native vlan

Is this correct?

Yes

2) If we use " switchport voice vlan dot1p" the switch tells ip phone  to use vlan 0 for voip traffic and use native vlan ( which is vlan 22)  for PC.

My question is since we are using vlan 0 for voip, it should be used for voip throughout switched network for example:

Ip phone1-----sw1--------sw2------ipphone2

    |                                            |

  PC                                       PC

If  we use " switchport voice vlan dot1p" on sw2,  voip frames will be sent  in vlan 0 by iphone2 to sw2.  If ipphone2 has to communicate with  iphone1  and they are on same subnet, then should  ipphone1 be on vlan 0  as well?( that means we must also configure  SW1 with " switchport  voice vlan dot1p")

Yes, you would need to configure switchport  voice vlan dot1p on all your switches, but remember vlan 0 is an internal voice vlan to the phone, when the switch receives vlan 0, it will change it to whatever access vlan you have configured (in your case 22).

3) If we use " switchport voice vlan untagged" on sw2, my book says both  voip and pc data are sent using native vlan. then book also says COS  bits still sent.  This boggles my mind. When we use the option "  untagged"  the switch should not insert any dot1q tag . So without dot1q  tag, how COS bits can still be carried?

Since the dot1p is a 3 bit priority tag and it is inside dot1q, when you configure "switchport voice vlan untagged" than there is no tag and no COS.

happy 4th.

HTH

VIP Super Bronze

COS values and outgoing interface queues.

Hi Sarah,

Yes, your understanding is correct.

Good Luck with the switching exam!

Make sure to get some hands-on practice on routers and switches before you take it.

Reza

Gold

Re: COS values and outgoing interface queues.

With regards to the receiving end point, since 802.1p uses vlan 0 as a spacial case to carry a CoS value for voip frames, and cos is only used by intermediate devices for QoS purposes and having in mind that upon receiving the Voice packet, Switch assumes the Access vlan which is set on the interface in this case.

then i'd say, the Switch will simply strip off the vlan ID from the frame and and forward it to ip phone's IP address out the interface as it'll do on a normal access switchport.

this was my assumption based on the facts.

HTH,

Soroush.

Hope it Helps, Soroush.
Gold

Re: COS values and outgoing interface queues.

I guess u are getting confused with the term of "Native VLAN or Untagged", this is in reference to an 802.1q tag. You can't put a CoS into a frame that is untagged (either 802.1q or 802.1p tag is required). A host connected to the phone can be configured to insert a tag into the frame (802.1p). in such case's or as a precaution, to make sure we don't ruin our voice priority accidentally or by a rogue user, intentionally, we could use this command.

Hope it Helps,

Soroush.

Hope it Helps, Soroush.
Gold

Re: COS values and outgoing interface queues.

when voice packet is received at the ip phone with its Mac Address attached, the phone will just pick it up n otherwise will send it out the other interface, is a small 1 to 2 / 2 to 1 switch module. i dont think the built-in switch module in an ip phone is that sophisticated to perform queuing and other QoS stuff, this needs some hardware muscle... n it doesn't really need it.

its just faster to read the address and switch.

whatever qos and marking we implement at the beginning (ip phone) is just for Access, Distribution and Core network handling.

EDIT:

a 2nd view: reasong behind using CoS & DSCP marking is that the intermediate device has a lot of packets to handle and the only way it could know abt the urgency of the frame is reading these markings and follow instructions. as for the ip phone it could be hardcoded in itself that packets destined for the phone itself has the highest priority over all others!


Soroush.

Hope it Helps, Soroush.
Gold

Re: COS values and outgoing interface queues.

Sarah,

Priority is 802.1p totally different from 802.1Q header

check this url:

http://www.cisco.com/en/US/products/hw/switches/ps607/products_qanda_item09186a0080116ffe.shtml#q9

Soroush.

Hope it Helps, Soroush.
Silver

COS values and outgoing interface queues.

I like this discussion, learned few things that I don't know before.

"Dot1p marrkings are carried by dot1q tag . So If there is no dot1q tag, there is no dot1p marking either.

That is correct.

if  ip phone is using native vlan for attached PC, that means there is no  802.1p markings because switch does not insert dot1q tag for native  vlan"

I am not sure what you exactly mean here but IP phone can't influece what PC can use.

usualy PCs can't tag the traffic and can't mark the traffic unless you use any special settings, so if the switch port is configured as a trunk port the outgoing or incomming PC traffic will go to the native VLAN defined.

that means there is no  802.1p markings because switch does not insert dot1q tag for native  vlan"

Yes

Siddhartha

Siddhartha
33 REPLIES
Gold

Re: COS values and outgoing interface queues.

Hello Sarah,

as you already now, trusting CoS value itself has nothing to do with the way qos and traffic management behaves. the important part in how classified packets get serviced depends on the QoS setting that you apply on the switch.

for example, if you put a traffic flow with CoS 5, in an ingress priority queue, this flow doesnt necessarily go to an egress priority queue too, unless you set it so.

but using certain features such as Auto qos for voice, makes the switch manage both ingress and egress queues at the same time

Hope it Helps,

Soroush.

Hope it Helps, Soroush.
Bronze

Re: COS values and outgoing interface queues.

Thanks Soroushm.

By default  a switch trusts cos values received on its trunk port.  The cos value in received frame helps switch determine which priority queues  for ingress port, the frame be placed. And If a switch determines that received frame has to forwarded out say f1/2, it will not place the frame in priority queue for egress port (f1/2) based on cos value carried by received frame unless we configure specific features such as auto qos.

Did i get it right ?

Gold

Re: COS values and outgoing interface queues.

As for the trunk ports, I believe so Sarah, except for the Native Vlan frames, which dont have Tag Control info in their headers.

it said that in most cases without any special configuration, all user data traffic is sent in a Best Effort basis. so unless u configure ur device to take care of a certain class of traffic, it continues to use the best effort model.

but some configz are like a package! u config one thing, it takes care of ingress and egress; i.e. Auto QoS for voip!

EDIT: I misunderstood!!! you have to trust CoS and DSCP all along the way, then if u trust either CoS or DSCP, then the switch uses a conversion table to convert them in case its needed to be done (default and configurable). on access ports and uplinks you have to explicitly instruct to Trust and untagged traffic gets a 0 value by default.

Thanks Sid !

HTH,


Soroush.

Hope it Helps, Soroush.
Silver

COS values and outgoing interface queues.

Hi Sarah,

"By default  a switch trusts cos values received on its trunk port."

I don't believe the above statement is true, even if its a trunk port you still have to tell the switch to either the trust the COS or DSCP received in the incomming frame.

"Example 2:If the port is trunk port, you can configure either the mls qos trust cos or mls qos trust dscp command. The dscp-cos map table is used to calculate the CoS value if  the port is configured to trust DSCP. Similarly, the cos-dscp map table  is used to calculate the DSCP value if the port is configured to trust  CoS.

As Souroush mentioned since native VLAN traffic will have COS,DSCP values set to zero the switch will reset the COS and DSCP values back to zero even if we specify the trust command.

Example 3: If the port is a dot1q trunk port and the port is configured with the mls qos trust cos command, native VLAN frames will have CoS and DSCP values as 0. Because  native VLAN frames are untagged and the frame is tagged after it enters  the switch, the switch will set the default CoS value to 0 and the  CoS-to-DSCP table sets the DSCP value to 0.

Note: The DSCP value of the packet coming from native VLAN will be reset to 0.

AutoQos is the easiest way to configure LAN QOS.

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_tech_note09186a0080883f9e.shtml

https://supportforums.cisco.com/message/3656109#3656109

Siddhartha

Siddhartha
Bronze

Re: COS values and outgoing interface queues.

I should throw my book in thrash.

That is exactly what my book says:

By default, QOS is disabled globally on a switch and all QOS information is allowed to pass from one switch port to another."

thanks for the correction or i will be building my QOS foundation on a wrong concept.

Gold

Re: COS values and outgoing interface queues.

Sarah, if QoS is disabled this is different case i believe we both assumed where u have qos enabled coz we were talking abt priority packets n stuff, in case it is Enabled u have to set trust states, all along the way.

if QoS is disabled, then switch simply doesnt care! it doesnt look for 802.1p header then. think of it like a dumb hub (QoS-wise), would a hub care what header information is attached to a PDU ? No!

HTH,

Soroush.

Hope it Helps, Soroush.
Bronze

Re: COS values and outgoing interface queues.

May be i should keep my book.

Silver

COS values and outgoing interface queues.

"May be i should keep my book"

.

As descibed in your book, if QoS is not enabled on your switches it won't care about the QoS markings but they will loose their markings when they cross any layer 3 device.

.

Siddhartha

Siddhartha
Bronze

Re: COS values and outgoing interface queues.

As descibed in your book, if QoS is not enabled on your switches it  won't care about the QoS markings but they will loose their markings  when they cross any layer 3 device.

.

    R1---R2--trunk--sw1-----trunk-sw3-ip phone.

At which node should  we perform mapping cos to dscp? Cos marking will travel over the trunk link. to Sw1.   Can Sw1 map the cos to Dscp and send it  over trunk port to R2 ? Can Sw1 retain COS value and  let R2 map the Cos to Dscp before sending it to R1?

In between can  a router map cos value to dscp value and vice versa ?

thanks and have a good evening.

Silver

Re: COS values and outgoing interface queues.

The switches will calulate both COS and DSCP values, for example if you trust the COS value on a port it will also calculate the respective DSCP value based on the COS-to-DSCP mapping and in the same way if you trust the DSCP value it will calulate the respective COS value based on the DSCP-to COS map.

On the route we can configure using MQC - class maps and policy maps- with class map you can either match the incomming packets based on COS or based on DSCP not on both at the same time, for example

class-map match any voice

cos 5

or

class-map match any voice

dscp 46

Then you can use a policymap and set the value for the outgoing packets

policy-map qos

class-map match-any Platinum-Voice

priority percent 20

set ip dscp ef

At which node should  we perform mapping cos to dscp?

Router and switches

Cos marking  will travel over the trunk link. to Sw1.   Can Sw1 map the cos to Dscp  and send it  over trunk port to R2 ?

Yes

Can Sw1 retain COS value and  let  R2 map the Cos to Dscp before sending it to R1?

Routers can map cos to DSCP and vice versa, so it depends where you want to perform the conversion and it really doesn't matter.

The only requirement is QoS needs to be a end to end configuration.

Siddhartha

Siddhartha
Bronze

Re: COS values and outgoing interface queues.

Siddartham

Please correct me if  ia m wrong.   policy maps for incoming packets are evaluated first before routing.

On the route we can configure using MQC - class maps and policy maps-  with class map you can either match the incomming packets based on COS  or based on DSCP not on both at the same time, for example

class-map match any voice

cos 5

or

class-map match any voice

dscp 46

Let say we identify the   an incoming packet  using above policy map on a router. . Lets call this packet packt1. After we identify the pack1 we use " set" command to change DSCP value say to 45.  Router now perform QOS on pack1 using this new DSCP value by placing it in priority queue for ingress port. Is it correct?

thanks.

Gold

Re: COS values and outgoing interface queues.

Hi Sarah,

i aint Sidd thou!

this is the QoS chart on most of the devices, but note that this could be slightly different in different routers or switches:

Ingress Traffic ----> Classify ---> Policer ----> Marker (Set Cos) ----> Normal / Priority Queue ---> to the egress point

so its a Yes to what you said

HTH,


Soroush.

Hope it Helps, Soroush.
Silver

Re: COS values and outgoing interface queues.

Hi Sarah,

i aint Sidd thou!

I agree with Soroush's explanation in his post.

For routers you can define different calss maps and policy maps for different directions,

for example

Class-map in_G0/0

Policy-map in_G0/0

class-map out_G0/0

policy-map out_G0/0

class-map in_S0/0

policy-map in_S0/0

class-map out_S0/0

policy-map out_S0/0

Siddhartha

Siddhartha
Bronze

Re: COS values and outgoing interface queues.

Hi Soroushm

I already posted this question but still did not understand it.

I hope you can help me sort out this:

Sw1-f1/1-------------------Ip phone

                                     |

                                     |

                                    PC

Int f1/1

switchport acess vlan 22

switchport voice vlan 24.

1) My book says this command tells ip phone to use native vlan 22 ( also called data vlan) and vlan 24 for voip frames.

ip phone will send pc data without any tag and hence the word native vlan

Is this correct?

2) If we use " switchport voice vlan dot1p" the switch tells ip phone to use vlan 0 for voip traffic and use native vlan ( which is vlan 22) for PC.

My question is since we are using vlan 0 for voip, it should be used for voip throughout switched network for example:

Ip phone1-----sw1--------sw2------ipphone2

    |                                            |

  PC                                       PC

If we use " switchport voice vlan dot1p" on sw2,  voip frames will be sent in vlan 0 by iphone2 to sw2.  If ipphone2 has to communicate with iphone1  and they are on same subnet, then should  ipphone1 be on vlan 0 as well?( that means we must also configure  SW1 with " switchport voice vlan dot1p")

  3) If we use " switchport voice vlan untagged" on sw2, my book says both voip and pc data are sent using native vlan. then book also says COS bits still sent.  This boggles my mind. When we use the option " untagged"  the switch should not insert any dot1q tag . So without dot1q tag, how COS bits can still be carried?

=============================================================================

4) sw--------------ipphone

                           |

                         Pc

Let say we configure sw as:

int f1/1

switchport access vlan 2

switchport voice vlan 3

switchport priority extend cos 3

Ip phone will use native vlan2 for Pc which means no dot1q tag and  vlan 3 for voip traffic. The last command tells ipphone to set COS value to 3 for frames received on its port connected to PC.

My question is what is the point as ip phone  will send Pc 'frames using native vlan 2 to sw, without 8021q tag as a result , the cos value 3 can not be sent with PC data frames to SW.

If the above is true why  should one use "switchport priority extend cos 3"  command ?

Sorry for this long winded post. I am almost done with my book, three more chapters to go .I am planing to take switch exam in August.

thanks and happy 4 th of july if you are in states.

Gold

Re: COS values and outgoing interface queues.

Hi Sarah,

I hope i'll be a good help for u to get it this time;

1) many ip phones have a built-in three port switch in them, one for PC, one for the phone itself, and one for upstream connection. when using separate voice n data van for ip phones the internal switch will tag voice traffic with the respective voice van ID and applies a COS 5 value.

since the ip phone connection to upstream switch is 802.1q trunk, it considers the Data vlan, its native vlan and send PC traffic untagged. (Correct)

2) using 802.1p, my understanding is that the ip phone sends the voice and data traffic with 802.1p header set and the frames carry a vlan ID equal to Zero (not literally VLAN 0) and switch accepts the frames with VLAN zero as if they are in the access vlan set on the switchport.

3) u r right, this is probably IP Precedence 5, not the CoS 5.

4) This feature is complementary to the "port prioritization for untagged packets" available on supported Cisco Catalyst switches.

whats the use of it? it lets us make sure that the traffic coming from a PC connected to the iphone will never get as high priority as Voice packets generated from the ip phone itself.

me not in the States but Happy 4th of july to U

HTH,

Soroush.

Hope it Helps, Soroush.
Bronze

Re: COS values and outgoing interface queues.

Thanks Soroushm.

4) sw--------------ipphone

                           |

                         Pc

Let say we configure sw as:

int f1/1

switchport access vlan 2

switchport voice vlan 3

switchport priority extend cos 3

Ip  phone will use native vlan2 for Pc which means no dot1q tag and  vlan 3  for voip traffic. The last command tells ipphone to set COS value to 3  for frames received on its port connected to PC.

My question is  what is the point as ip phone  will send Pc 'frames using native vlan 2  to sw, without 8021q tag as a result , the cos value 3 can not be sent  with PC data frames to SW.

If the above is true why  should one use "switchport priority extend cos 3"  command ?

4) This feature is complementary to the "port prioritization for  untagged packets" available on supported Cisco Catalyst switches.

whats  the use of it? it lets us make sure that the traffic coming from a PC  connected to the iphone will never get as high priority as Voice packets  generated from the ip phone itself.

My question is since Ip phone will use native vlan to send PC 's frames to sw, therefore it should not matter whether we use the command "switchport priority extend cos 3" or not because the switch will not receives any COS if Ip phone uses native vlan to send attached Pc's frames.

If above is true, then the command "switchport priority extend cos 3" simply tells attached ip phone to set cos value to 3 for received frames from attached PC . Then could we say the command "switchport priority extend cos 3"  just helps internal switch of ip phone to perform qos for its ingress port?( i.e the data port of ip phone connected to PC)

Thanks and have a nice upcoming weekend.

"

Gold

Re: COS values and outgoing interface queues.

I guess u are getting confused with the term of "Native VLAN or Untagged", this is in reference to an 802.1q tag. You can't put a CoS into a frame that is untagged (either 802.1q or 802.1p tag is required). A host connected to the phone can be configured to insert a tag into the frame (802.1p). in such case's or as a precaution, to make sure we don't ruin our voice priority accidentally or by a rogue user, intentionally, we could use this command.

Hope it Helps,

Soroush.

Hope it Helps, Soroush.
Bronze

Re: COS values and outgoing interface queues.

Thanks Soroushm.

let me eloboarate on it


sw-------------ipphone

                         |

                     PC

we configure our switch as:

int f1/1( port connected to ip phone)

switchport access vlan 22

switchport voice vlan 23

switchport priority extend trust

Ip phone will use native vlan 22( which means no 802.1q tag, hence no cos value) for attached pc.

Let say PC is capable of inserting 8021q tag and currently using cos=4

But when iphone sends the frame from pc to sw, it will use native vlan 22 which means cos value will not be carried because there is no 8021q tag.

Is this  correct?

thanks

Gold

Re: COS values and outgoing interface queues.

Sarah,

Priority is 802.1p totally different from 802.1Q header

check this url:

http://www.cisco.com/en/US/products/hw/switches/ps607/products_qanda_item09186a0080116ffe.shtml#q9

Soroush.

Hope it Helps, Soroush.
Bronze

Re: COS values and outgoing interface queues.

thanks for the link Soroushm.

Dot1p marrkings are carried by dot1q tag . So If there is no dot1q tag, there is no dot1p marking either.

if ip phone is using native vlan for attached PC, that means there is no 802.1p markings because switch does not insert dot1q tag for native vlan.

Feel free to correct me If I am wrong.

thanks

Gold

Re: COS values and outgoing interface queues.

hahaha, its getting complicated and too technicall, im looking arround to find a solid documented chart or sth.

the case is the ip phone itself doesnt tag the packets comming from the PC or the device attached. the device itself could make the frame in such way to carry the 802.1 header.

HTH,

Soroush.

Hope it Helps, Soroush.
Silver

COS values and outgoing interface queues.

I like this discussion, learned few things that I don't know before.

"Dot1p marrkings are carried by dot1q tag . So If there is no dot1q tag, there is no dot1p marking either.

That is correct.

if  ip phone is using native vlan for attached PC, that means there is no  802.1p markings because switch does not insert dot1q tag for native  vlan"

I am not sure what you exactly mean here but IP phone can't influece what PC can use.

usualy PCs can't tag the traffic and can't mark the traffic unless you use any special settings, so if the switch port is configured as a trunk port the outgoing or incomming PC traffic will go to the native VLAN defined.

that means there is no  802.1p markings because switch does not insert dot1q tag for native  vlan"

Yes

Siddhartha

Siddhartha
Gold

Re: COS values and outgoing interface queues.

hey Sid,

from cisco.com:

Q. Can the Cisco EtherSwitch EHWICs support 802.1p and port prioritizations at the same time?

A. Yes. The switch uses 802.1p prioritization for the incoming tagged packets and port-based prioritization for the incoming untagged packets. The two modes function in a mutually exclusive and complementary manner.

know anything about it?

this objective is on my nerve now lol gotta look into it in more depth, maybe ask my frnds @ Cisco! will post if anything.


Soroush.

Hope it Helps, Soroush.
Silver
Bronze

Re: COS values and outgoing interface queues.

if   ip phone is using native vlan for attached PC, that means there is no   802.1p markings because switch does not insert dot1q tag for native   vlan"

I am not sure what you exactly mean here but IP phone can't influece what PC can use.

i apologize for not being very articulate.

Let me expound on it.

Sw1--------------------------------ip phone

                                          |

                                       PC

By using command " switchport voice vlan 2"  on sw1, we instruct ip phone to use native vlan for all traffic from attached PC, It also tells ip phone to use vlan 2  for voip traffic.Native vlan means no dot1q tag is inserted by ip phone and therefore no 8021p markings either.

Are you following me Siddhartham? If not let me know.

I assume you underrstood my point. Let me recap the discussion I was having with our friend Soroush.

The command"switchport priority extend cos 3 ' on sw1 tells ip phone to set cos value in frames received from attached pc to 3 . Let assume it is possible that attached Pc can set cos value .

But since Ip phone is instructed to use native vlan for attached pc's traffic. therefore all these cos values will not be carried because ip phone does not insert dot1q tag for native vlan.

It implies " the command " switch priority extend cos 3" or with any other option such as " trust " does not cause sw1 to perform qos for frames originated from attached pc because  these frames are sent over native vlan which means no dot1q tag and therefore no cos markings.

So what is the purpose of this command then?  you might say  by using this command we are telling ip phone to trust or set cos value. I agreed but what is the benefit? It was mentioned in earlier post internal switch inside ip phone does not perform qos.

thanks and have a great day

Silver

COS values and outgoing interface queues.

"

Sw1--------------------------------ip phone

                                          |

                                       PC

By  using command " switchport voice vlan 2"  on sw1, we instruct ip phone  to use native vlan for all traffic from attached PC, It also tells ip  phone to use vlan 2  for voip traffic.Native vlan means no dot1q tag is  inserted by ip phone and therefore no 8021p markings either."

Yes, switchport voice vlan 2 command tells the IP phone to send its voice traffic to VLAN2. But I don't think we instruct IP phone to use native VLAN for the PC. It happens by default since the PC sends untagged (no 802.1Q) frames they will be sent to the native VLAN ( which is defined on the SW1 either by switchport access VLAN or by switch trank native VLAN command.)

The command"switchport priority extend cos 3 ' on sw1 tells ip phone to set cos value in frames received from  attached pc to 3 . Let assume it is possible that attached Pc can set  cos value .

But since Ip phone is instructed to use native vlan  for attached pc's traffic. therefore all these cos values will not be  carried because ip phone does not insert dot1q tag for native vlan.

It  implies " the command " switch priority extend cos 3" or with any other  option such as " trust " does not cause sw1 to perform qos for frames  originated from attached pc because  these frames are sent over native  vlan which means no dot1q tag and therefore no cos markings.

I don't have answer to this question, I read few documents but couldn't find anything usefull.

switchport priority extend cos 3- Command tells the IP phone to assign cos 3 (802.1P tag) to the frames that the switch in the ip phone receives on the port connected to the PC

Since 802.1P is a field in 802.1Q,  ip phone should tag the data traffic from the PC with 802.1Q. In that case what will be the VID (VLAN ID) field in the frame set to.

Traffic will be forwarded to native VLAN only if its untagged traffic, does this mean all our PC traffic is going to be drooped?

Sarah,

Sorry for asking more questions instead of answering yours

Soroush,

Please correct me if my questions are not valid.

Siddhartha

Siddhartha
VIP Super Bronze

Re: COS values and outgoing interface queues.

Hi Sarah,

1) My book says this command tells ip phone to use native vlan 22 ( also called data vlan) and vlan 24 for voip frames.

ip phone will send pc data without any tag and hence the word native vlan

Is this correct?

Yes

2) If we use " switchport voice vlan dot1p" the switch tells ip phone  to use vlan 0 for voip traffic and use native vlan ( which is vlan 22)  for PC.

My question is since we are using vlan 0 for voip, it should be used for voip throughout switched network for example:

Ip phone1-----sw1--------sw2------ipphone2

    |                                            |

  PC                                       PC

If  we use " switchport voice vlan dot1p" on sw2,  voip frames will be sent  in vlan 0 by iphone2 to sw2.  If ipphone2 has to communicate with  iphone1  and they are on same subnet, then should  ipphone1 be on vlan 0  as well?( that means we must also configure  SW1 with " switchport  voice vlan dot1p")

Yes, you would need to configure switchport  voice vlan dot1p on all your switches, but remember vlan 0 is an internal voice vlan to the phone, when the switch receives vlan 0, it will change it to whatever access vlan you have configured (in your case 22).

3) If we use " switchport voice vlan untagged" on sw2, my book says both  voip and pc data are sent using native vlan. then book also says COS  bits still sent.  This boggles my mind. When we use the option "  untagged"  the switch should not insert any dot1q tag . So without dot1q  tag, how COS bits can still be carried?

Since the dot1p is a 3 bit priority tag and it is inside dot1q, when you configure "switchport voice vlan untagged" than there is no tag and no COS.

happy 4th.

HTH

Bronze

Re: COS values and outgoing interface queues.

Thanks Reza.

2) If we use " switchport voice vlan dot1p" the switch tells ip  phone  to use vlan 0 for voip traffic and use native vlan ( which is  vlan 22)  for PC.

My question is since we are using vlan 0 for voip, it should be used for voip throughout switched network for example:

Ip phone1-----f1/1sw1--------sw2 f1/1------ipphone2

    |                                                                         |

  PC                                                                      pc

Yes, you would need to configure switchport  voice vlan dot1p on all  your switches, but remember vlan 0 is an internal voice vlan to the  phone, when the switch receives vlan 0, it will change it to whatever  access vlan you have configured (in your case 22).

we have configured both sw2 and sw1 with :

switchport access vlan 22

switchport voice vlan dot1p

Iphone2 sends voip frame lets call it f1 using vlan 0

sw2 receives it perform qos and replaces vlan 0 by vlan 22 and switches it out of trunk port to sw1.

Sw1 receives the frame f1 and performs qos and replaces vlan 22 id by vlan 0 id and forwards it out f1/1 to ip phone.

Is my understanding correct?

Happy 4th to you as well.

VIP Super Bronze

COS values and outgoing interface queues.

Hi Sarah,

Yes, your understanding is correct.

Good Luck with the switching exam!

Make sure to get some hands-on practice on routers and switches before you take it.

Reza

1210
Views
0
Helpful
33
Replies