Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Counters on the SVI problem

Hello All,

I was doing some testing today and seem to have encountered a weird problem(I assume). The scenario is as follows.

* the switch is a couple of C3750 interconnected and doing the L3 function for its LAN

* they also operate on the hsrp so say sw-2 is active for even vlans and sw-1 for odd.

* let us consider vlan 4 and vlan 6 configured on the switches and specifically the sw2 switch. This switch has the IP address as : 10.x.4.3 for vlan 4 (config via interface vlan CLI, HSRP is 10.x.4.1 and this is the active switch for vlan 4) & 10.x.6.3 for vlan 6 ( HSRP is 10.x.6.1 and is active switch for this vlan too)

* Now in sw2 itself, I tried to do an extended ping with source address 10.x.4.1 to target address 10.x.6.1, say 2000 packets, now when I look at the show int vlan 6, i dont see the input packet incrementing nor the 5 minute input rate incrementing? Am I missing something here before I think in lines of an IOS bug.

* if i ping 10.x.6.1 from another LAN/site say 10.y.6.1 then counters do increment.

Please help.

THe IOS is 12.2(25SEE1) i know its a bit old one :)

  • LAN Switching and Routing
Hall of Fame Super Bronze

Re: Counters on the SVI problem

Packets coming from another LAN/Site are processed by the route processor (CPU) hence is counted under the SVI.

Inter-Vlan switching is done purely in hardware - hence the fast speed - and counters won't be incremented.

What you are seeing is normal.




New Member

Re: Counters on the SVI problem

Ohh cool!!! is there any documents that actually shows this?

thanks :)

Hall of Fame Super Bronze

Re: Counters on the SVI problem

Can't find one at the moment, sorry.

New Member

Re: Counters on the SVI problem

Thanks you Edison :),

I tried to repeat the whole process with "no ip route-cache cef and no ip route-cache" commands in the Interface vlan X config mode. Even then I am not noticing the input packets. I was under the impression that if CEF is disabled then all packets will be punted to processor thus the SVI should be able to pick up. But ping the intervlan IP on the same switch still no packets increment no traffic :(....