Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CPU 100% - STP?

Hi, we are have strange problem with sup720-base:

In different time CPU utilization equal ~99-100%

and we have out for service (we haven't ping to the switch!)

I start stp debug all, and when cpu grow to 100% I recieve these messages:

Dec 10 08:38:54: SPANTREETYPE: getting tree type vlan for parameter 1 value 1

Dec 10 08:38:54: stp: begin nvgen vlan 999 config blocks

Dec 10 08:38:54: stp: nvgen state 0 config blocks

Dec 10 08:38:54: stp: nvgen protocol 0 config blocks

Dec 10 08:38:54: stp: nvgen priority 999 config blocks

Dec 10 08:38:54: stp: nvgen hello 0 config blocks

Dec 10 08:38:54: stp: nvgen fwddelay 0 config blocks

Dec 10 08:38:54:et1/3 (462FA4B8)

Dec 10 08:38:55: STP CFG: get port param unknown 0 GigabitEthernet1/3 1=2 rc=1

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/3 (462FA4B8) stp: n

Dec 10 08:38:55: STP CFG: get port param unknown 0 GigabitEthernet1/3 1=3 rc=1

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/3 (462FA4B8)

Dec 10 08:38:55: STP CFG: get port param unknown 0 GigabitEthernet1/3 1=1 rc=1

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/3 (462FA4B8)

Dec 10 08:38:55: STP CFG: get port param unknown 0 GigabitEthernet1/3 12=1 rc=1

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/3 (462FA4B8)

Dec 10 08:38:55: STP CFG: get port param unknown 0 GigabitEthernet1/3 11=1 rc=1

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/3 (462FA4B8)

Dec 10 08:38:55: STP CFG: get port param unknown 0 GigabitEthernet1/3 9=1 rc=1vgen maxage 0 config blocks

Dec 10 08:38:55: STP CFG: found (462FA4B8)

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/3 (462FA4B8)

Dec 10 08:38:55: STP CFG: get port param unknown 0 GigabitEthernet1/3 4=3 rc=1

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/3 (462FA4B8)

Dec 10 08:38:55: STP CFG: get port param unknown 0 GigabitEthernet1/3 3=3 rc=1

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/4 (462FBA20)

Dec 10 08:38:55: STP CFG: get port param unknown 0 GigabitEthernet1/4 1=2 rc=1

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/4 (462FBA20)

Dec 10 08:38:55: STP CFG: get port param unknown 0 GigabitEthernet1/4 1=3 rc=1

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/4 (462FBA20)

Dec 10 08:38:55: STP CFG: get port param unknown 0 GigabitEthernet1/4 1=1 rc=1

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/4 (462FBA20)

Dec 10 08:38:55: STP CFG: get port param unknown 0 GigabitEthernet1/4 12=1 rc=1

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/4 (462FBA20)

Dec 10 08:38:55: STP CFG: get port param unknown 0 GigabitEthernet1/4 11=1 rc=1

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/4 (462FBA20)

Dec 10 08:38:55: STP CFG: get port param unknown 0 GigabitEthernet1/4 9=1 rc=1

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/4 (462FBA20)

Dec 10 08:38:55: STP CFG: get port param mst 0 GigabitEthernet1/4 10=1 rc=1

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/4 (462FBA20)

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/4 (462FBA20)

Dec 10 08:38:55: STP CFG: get port param unknown 0 GigabitEthernet1/4 7=1 rc=0

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/4 (462FBA20)

Dec 10 08:38:55: STP CFG: found port cfg GigabitEthernet1/4 (462FBA20)

and more...

maybe somewho know what is it and how it can be fixed?

8 REPLIES
Silver

Re: CPU 100% - STP?

Is GigabitEthernet interface 1/3 and 1/4 are providing redundancy? Looks like in loop. Is it possible to take out one and see if that break the loop.

New Member

Re: CPU 100% - STP?

This ports is disabled...

witchcraft...

New Member

Re: CPU 100% - STP?

go for show cdp nei command, if you see the same switch then its a loop between ports on the same switch.

does the 100% cpu is reached after you issue debug all command, for information the debug all command is very process intensive.

New Member

Re: CPU 100% - STP?

cdp don't display same switch.

about debug - we enable only spanning-tree debug.

Silver

Re: CPU 100% - STP?

did u try

show processes cpu i think it tells u which process is utilizing that much CPU. Maybe that can help you to crack the problem.

New Member

Re: CPU 100% - STP?

done, but I don't seen any process that utilize CPU

Hall of Fame Super Silver

Re: CPU 100% - STP?

Hello Aleksey,

I lost a C4506 switch just doing debug stp packets so it is quite heavy for the switch.

You say the two ports are disabled are also unplugged ?

Hope to help

Giuseppe

New Member

Re: CPU 100% - STP?

Hello, Guiseppe!

Yes! Ports disabled and unplugged...

1838
Views
0
Helpful
8
Replies