Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CPU high utilization


Hi,

New switch installed in our network shows 55-60 %(some time even 1 minute 60%) process utilization always dont know why .. nothing unusual in the logs and configuration

below information is switch info please help if any members had gone thru the same and know why.

thanks

Directory of flash:/

  583  -rwx        4120   Oct 7 2010 14:11:55 +04:00  multiple-fs
    2  -rwx         796   Mar 1 1993 04:01:23 +04:00  vlan.dat
    3  -rwx        3804   Mar 1 1993 04:01:48 +04:00  private-config.text
    5  -rwx       21172   Mar 1 1993 04:01:47 +04:00  config.text
    6  drwx         512   Mar 1 1993 04:27:04 +04:00  c2960s-universalk9-mz.122-53.SE2

CPU utilization for five seconds: 20%/0%; one minute: 39%; five minutes: 55%

NAME: "1", DESCR: "WS-C2960S-48FPS-L"
PID: WS-C2960S-48FPS-L , VID: V01  , SN: FOC1432Z4DU

18 REPLIES

Re: CPU high utilization

Hi,

Have you run the Show Processes CPU command to see what that says? It may point towards the specific process that is causing the high CPU utilisation.

Hope this helps,

Jonathan

New Member

Re: CPU high utilization

thanks for your reply

except below process all other process seems normal

133    51062274   8261056       6181 12.19% 12.81% 12.78%   0 Hulc LED Process

Re: CPU high utilization

Hi,

I have found the following post which relates to the LED Process:

https://supportforums.cisco.com/message/608643

Seems that the percentage you are seeing is considered normal behaviour with regards to the Hulc LED Process on a 2960, are you noticing any performance problems that you think may be related to the CPU utilisation?

Many thanks

Jonathan

New Member

Re: CPU high utilization

Hi.

We have same problem.

We installed six 2960S.

All switch is high CPU.

CPU utilization for five seconds: 63%/40%; one minute: 44%; five minutes: 59%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
   1           0         7          0  0.00%  0.00%  0.00%   0 Chunk Manager   
   2        7233    395600         18  0.00%  0.00%  0.00%   0 Load Meter      
   3        2460      1250       1968  0.00%  0.00%  0.00%   0 SpanTree Helper

I think maybe IOS bug.

We plan to upgrade IOS to 12.2(55)SE.

If we sloved this problem and I will tell you.

thanks.

New Member

Re: CPU high utilization

Hi JunKun Kwon,

the upgrade to IOS 12.2(55)SE. did this solve the issue on the 2960s?

Kind regards,

Matthias

JunKun Kwon

New Member

Re: CPU high utilization

Hi, Maker.

We plan to upgrade Nov.18.

Using six 2960-S is high CPU.

We buy two new 2960-S.

But this swich idle status is nomal CPU.

So, we testing more now before upgrade to 12.2(55)

Cisco Employee

Re: CPU high utilization

Hi JunKun,

You might be running into one of these 2 bugs:

CSCtg86211    Hulc LED Process uses 6-15% CPU on Catalyst 2960/2960S 24/48-port switch

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCtg86211

-> expected behaviour

CSCth24278 Bug Details High CPU when no Console/VTY activity

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCth24278

-> will be in next 12.2SE release, 12.2(58)SE

Rgds,

Tom

New Member

Re: CPU high utilization

Hi JunKun,

how was the upgrade? Did it solve the issue?

Kind regards,

Matthías

New Member

Re: CPU high utilization

Hi maker.

I had case opened for this issue.

When I receive an answer from Tac.

I will tell you.

Thanks.

New Member

Re: CPU high utilization

Hi, maker.

I was received result of this case from TAC.

See the below.

--------------------------------------------------------------------------------------------------------------------------------------

Bug still keep Release-Pending.

It means our Development Engineer keep on touch this issue and investigate further.

Regarding to the bug, I was just informed that the fix for this issue

will be integrated in 12.2(58)SE, and the approximate time is March,2011.

What’s more, the issue is cosmetic and has no impact to the system's

functionality and performance, according to the confirmation from our Develop team.

--------------------------------------------------------------------------------------------------------------------------------------

Thanks.

Cisco Employee

Re: CPU high utilization

Correct JunKun,

this is purely cosmetic issue.

Have verified this as well in lab,

and this is also explained on the bug details on CCO:

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCth24278

Tom

New Member

Re: CPU high utilization

Thank you, Tom.

New Member

Re: CPU high utilization

I have tried 12.2 58 version on 2960S. High CPU Utilisation issue is fixed but there is another problem. Master reloads when we have SSH and Login Banners turned on. I disabled the banner which stopped rebooting the master but it started again.

Looks like 12.2 55 and 58 both are not stable versions.

Not sure which IOS to use now. Any suggestion?

Cisco Employee

Re: CPU high utilization

You can try 12.2(58)SE1. 12.2(58)SE got deferred yesterday.

HTH,

jerry

New Member

Re: CPU high utilization

Thanks jeye.

I'll try.

New Member

Re: CPU high utilization

Thanx Tom. I have been running 58SE1 for a month with no issues.

Cisco Employee

Re: CPU high utilization

FYI: This is:

CSCto62631    12.2(58)SE crashes on second SSH session when banner is enabled

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCto62631

indeed 58SE1 has the fix

New Member

Hi friend,

Hi friend,

I got high CPU utilization for the process Hulc LED Pro and it's always high for a long time

Is there any bug hitting for the IOS 

how can i get rid of this problem?

any help would appreciable .

the logs are

SW5#show processes cpu | ex 0.00
CPU utilization for five seconds: 82%/33%; one minute: 82%; five minutes: 87%
PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
45 9315208 52503688 177 1.75% 1.45% 1.51% 0 Net Input
53 6268876 386239552 16 0.47% 0.12% 0.10% 0 DownWhenLooped
69 12859754 187938145 68 0.15% 0.07% 0.11% 0 RedEarth Tx Mana
74 67204962 956595118 70 0.63% 0.43% 0.36% 0 Fifo Error Detec
105 16480672 20214830 815 0.31% 0.37% 0.36% 0 hpm counter proc
133 83973414 504307953 166 32.90% 33.47% 33.88% 0 Hulc LED Process
142 33521049 4039068 8299 0.31% 0.17% 0.16% 0 HQM Stack Proces
165 9395187 201949573 46 0.79% 0.30% 0.30% 0 UDLD
183 385 229 1681 0.15% 0.01% 0.01% 1 Virtual Exec
201 29114634 35845034 812 0.15% 0.16% 0.15% 0 Spanning Tree
223 41728709 42681366 977 4.15% 4.05% 4.80% 0 IGMPSN
230 32514585 44302472 733 0.47% 0.46% 0.60% 0 Marvell wk-a Pow

SW5#show version
Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 15.0(2)SE6, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2014 by Cisco Systems, Inc.
Compiled Wed 09-Apr-14 03:40 by prod_rel_team

ROM: Bootstrap program is C2960 boot loader
BOOTLDR: C2960 Boot Loader (C2960-HBOOT-M) Version 15.0(2r)EZ1, RELEASE SOFTWARE (fc2)

SW5 uptime is 33 weeks, 2 days, 23 hours, 17 minutes
System returned to ROM by power-on

Thanks in advance

6021
Views
0
Helpful
18
Replies
CreatePlease to create content