Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CRC Errors and Loss of Packets

Hello everyone,

I am experiencing a weird problem concerning heavy loss of packets and CRC errors.

I have a 2811 router connected to a 3560 switch. the connection is a standard staright cable connected between the fastethernet of the router and the gigabitethernet on the switch.

The speed and duplex settings on both sides were set to "auto" and was working fine.

Suddenly, the uplink on the router side started generating CRC errors which made users connected to the switch suffer connectivity issues. Even hard-coding the speed/duplex on both sides still doesn't solve it.

I used to get duplex error messages, I don't anymore but the problem remains

I tried all possible settings, even changed the cable, switch then even changing the router itself.

When I open a ping session from the HQ router to the remote site router's LAN interface, there is a huge loss of packets, same thing happens when pinging the switch's uplink interface.

The problem is solved momentarily by connecting both ends of the uplink to fastethernet ports.

However, I am not sure of the cause given that the exact configuration/IOS/Hardware model exists and continues to operate fine at other remote sites.

I need to know what caused this sudden loss of service.

which hardware is faulty or is it a software problem although

Your response is highly appreciated.

Thanks,

Ahmed El-Eraky

7 REPLIES

Re: CRC Errors and Loss of Packets

CRC errors generally indicate a faulty cable or a a bad ethernet controller

What do you see whene you issue the command

sh controller ethernet-controller

Narayan

New Member

Re: CRC Errors and Loss of Packets

hey Narayan,

Thanks for your prompt response.

Actually, I changed the cable tens of times. I even changed it to a short STP cable, but still no change.

I issued the "show interface fa0/1" on the router's end, and I got CRC and frame errors.

Like I said, when using that same cable but connecting both ends to fastethernet ports on both ends (on the same router and switch), I get no errors at all, and everything works perfectly.

Can you help me with that?

thanks,

Ahmed El-Eraky

New Member

Re: CRC Errors and Loss of Packets

Forgot to attach the output..:)

Thanks.....

Purple

Re: CRC Errors and Loss of Packets

Can you post the config of both interfaces as they are now ? It certainly looks like one side is half duplex .

New Member

Re: CRC Errors and Loss of Packets

Okay,

the configuration on the router's side

!

interface FastEthernet0/1

description To Switch

ip address 192.168.15.2 255.255.255.128

ip route-cache flow

duplex auto

speed auto

!

and the configuration on the sitches side is:

!

interface GigabitEthernet0/1

description Uplink To Router

speed 100

!

Note that setting the speed to auto doesn't help either.

Hard-coding both sides with "speed 100" or "duplex auto" or "duplex auto" didn't do much good either.

Thanks...

Ahmed El-Eraky

New Member

Re: CRC Errors and Loss of Packets

Tough problem, huh?....

Really appreciate the help....

Purple

Re: CRC Errors and Loss of Packets

The ends have to match , the switchside currently does not match the as auto . Set both the speed and duplex to auto on the switchside then bounce the port and let it negotiate the link.

224
Views
0
Helpful
7
Replies