Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Creating a subinterface - Help

Hi

I have a router doing some routing this is connected to an access switch port, I would like to add a subinterface to it can someone help me with setting it up as I've never done this before.

Here are the details

Router:

interface FastEthernet0/0

ip address 10.32.1.3 255.255.255.0

duplex auto

speed auto

standby 32 ip 10.32.1.1

standby 32 priority 110

standby 32 preempt

standby 32 track FastEthernet0/1 30

exit

Switch

interface GigabitEthernet2/0/48

switchport mode access

spanning-tree portfast.

I want to create a fa0/0.0 interface, is that possible on a 2800 router? When I initially created it I lost connection to the router, here's what I added:

int fa 0/0.0

ip address 10.32.50.0 255.255.255.0

exit

Could I have lost connection to the router becuase the switch is set as access mode instead of trunk?

After a short while I tried the same thing above but this time just did the below:

int fa 0/0.0

Description Test interface

exit

But when I run "show run" I can't see this interface anywhere it only shows me fa0/0 and fa0/1. Any thoughts?

Also I then thought let me add the address "10.32.50.0 255.255.255.0" again but this time the router says "Bad mask /24 for address 10.32.50.0". Any thoughts on this?

Thanks in advance

Dan

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: Creating a subinterface - Help

6 REPLIES
Hall of Fame Super Silver

Re: Creating a subinterface - Help

Hello Dan,

use the following examples adapt to your scenario

router side:

use two subinterfaces with different vlan-id and remove ip address from main interface

int f0/0

no ip address

int f0/0.10

enc dot1q 10

ip address 10.32.50.1 255.255.255.0

int f0/0.20

enc dot1q 20

ip address 10.32.60.1 255.255.255.0

switch side:

int f0/15

switchport

swithcport trunk enc dot1q

swithcport mode trunk

switchport trunk allowed vlan 10,20

>> he address "10.32.50.0 255.255.255.0" again but this time the router says "Bad mask /24 for address 10.32.50.0". Any thoughts on this?

this is the subnet address and cannot be used for any host including a router interface (all 0 in host portion)

Hope to help

Giuseppe

Hall of Fame Super Blue

Re: Creating a subinterface - Help

Blue

Re: Creating a subinterface - Help

New Member

Re: Creating a subinterface - Help

Hi,

Thank you all for this. Can someone suggest how I can do this remotely? I.e the exact process to take without losing connection?

Thanks

Dan

Hall of Fame Super Blue

Re: Creating a subinterface - Help

Dan

You need to access the router through another interface ie. not fa0/0

If you can do thiss log onto the switch and change the port to a trunk port first. Be aware that as soon as you do this you will lose connectivity between the switch and the router. Then configure fa0/0 interface as described and it should start communicating again.

Jon

New Member

Re: Creating a subinterface - Help

Ahh, so that's a problem as I onlyt have one link to this site and it's this link that's going to be dropped. I'll find a way round somehow. Appreciate the info though.

Thanks

Dan

640
Views
0
Helpful
6
Replies