Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Data and Voice VLAN Config

hi all,

just a quick question, can the below config be converted on a cisco switch port.

INITIAL CONFIG:

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 2  

switchport mode trunk  

switchport voice vlan 1  

no mdix auto

spanning-tree portfast

CONVERT TO:

interface FastEthernet0/1

switchport access vlan 2  

switchport mode access

switchport voice vlan 1  

no mdix auto

spanning-tree portfast

Everyone's tags (4)
3 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Bronze

Data and Voice VLAN Config

I don't see why not.

Data and Voice VLAN Config

Yes that is how we setup our ports:

interface FastEthernet0/3

switchport access vlan 10

switchport mode access

switchport voice vlan 20

switchport port-security maximum 2

switchport port-security maximum 1 vlan access

switchport port-security

switchport port-security aging time 1

switchport port-security violation restrict

switchport port-security aging type inactivity

no logging event link-status

srr-queue bandwidth share 1 30 35 5

priority-queue out

mls qos trust cos

auto qos trust

spanning-tree portfast

Cisco Employee

Data and Voice VLAN Config

Hi, Yes you can use this configuration to connect your workstation(DATA) to switch via IP phone(voice).

In this configuration the workstation would utilize the data vlan and the IP phone would utilize the data vlan first and then the voice vlan.

Thanks.

7 REPLIES
Hall of Fame Super Bronze

Data and Voice VLAN Config

I don't see why not.

Data and Voice VLAN Config

Yes that is how we setup our ports:

interface FastEthernet0/3

switchport access vlan 10

switchport mode access

switchport voice vlan 20

switchport port-security maximum 2

switchport port-security maximum 1 vlan access

switchport port-security

switchport port-security aging time 1

switchport port-security violation restrict

switchport port-security aging type inactivity

no logging event link-status

srr-queue bandwidth share 1 30 35 5

priority-queue out

mls qos trust cos

auto qos trust

spanning-tree portfast

Cisco Employee

Data and Voice VLAN Config

Hi, Yes you can use this configuration to connect your workstation(DATA) to switch via IP phone(voice).

In this configuration the workstation would utilize the data vlan and the IP phone would utilize the data vlan first and then the voice vlan.

Thanks.

Bronze

Re: Data and Voice VLAN Config

Apart from the answer "yes" to your question:
it is not custom to use vlan 1 as voice vlan
Vlan 1 is default used for many other packets too

Sent from Cisco Technical Support iPad App

Re: Data and Voice VLAN Config

thank you guys for your feedback! +5

i just wanted to confirm before i go and make changes (although deep in my head i already know).

pieterh,

yes, from a security standpoint i understand. but the network is already in place (a long time ago) and it would be a major change just to change VLAN 1.

Hall of Fame Super Gold

Data and Voice VLAN Config

no mdix auto

It will work, John but I question the "sanity" of this line.

I do not see the benefits gained by disabling MDI/MDI-X. 

Data and Voice VLAN Config

thanks pre for spotting this!

good stuff! (as what my australian boss tells me).

maybe i can enable mdix back.

i'm not sure why the previous admin did this.

274
Views
9
Helpful
7
Replies
CreatePlease to create content