Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Day from Hell...!! :-(

Hi Peeps,

Wondering if anyone could offer me any Pearls of Wisdom...?

Have been working at a customers site today to connect a fibre link between 2 joined buildings.  Connected the SFP and Fibre etc.. and no issues.  when I came to patch the Switch in the main building to their current Network, all Internet access was lost.  On closer inspection it appears that Spanning Tree had blocked both the port in the Access switch that I had connected my fibre connected Switch to and also the Uplink from the Access Switch to the downstairs Comms cab where the Router is.  I removed the Fibre and all other connections until I only had 1 patch cable from a trunk port on my Fibre connected Switch to the Uplink port on the Cisco Switch but again same thing.  I can't understand how there could be a loop when I only have 1 cable connected.

The other problem I have is that my fibre connected switch is a 3com 2928 sfp plus (limited cli options) and the Access switch is a Cisco 500 Series which denies me access to the CLI and has no console port.  I have tried turning off STP on the Cisco 2960 that is the uplink for the Acess Switch but this has made no difference.

There were a couple of other Switches (Avaya) that I tried using the LAN port to test and same thing happened... to make things worse this was taking place in a Roofspace in 27 degree heat whilst kneeling to use my laptop and I have to go back on Monday :-(

Any ideas anyone can offer would be gratefully accepted and thanks for taking the time to read this

Mark

4 REPLIES

Re:Day from Hell...!! :-(

Hello

Bit hard to understand this topology but could you post the config of the access switch and the core

A couple of things:

Does the new switch have stp applied and is the core switch defined to be the to be stp root?

Also the upland interface is set as a trunk as is the core interface?

Also is bpduguard disabled on these ports?

Res
Paul





Sent from Cisco Technical Support Android App

Please don't forget to rate any posts that have been helpful. Thanks.
Cisco Employee

Day from Hell...!! :-(

Hi Mark,

Absolutely agree with Paul's suggestions. Some command outputs are essential for us to understand what could have gone wrong, as there are many protections on Cisco switches that could keep the STP or some other subsystem blocking the ports.

I am not sure if you can repeat the experiment but these would be the outputs that are of utmost importance:

show spanning-tree

show spanning-tree summary

show spanning-tree inconsistent

show interfaces status

show interfaces status err-disable

Trying to guess what could have happened is, at this point, quite difficult.

Best regards,

Peter


New Member

Day from Hell...!! :-(

Hi Both,

Thank you for taking the time to reply...  the Topology basically is a Comms Cab in the main building trhat houses 2 routers, Cisco 870 i think for Internet access and an Cisco 877 that handles a site to site VPN.  There is also a Cisco 500 Series Express Switch that has the Servers attached and a Fibre uplink to the Roofspace.

The Roofspace has a couple of Avaya Switches for the Voip and another Cisco 500 Series Express and Cisco 2960 Series Switch for Access Layer.  This is where I am trying to connect a factory reset 3com 2928 sfp plus switch that houses a fibre uplink to a new building that will have another 3com 2928 at the other end to accomodate the the machines that will reside in the new building. (These 3com Switches were already owned by the Customer).

If I plug the 3com to any of these other Switches STP seems to block the 3com and also one of the uplinks as nobody can access the Internet and external ping times out.  I tried to turn off STP globally on the 2960 as a test but no change.  It's made worse by no CLI on any of the 500 Series Switches and very limited on the 3com.  The only CLI really is on the 2960.  Currently STP is on all Cisco and 3com Switches as I wasn't really happy turning it off on all Switches to test  just in case.

I will run the Commands you suggest on the 2960 to see if I can get any further info as to where exactly the issue lies.

I also only have a patch cable not a crossover but have been relying on the Mdix to compensate, Speed and Duplex are Auto.

I appreciate the assistance offered by you both and will be trying again in a few hours....

Many Thanks

Mark

Day from Hell...!! :-(

Hello Mark

It sounds like you are installing this 3com switch into a cisco 2960- if this is the case, need to make sure a couple of things:

1) the link between the two switches need to be able to carried all the vlans in your estate, so as stated previously they need to be trunked, and if you have reset the 3com that means you need to manually create all the other vlans currently running on the other switches to the 3com ( apart from vlan 1)

2) This 3com switch will default to a bridge priority of 32768, now if you haven't specified any stp root in you estate or left them to defaults you could have  a potential for this new devcie becoming an stp root switch, so I would advise before adding it to the live environment, change its bridge priority higher then 32768 - something like 65536, additionally on all the access ports apply stp bpduguard.

Can you also post the output from the commands peter stated in his post.

res

Paul

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.
271
Views
15
Helpful
4
Replies
CreatePlease to create content